Boot question

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Boot question
# 1  
Old 02-07-2002
Question Boot question

Hey all,

Just wondering about to things with the bootup.

First one is. When you boot Solaris, the background is white and text black. Is it possible to change this so that the text it white and background is black? I don't have any idea how to do this one. So if anyone does please let me know or post a link to where I can read up about it!

Secondly. When you boot up (I'm running Solaris 7) after boot it dumps you into a login screen (Duh! need to login in. Right) Well I want to bypass this screen and make it automatically login into one of my users. So when ever the computer gets turned on they are the user that are logged in right way. Yes I will note I am aware of security issues but it's no factor with the computers!

Thx in advanced if anyone can help me!
# 2  
Old 02-07-2002
For your second question - I'm not sure if this will help but there was a requirement for folks who had SUN systems on their desktop to go straight to a login on a HP server.

Dtlogin was changed (S99dtlogin in /etc/rc2.d) as follows:
case "$mode" in


if [ -x /usr/dt/bin/dtlogin ] ; then
# Old default
# /usr/dt/bin/dtlogin -daemon &

# To get from Prism
/usr/openwin/bin/Xsun -query prism &


You could probably change it in the same way to login.
# 3  
Old 02-07-2002
I haven't tried this - up to you if you want to try it!

found on sunsolve - hopefully it copied ok:

Some users/customers who want to set the screen output off the fly at
the OBP level due to lighting considerations may try this out instead
of doing it in Solaris and SunOS which gives you limitations as the
reverse screen output only gets set once inittab or gettytab is initiated.
Look at SRDB's 3642, 3690 for the resolutions.

This workaround is better however as, once the system boots or is powered
on, it is already in reverse video mode.

This method enables reverse video mode which sets white letters
on a black background.
Problem Solution Top

You have two methods here, and either one will work:


At the OBP (Open Boot PROM) level:

ok nvedit
0: d# 27 emit ." [q"
ok nvstore
ok setenv use-nvramrc? true
ok reset

This has been tested to work OK on OBP Versions 2.X and 3.X and may still
work on the 1.X's.


If an existing nvramrc data exists you can
edit the following into nvramrc via nvedit:

ok> nvedit

0: probe-all
1: install-console
2: banner
3: : rev-video
4: d# 27 emit ." [q"
5: ;
ok> nvstore
ok> setenv use-nvramrc? true
ok> reset

Then to reverse video enter:

ok> rev-video

In this scenario any existing nvedits will be there and
rev-video is the only {nvedit call} that will get executed.

To reset the video back to it's default:
Either do the following:
Use nvedit once more and remove the line for the reverse video setting.
Disable the nvram data via ok> setenv use-nvramrc? false
Soft reset to default nvram settings via ok> set-defaults
(This will wipe out any other customized parameters within the
nvram like nvalias'es or nvram data)
Hard reset to default nvram settings via power-cycling while holding
down to the 'Stop' and 'N' keys.
(This will wipe out any other customized parameters within the
nvram like nvalias'es or nvram data)

NOTE: If you have any previous data in your nvramrc other than the
reverse video settings, you will probably have to re-enter this again
via nvedit. Both methods work for any OBPrev's starting from 2.0 or higher.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Question about Volume Boot Record

Hello and thanks in advance for any help anyone can offer Hopefully this is a simple question but is the Volume Boot Record (VBR) only used in Windows? I've seen references to it in relationship to Windows & not Linux... but I'm not sure if that means it's unique to Windows or not. If it is... (1 Reply)
Discussion started by: bodisha
1 Replies

2. Solaris

Solaris 2.4 boot question

Hi Guy's, Newbee here. I installed Solaris 2.4 in VMWare Fusion 5.0.2 on a MacBook Pro. All went well, but after 'system ready' I get a 'console login' prompt. But I never got to the point where I could set a name and password for that. I can login as root. But that's all. How do I get to... (7 Replies)
Discussion started by: hansolo
7 Replies

3. Solaris

Solaris x86 installation using jumpstart does not local boot ( boot from hdd)

I am trying to install Solaris x86 using the Jumpstart server. I run the add_install_client command with appropriate options, and reboot my x86 Target box. The installation starts fine and unattended. After the installation completes and the target goes for a re-boot, it does not boot from the HDD... (9 Replies)
Discussion started by: hemalsid
9 Replies

4. Boot Loaders

Reboot and Select Proper Boot device or insert Boot media in select Boot device and press a key

Hello, I have kubuntu on my laptop and now I decided to switch to Windows 7. I made the bios settings properly (first choice is boot from cd\vd) but I see the error " reboot and select proper Boot device or insert Boot media in select Boot device and press a key " I have tried CD and... (0 Replies)
Discussion started by: rpf
0 Replies

5. Solaris

Boot question

I have to install Solaris 10 (for x86 CPU) on my pc. How can I do a dual boot solaris and Windows 7, on the same hard disc? I searched here, but it works with windows NT, not Seven. May I use a bootloader? How I can do it? Thank you in advance for any answer! :) (12 Replies)
Discussion started by: mghis
12 Replies

6. Filesystems, Disks and Memory

Question - error during boot

I have an HP NetServer LH3 which is exhibiting an error during the boot process. I am getting the following messages, none of which I've seen before 1. WARNING: SCSI adapter: Cannot install intr vecno=12 type=4 IPL=5 Vector 12 is private 2. WARNING: "TEST_UNIT_READY" Command timed 11 seconds... (0 Replies)
Discussion started by: slant-40
0 Replies

7. Solaris

question about opb boot device

hi all: I have a sun blade-1000 for labs only, with 73G hd loaded, which boot block installed on slice 0. I'm confused by setting "boot-device" value in obp, which my question as follow: in ok mode, I got device alias like this: disk0: /pci@8,600000/SUNW,qlc@4/fp@0,0/disk@2,0 as I know the... (4 Replies)
Discussion started by: netshu
4 Replies

8. Solaris

solaris boot problem boot error loading interpreter(misc/krtld)

When I installed the SOLARIS 10 OS first time, the desktop would not start up, this was because of network setup. Reinstalled worked. After a week due to some problem I had to reinstall OS, installation went fine and but when i reboot I get this error. cannot find mis/krtld boot error loading... (0 Replies)
Discussion started by: johncy_j
0 Replies

9. UNIX for Advanced & Expert Users

Cannot boot - Boot : Panic : File size out of range (EWS-UX/V unix)

Hey ! I am running EWS-UX/V (Rel 4.2) on NEC EWS/4800/330 station and I am having problems rebooting my station : I am getting the following message on display : BOOT : PANIC : File size out of range. According to user guide, this error is occuring when a file exceeding the limit and/or... (2 Replies)
Discussion started by: fredo
2 Replies

10. UNIX for Dummies Questions & Answers

another dual boot question/problem

Well, I formatted my entire harddrive (40gig), partitioned it into three partitions, FAT32 for WindowsXP (30 gig), Linux ext3 (7gig), and Linux swap (about 500mb). All this with PartitionMagic 8.0 and it took hours. After all that, I installed the "publishers version" of Red Hat with ease. I was on... (12 Replies)
Discussion started by: chutt
12 Replies
Login or Register to Ask a Question