Visit Our UNIX and Linux User Community


Cron job not working


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Cron job not working
# 1  
Old 10-25-2007
Cron job not working

Hello, I have the following crontab entry that does not seem to be running. When I check /var/cron/log, it is not there. Here is my os info:

SunOS birch 5.9 Generic_118558-09 sun4u sparc SUNW,Sun-Fire-V240

Here is the crontab entry:
01 21 * * * find /export/app/datafeed/flus/archive -mtime +5 -exec rm -r {} \;
Any suggestions as to why it is not executing?

Thank you.

David
# 2  
Old 10-25-2007
Few questions to check:

Were there files with specified condition to be deleted ?
Are there necessary permissions to delete the selected files ?
# 3  
Old 10-25-2007
The files are owned by the same user in which the crontab entry is located. Shouldn't there be logging on /var/cron/log if it attempted to run? There may not have been files old enough to be deleted at the time it was run last.


David
This User Gave Thanks to dkranes For This Post:
# 4  
Old 10-25-2007
test it by printing

For testing , U make one more entry in crontab to list those filenames which are modified morethan 5 days like this.

01 21 * * * find /export/app/datafeed/flus/archive -mtime +5 -print >$HOME/test.log

U check whether test.log is created or not.if it is created means cron is working, otherwise not.
# 5  
Old 10-25-2007
On just a point of style and manageability, I make my crontab entries call a single script, then have the script do all the fancy foot work.

1. it means I can simply add any tracing I need

2. it means I can test exactly the same thing outside of crontab

3. my crontab contains the minimum, eg when and what command
# 6  
Old 10-26-2007
Yes, I have now done just this. I created a single script to do the work. Thank you.

David
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #640
Difficulty: Medium
After the purchase of NeXT by Apple, NeXT became the source for macOS, iOS, watchOS, and tvOS.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Cron job - Need to run Cron every quarter at particular time

Hi, 1) If some job supposed to run on 1st of every month at 7 AM In cron job when we have a blackout on the 1st ( i.e when 1st falls on a sunday ) how can we make the job run the next business day? 2) How can we run a job on 25th of every quarter 7 AM(jan,apr,jul,oct) And if 25th... (5 Replies)
Discussion started by: System Admin 77
5 Replies

2. Shell Programming and Scripting

Crontab - entry not working , cron job not running

I have put a cron entry in oracle user for taking hot backup every wednesday@ 2.30 AM and have given the cron entry 30 02 * * 3 /u01/vijay/hotbackupcron 2>&1 >> /u01/vijay/hotbackup.log also find below the script inside hotbackupcron, i have put in env variables as well ... (13 Replies)
Discussion started by: vijaymec50
13 Replies

3. AIX

Cron job not working but works on other nodes.

Hi All, I have a many cron jobs scheduled in my AIX server. Only one cron not getting executed in the same server but that job is good on all other servers. Here is my cron , which will keep last 30 files and remove others., 00 00 * * * /usr/bin/find /tmp/reports/nmon -name *.nmon -mtime... (9 Replies)
Discussion started by: Thala
9 Replies

4. UNIX for Dummies Questions & Answers

Cron job not working

cron process in AIX is there when I do ps -ef |grep cron, but none of cron job is working. It appears that cron process is hanging or having some issues? How do you resolve this? Do I kill the cron process by kill -9 PID? and how to start it? Please advise. (1 Reply)
Discussion started by: Daniel Gate
1 Replies

5. Shell Programming and Scripting

Cron job is not working in the desired manner on IBM AIX

Hi, I have created a cron job on IBM AIX but it is not working in desired manner ! Here are the steps which I have followed :- #!/bin/ksh #------------------------------------------------------------------ find /some/file/at/the/user/side/test.log -exec cp {}... (8 Replies)
Discussion started by: acidburn_007
8 Replies

6. Shell Programming and Scripting

cron job now working?

Hi all, I wrote a script as below, #!/bin/ksh . /app/home/etc/sudo.profile >/dev/null java -jar $HOME/abc.jar The jar file abc.jar is located in the same folder as the script. When I'm manually running that script the jar file gets executed. However if I set a cron job, it... (5 Replies)
Discussion started by: isaacniu
5 Replies

7. Shell Programming and Scripting

cron job is not working for two scripts

Hi Gurus, I have a test unix server in which currently some unix cronjob are running. I have written two script one is a shell script in which env variable are there (in that i am exporting those variables). I have also written a perl script . when i am running at the shell manually like... (5 Replies)
Discussion started by: sanjay.login
5 Replies

8. Shell Programming and Scripting

Sudo command not working with cron job.

Hello, I have written a script that has a sudo command to change file permissions within it. When I run the script manually, the sudo command inside of it works fine. When the script is run through crontab I get the error "cron: not found". It the same user profile that I am using... (6 Replies)
Discussion started by: WhotheWhat
6 Replies

9. Shell Programming and Scripting

cron job not working for some reasons

I set up a new cron job. I have set cron jobs many times in the past and never faced issues. For some reasons my new cron job is not working.This is how my cron job looks like. plz help me out guys. 3,8,13,18,23,28,33,38,43,48,53,58 * * * * /siebel/sblp900/home/FSMTaskChk/script... (14 Replies)
Discussion started by: ragha81
14 Replies

10. Shell Programming and Scripting

Cron job not working

Hi All, I created a shell script and it works perfectly fine when I run from the command. But the same does not work as expected when I call it from a cron job. Here is the shell script(scan.sh): # # #Which directory to scan for files?... (7 Replies)
Discussion started by: janavenki
7 Replies

Featured Tech Videos