Visit Our UNIX and Linux User Community


Mounting on boot up


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Mounting on boot up
# 1  
Old 02-07-2002
Bug Mounting on boot up

Is there a recognised way of mounting drives/network connections on bootup?

I realise you can do this by adding the mount command to the 'bashrc' file, but for some rearon this does not seem to be the way i would expect you are supposed to do it.

Cheers!

Nic
# 2  
Old 02-07-2002
more info

Please give us more information about your system.
uname -a
regards joerg
# 3  
Old 02-07-2002
Yeah sure - im running redhat linux (7.2) and basically want to mount my floppy + cdrom, and also mount a samba share to my win2000 machine so they are all available on boot up.
# 4  
Old 02-07-2002
Sorry

Sorry no linux admin !
Only unix solaris 2.x experience.
# 5  
Old 02-07-2002
Cheers

Cheers anyway mate!
# 6  
Old 02-07-2002
You want to modify the /etc/fstab file. Anything in there NOT listed as noauto should mount. But you may have problems if the resources aren't available... What I would do if list them in there as noauto, then bring them up manually...

For example, one line in my /etc/fstab might be:
/dev/fd0 /mnt/floppy defaults,noauto 1 1

At the command prompt, I can just type:
mount /dev/fd0
or in some case, just "mount fd0".

Check the man page for mount, and fstab for more info.
# 7  
Old 02-07-2002
Quote:
Originally posted by nicfellows
Yeah sure - im running redhat linux (7.2) and basically want to mount my floppy + cdrom, and also mount a samba share to my win2000 machine so they are all available on boot up.

Here is my /etc/fstab

/dev/fd0 /fl auto defaults,user,noauto 0 0

/dev/cdrom /cd iso9660 defaults,ro,users,noauto 0 0


and when I want to mount CDROM or Floppy I just type mount /cd or mount /fl. option user in /etc/fstab alows anyone to mount the device.

BTW You can try to mount CD or floppy by bootup by replacing option 'noauto' with 'auto'. And mounting floppy and cdrom on boot is bad idea as system will hang for few minute(s) if tray is empty
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #371
Difficulty: Medium
PHP opcodes are generated each time the program is launched and are always interpreted and not just-in-time compiled.
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Help mounting nfs on boot on Solaris 11

Hello, I am looking for some assistance in mounting an nfs drive on boot, on a Solaris 11 machine. On my Solaris 9/10 machines, I have an entry for my nfs mount in /etc/vfstab, however when I add the same entry to my vfstab on Solaris 11, the drive will not mount on boot. After booting up, I... (5 Replies)
Discussion started by: bstring
5 Replies

2. Solaris

Solaris x86 installation using jumpstart does not local boot ( boot from hdd)

I am trying to install Solaris x86 using the Jumpstart server. I run the add_install_client command with appropriate options, and reboot my x86 Target box. The installation starts fine and unattended. After the installation completes and the target goes for a re-boot, it does not boot from the HDD... (9 Replies)
Discussion started by: hemalsid
9 Replies

3. Boot Loaders

Reboot and Select Proper Boot device or insert Boot media in select Boot device and press a key

Hello, I have kubuntu on my laptop and now I decided to switch to Windows 7. I made the bios settings properly (first choice is boot from cd\vd) but I see the error " reboot and select proper Boot device or insert Boot media in select Boot device and press a key " I have tried CD and... (0 Replies)
Discussion started by: rpf
0 Replies

4. SCO

stage 1 boot failure: error loading hd (40)/boot

hi SCO Unix 5.0.6 doesn't boot due to this problem: not a directory boot not found cannot open stage 1 boot failure: error loading hd (40)/boot Knows someone howto solve it? (16 Replies)
Discussion started by: ccc
16 Replies

5. Ubuntu

mounting shared folder at boot

Hi All Everytime a reboot my machine "hostB" I have to mount a shared (with machine "hostA" ) NFS folder giving this command sudo mount hostA:/sharedFolder /sharedFolder How to use fstab in order to do this automatically? I should say hostA:/sharedFolder /sharedFolder ... (0 Replies)
Discussion started by: manustone
0 Replies

6. Solaris

Mounting disk at boot

Hi once more :p Yesterday I reinstalled Solaris OS and now I can not mount pcfs HDD SunOS unknown 5.10 Generic_142901-03 i86pc i386 i86pc and what has been added in /etc/vfstab is /dev/dsk/c1t0d0p1:c - /podaci - pcfs - yes rw But as I said , my disk is... (4 Replies)
Discussion started by: solaris_user
4 Replies

7. Solaris

cannot find boot device and won't boot off cdrom

I'm running solaris 2.5.1. My main development server is DEAD, i can't even boot off the cdrom, it powers up, acts like it is starting the boot process but then says cannot find boot device. I've done the search here on this site and saw the other posts, but at the ok prompt it won't even let me... (3 Replies)
Discussion started by: kymberm
3 Replies

8. Solaris

solaris boot problem boot error loading interpreter(misc/krtld)

When I installed the SOLARIS 10 OS first time, the desktop would not start up, this was because of network setup. Reinstalled worked. After a week due to some problem I had to reinstall OS, installation went fine and but when i reboot I get this error. cannot find mis/krtld boot error loading... (0 Replies)
Discussion started by: johncy_j
0 Replies

9. UNIX for Advanced & Expert Users

Cannot boot - Boot : Panic : File size out of range (EWS-UX/V unix)

Hey ! I am running EWS-UX/V (Rel 4.2) on NEC EWS/4800/330 station and I am having problems rebooting my station : I am getting the following message on display : BOOT : PANIC : File size out of range. According to user guide, this error is occuring when a file exceeding the limit and/or... (2 Replies)
Discussion started by: fredo
2 Replies

Featured Tech Videos