/home locked

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers /home locked
# 1  
Old 01-22-2002
/home locked

Hi all,

Does anyone knows why can't I change the /home dir in to writeable?

here is what I get ?

dr-xr-xr-x 1 root root 1 Jan 22 10:09 xfn
dr-xr-xr-x 1 root root 1 Nov 28 16:11 home
dr-xr-xr-x 1 root root 1 Nov 28 16:11 net
dr-xr-xr-x 6 root root 512 Nov 28 16:12 vol
dr-xr-xr-x 125 root root 480032 Jan 22 11:08 proc
drwx------ 2 root other 512 Nov 15 12:38 Mail
drwx------ 2 root other 512 Sep 13 14:20 nsmail
drwx------ 2 root root 8192 Sep 13 12:12 lost+found
drwxr-xr-x 2 root other 512 Nov 23 10:17 ANP
drwxr-xr-x 2 root root 512 Sep 26 11:30 TT_DB
drwxr-xr-x 2 root sys 512 Sep 13 12:16 mnt
drwxr-xr-x 2 root sys 1024 Sep 13 12:19 sbin
drwxr-xr-x 3 root nobody 512 Dec 14 12:22 cdrom
drwxr-xr-x 3 root sys 512 Sep 13 12:15 export
drwxr-xr-x 4 root sys 512 Sep 13 12:32 devices
drwxr-xr-x 5 root other 512 Jan 22 10:25 MagellanNMS
drwxr-xr-x 9 root sys 512 Sep 13 13:15 kernel
drwxr-xr-x 14 root sys 4608 Sep 26 11:29 dev
drwxr-xr-x 29 root sys 1536 Sep 13 12:32 platform
drwxr-xr-x 32 root sys 512 Sep 13 12:59 var
drwxr-xr-x 36 root sys 1024 Sep 21 10:41 usr
drwxr-xr-x 41 root sys 3584 Jan 22 11:03 etc
drwxrwxr-x 23 root other 512 Jan 11 10:07 opt
drwxrwxrwt 9 root sys 1828 Jan 22 11:05 tmp
lrwxrwxrwx 1 root root 9 Sep 13 12:16 bin -> ./usr/bin
lrwxrwxrwx 1 root root 9 Sep 13 12:16 lib -> ./usr/lib
total 1063
# chmod 644 /home
chmod: WARNING: can't change /home
# w
11:08am up 54 day(s), 18:58, 2 users, load average: 0.14, 0.11, 0.10
User tty login@ idle JCPU PCPU what
root pts/3 11:08am w
root dtremote 10:24am 44 6 2 /sbin/sh
root pts/1 10:55am 3 /sbin/sh

# 2  
Old 01-22-2002
Perhaps the root partition was mounted read-only?
# 3  
Old 01-22-2002
I see,

Here is a bit more information. I haven't seen this before. I don't understand. I am logged in as root.

# mount
/ on /dev/md/dsk/d0 read/write/setuid/intr/largefiles/logging/onerror=panic/dev=1540000 on Wed Nov 28 16:11:35 2001
/usr on /dev/md/dsk/d4 read/write/setuid/intr/largefiles/logging/onerror=panic/dev=1540004 on Wed Nov 28 16:11:37 2001
/proc on /proc read/write/setuid/dev=3fc0000 on Wed Nov 28 16:11:33 2001
/dev/fd on fd read/write/setuid/dev=4080000 on Wed Nov 28 16:11:38 2001
/etc/mnttab on mnttab read/write/setuid/dev=4180000 on Wed Nov 28 16:11:40 2001
/var on /dev/md/dsk/d2 read/write/setuid/intr/largefiles/logging/onerror=panic/dev=1540002 on Wed Nov 28 16:11:41 2001
/var/run on swap read/write/setuid/dev=1 on Wed Nov 28 16:11:41 2001
/tmp on swap read/write/setuid/dev=2 on Wed Nov 28 16:11:45 2001
/opt on /dev/md/dsk/d3 read/write/setuid/intr/largefiles/logging/onerror=panic/dev=1540003 on Wed Nov 28 16:11:45 2001
/export/home on /dev/md/dsk/d5 read/write/setuid/intr/largefiles/logging/onerror=panic/dev=1540005 on Wed Nov 28 16:11:46 2001
# pwd
# ls -la |grep home
dr-xr-xr-x 1 root root 1 Nov 28 16:11 home
# mkdir /home/test
mkdir: Failed to make directory "/home/test"; Operation not applicable

Can anyone help please?
# 4  
Old 01-22-2002
From the output of your mount command, it looks like you are using Solaris. On Solaris, /home is an automount mount point. If you aren't using automount, then mv /etc/auto_master to /etc/auto_master.orig (or a filename of your choice), then bounce automounter. You should now be able to mkdir in /home.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

cp -p /home/* home/exp/*.date not working please help

:( ---------- Post updated at 01:51 AM ---------- Previous update was at 01:50 AM ---------- Not working ---------- Post updated at 02:04 AM ---------- Previous update was at 01:51 AM ---------- cp -p /home/* home/exp/*.`date` i am using this (4 Replies)
Discussion started by: rishiraaz
4 Replies

2. UNIX for Dummies Questions & Answers

I have files that are locked up...

Here's the story: I had an LaCie Internet Space (1TB)... Recently the network (or software) functions of the device just died... I tried to access it via different routers, checking UTP, tried everything possible to rule out physical damage to components. Then i got the disk out of its... (2 Replies)
Discussion started by: SentinelX
2 Replies

3. UNIX for Advanced & Expert Users

Who locked my id?

I am running Solaris 10. Occasionally, my id gets loked. I want to know who/which rougue process locked it. How do I find out? Thanks, KNK (9 Replies)
Discussion started by: nkamatam
9 Replies

4. Solaris

how to change /export/home/user dir to /home /user in solaris

Hi all i am using solaris 10, i am creating user with useradd -d/home/user -m -s /bin/sh user user is created with in the following path /export/home/user (auto mount) i need the user to be created like this (/home as default home directory ) useradd -d /home/user -m -s /bin/sh... (2 Replies)
Discussion started by: kalyankalyan
2 Replies

5. Programming

how to simulate "mkdir -p /home/blah1/blah2/blah3" in "c" where only /home exist

I'm trying to make use of mkdir(char *pathname, S_IRWXU) to create the directories. but it only creates one directory at a time. so I have to separate the tokens for "/home/blah1/blah2/blah3" as "home blah1 blah2 blah3" using delimiter "/", but it is again hectic to create such directory... (8 Replies)
Discussion started by: platinumedge
8 Replies

6. Programming

Port is locked

Hi, I am working with sun solaris sparc 5.9 and I want to use the serial port in my application..when I am trying to use it.it is throwing the message-- So how can I check the serial port is locked or not and how can I unlock the port?? Thanks in advance. (1 Reply)
Discussion started by: smartgupta
1 Replies

7. AIX

account is always locked out

we have a user name "Test1" that account is alwyas locked out. The user has been used to many servers to ftp a file from the main server. i already increase the MaxStartups to 99. And still after how many days account will locked. (3 Replies)
Discussion started by: invinzin21
3 Replies

8. Solaris

need script for locked and unused user accounts in /export/home directory

Hi all, i have to need one script: 1. it will capture the unused user accounts in /export/home directory. 2. it will capture the locked user accounts in /export/home directory. Note: locked accounts will show in /etc/passwd like /bin/false --> (instead of ksh it will show false) the... (1 Reply)
Discussion started by: krishna176
1 Replies

9. HP-UX

locked out!

:confused: I have an K580 HP server. All I did was change the IP address on the NIC and now I can't telnet into it. I can ping, but no telnet. Also, it won't boot if the console monitor is plugged in. ANY IDEAS??? (1 Reply)
Discussion started by: ncmurf00
1 Replies

10. UNIX for Dummies Questions & Answers

OpenWin Locked up

I have a server that is on solaris 9 and openwin is locked. The mouse won't respond and I can't seem to kill the openwin pid on the server.. Is there a command line to kill openwin from the server side? (2 Replies)
Discussion started by: jphorton
2 Replies
Login or Register to Ask a Question