starting a server

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers starting a server
# 1  
Old 01-06-2002
Lightbulb starting a server

i am currently am planning to start a webserver to host a community of webpages, but i need help getting started? anyone have any sites or advice for me? thanks!
# 2  
Old 01-06-2002
A quick Google search on "Web hosting" will
get you a large list of web hosting possibilities
from domain name registration through to building
and deploying your web site. Some are free but
remember... "there's no free lunch".

If you are looking to build and deploy one on
your own, the most problematic issue you will
have is Internet connectivity. Assuming you have
registered your domain name, you'll need to get
your IP address(s) from your ISP. Depending
on your budget, you should be looking for
"business" access. By this I mean, if you web site
is going to be used for "business", most ISPs
require a business use type of account (vs. a
"home" use type).

The other issues are of course, the hardware, OS,
software, administration, backups, etc., etc.
Since you are posting on a UNIX forum, I will
assume you have a UNIX/Linux machine. I would
also recommend Apache with SSL and PHP along
with MySQL. These components will give you the
basic (IMHO) elements necessary for a minimally
full featured web site.

I could go on for many pages but I think you
get the drift.

Good luck to you. Smilie
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Windows & DOS: Issues & Discussions

Start X Server without starting a terminal

when I run C:\cygwin\bin\run C:\cygwin\bin\startxwin.exe it fires up a terminal by default. Can I eliminate that terminal and start the x server as a service silently and sits in my status bar just there? Thanks Jack (0 Replies)
Discussion started by: lucky7456969
0 Replies

2. Solaris

Web server cannot starting

hi guys i try to start my web server on solaris 10 with T2000 server, i have been already start but the status always maintenace. when i check logfile i have this messages when i exceute " svcs -l http" i have this output fmri svc:/network/http:apache2 name ... (10 Replies)
Discussion started by: audi_99
10 Replies

3. Solaris

Starting nfs/server

Hi, I do not get nfs/server started. bash-3.00# svcadm enable nfs/server bash-3.00# svcs -a |grep nfs disabled 21:44:36 svc:/network/nfs/cbd:default disabled 21:44:36 svc:/network/nfs/client:default disabled 21:44:51 svc:/network/nfs/rquota:default disabled ... (4 Replies)
Discussion started by: jld
4 Replies

4. UNIX for Advanced & Expert Users

Starting an Apache Server

Sir, I have installed an Apache server in Fedora 9 (packages) and when i go to etc folder and try the command httpd -k start it says command not found....can any one help me out!!! ---------- Post updated at 12:02 PM ---------- Previous update was at 11:46 AM ---------- When i... (4 Replies)
Discussion started by: bssandeshbs
4 Replies

5. Solaris

nfs/server not starting

Hi Gurus Sorry to ask this question again but left with no option I have entry in /etc/dfs/dfstab for resources which i am welling to shaer over the netwrok. Idelay once i execute shaerall it should enabel the nfs/server servcie in Solaris 10, however it was not stared and later i tried... (2 Replies)
Discussion started by: kumarmani
2 Replies

6. UNIX for Dummies Questions & Answers

Starting Server after losinf usr

Hi I accidentally deleted all the files in the /usr when I should have deleted files in usr1. Ever since I haven't been able to satrt my server which runs on Solaris 9 and SPARC engine. Can anyone help me to start the server and restore the rest of the services? (1 Reply)
Discussion started by: rahmantanko
1 Replies

7. Solaris

Starting NFS server Solaris 10

Whenever I start nfs/server using "svcadm -v enable" it appears to start up. But when I look for daemons such as nfsd I don't see any. So I checked the manifest logs for nfs/server and it's telling me the NFS service gets enabled and then immediately disabled with a stop 102. All the... (2 Replies)
Discussion started by: bdsffl
2 Replies

8. Solaris

x server starting problem

i have installed solaris 10 on PIII i Ghz cpu, whole installation carried out in GUI mode but after installation it is unable to start GUI mode. Error is : "X server can not be started on display 0" screed flickers twice and the CLI login prompt appears (1 Reply)
Discussion started by: ajays
1 Replies

9. HP-UX

The server is not starting all services

Hi everybody When I Boot/restart my HP-UX server when it reaches the step described below doesn't go through. When I kick a key in the console it show me the login prompt and a can log on but I cannot access the server from the network, I can only do it via LAN console. Please, can you help... (3 Replies)
Discussion started by: cgege
3 Replies

10. UNIX for Dummies Questions & Answers

starting jabber server on startup

Fedora Core2 Jabberd 1.4.2 quickstart Anyone using a jabber server? Do you know how to have it startup when booting? I can't seem to figure that part out. Jeff (1 Reply)
Discussion started by: lawadm1
1 Replies
Login or Register to Ask a Question