can't even compile my compiler!!!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers can't even compile my compiler!!!
# 1  
Network

I have two systems, both running solaris 2.5.1. the first is a test server and the other is the production box.

On the test server I just compiled and installed php4, apache 1.3.17, and MySQL 3.23.32. when I tried to do it on the production box, nothing will compile and I get the following error (php4 example):

Code:
In file included from internal_functions.c:39:
/usr/local/src/php-4.0.2/ext/gd/php_gd.h:33: gd.h: No such file or directory
make[2]: *** [internal_functions.lo] Error 1
make[2]: Leaving directory `/usr/local/src/php-4.0.2/main'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/php-4.0.2/main'
make: *** [all-recursive] Error 1

I installed a new make (gnu make 3.79.1) which seemed to go ok, but did not help anything. I tried to compile a new compiler ( gcc 2.95.2 ), but guess what?

anyone?
# 2  
What are the error messages you receive when you try to compile gcc?

The error you noted from php is caused because the compiler cannot find a header file (gd.h) that it needs.
# 3  
here are the errors that crap out the build process after about 20 minutes:

Image

sorry for the slow image - copy and paste was f&*d for some reason.
# 4  
Your gcc appears to be broken. You can get a binary to install from http://www.sunfreeware.com/
# 5  
i actually tried that before and don't know what to do with the file: it comes gzipped, so I unzipped it and put it in my /usr/local/bin dir (after backing up the other one), made it executable (it wasn't after downloading) and now configure scripts will not even recognize it as a functioning compiler. what am I missing here?

this is getting worse.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #881
Difficulty: Medium
One many threat vectors to a modern SCADA system is the threat of unauthorized access to the control software,
True or False?

10 More Discussions You Might Find Interesting

1. Programming

New to C/gcc compiler - compile error.

I am new to comiling c/c++ programs with gcc compilier unix - AIX version 5.3 gcc compiler version - 4.0.0 My makefile. # makefile 1.0 08/20/98 #CC = cc CC = gcc ESQL = esql CFLAGS = -Wall DBSLIB= DBSLIB=-L${INFORMIXDIR}/lib/esql -L${INFORMIXDIR}/lib `esql -libs` ALL = hds_near... (9 Replies)
Discussion started by: anish
9 Replies

2. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

3. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

4. Programming

Couldn't compile the simple "Hello World"

So, this is my first C++ program under linux. My OS is Red Hat 8.0, and my codes are like following: $vi hello.cpp #include <iostream> using namespace std; int main() { cout << "Hello World!" << endl; return 0; } $ g++ -o hello hello.cpp the error message are: ... (3 Replies)
Discussion started by: HOUSCOUS
3 Replies

5. Email Antispam Techniques and Email Filtering

Procmail recipe: blocking 'unsubscribe and opt-out' messages....

Here is a crude procmail recipe that I quickly created (NOT a procmail recipe expert, btw) that has been catching lots of spam (current second after the charset_spam recipe posted earlier): :0B * .*If.you.do.not.wish.to.receive...* more_spam :0B * You.requested.to.receive.this.mailing... (0 Replies)
Discussion started by: Neo
0 Replies

6. IP Networking

BELKIN 'F5D5020' 16bit PCMCIA - FreeBSD HOWTO

Hey all, I've bought a few bits from Belkin who seem quite happy to support FreeBSD! Last time I bought a UPS from them and it's still going well :D I saw this on their website that the 16bit PCMCIA card was supported under FreeBSD: http://www.belkin.com/network/F5D5020.html I went to my... (0 Replies)
Discussion started by: WIntellect
0 Replies

7. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

8. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

9. Programming

I have not c compile environment ,i can download it but it ends with *.gz,so i can't

I need for help . (1 Reply)
Discussion started by: dsun5
1 Replies

10. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies

Featured Tech Videos