Visit Our UNIX and Linux User Community


syntax error: `(' unexpected


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers syntax error: `(' unexpected
# 8  
Old 12-13-2001
Ahhh... well, I know nothing about the
Informatica products but I would look for
differences in the setup and configuration
of the Informatica server between the two
machines. I would seriously doubt it has
anything to do with Solaris.
(but you never know) Smilie
# 9  
Old 12-13-2001
Assuming that this is a magic number error, meaning that the some executable in the execution chain is not the type of binary executable image expected by Solaris 8, and given the output of the file command you ran on each machine, this is either a problem with a 32 bit executable and shared library set running on a 64 bit operating system (not likely but possible), or the shared libraries that were installed were of the wrong executable format.

If you run

truss -f pmconfig > /truss.out 2>&1

and look at the /truss.out output file, the end of the file should show some type of error, probably an error after an execve and a stat or an open call. If the file is fairly short, you could post it here for more help.
# 10  
Old 12-14-2001
A silly question. What is the hardware architecture of the two boxes in question?
# 11  
Old 12-14-2001
They are both Sun boxes. I do not deep things about their hardware but they are both identical.
# 12  
Old 12-14-2001
Set your LD_LIBRARY_PATH to have the lib directory of the Informatica libraries first in the directory list. If this still doesn't work, then

does

isainfo -kv

show that both kernels are running the same kernel (i.e. both 32 bit or 64 bit)? Also, if you use the file command to look at the Informatica shared libraries

i.e. file shared_lib.so.1

Does the output of the file command on the shared libraries show the same output?

If the hardware architecture is the same, the OS is the same, the install media/image is the same and is for Solaris 8, and both kernels are running in the same mode (i.e. 32 bit or 64 bit), then I'm at a loss as to the reason.

The only way we could possibly figure this out is to get the output of

truss -f <executable_name> > /truss.out 2>&1

where <executable_name> is pmconfig or whatever executable you run to get the error. If you can post this we can see where it's failing.

Sorry I haven't been a lot of help, but this error usually signifies an executable image that was compiled/linked for a different OS/arch.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #701
Difficulty: Easy
MySQL NOT LIKE is a sardonic DB operator used to exclude those rows which are not liked by Oracle Corporation executives.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Syntax error: `]' unexpected

I am getting this error Syntax error: `]' unexpected. Did I do something wrong with elif? Does ksh not like double brackets? if ]; then #echo hi source ~/.bashrc; elif ]; then #echo hi source ~/.kshrc; fi (5 Replies)
Discussion started by: cokedude
5 Replies

2. Shell Programming and Scripting

Syntax error `(' unexpected

I have written this in my script but while running i am getting syntax error `(' unexpected. unload to "$BACKUP_DIR/n_fac_fid-$clliname" select * from n_fac_fid where fac_accesskey in (select fac_accesskey From n_fac_ap_fid where ap_clli="$clliname"); Any help appreciated. (3 Replies)
Discussion started by: suryanmi
3 Replies

3. Shell Programming and Scripting

Syntax error: 'fi' unexpected

unzip file.zip if ] ; then echo "Success" else echo "Some failure." fi ; I tried many time to detect the unzip error, but it keep show the syntax error wherever how I change the syntac. Hope someone can help me fix the issue, thanks. Please use code tags next time for your code and... (5 Replies)
Discussion started by: duncanyy
5 Replies

4. Shell Programming and Scripting

Syntax error near unexpected token '('

I tried to execute the code but I got this error ./Array.c: line 9: syntax error near unexpected token '(' ./Array.c: line 9: ' nvals = get_data(a,MAXARRAY);' and #include<stdio.h> #define MAXARRAY 1000 main() { int a, nvals; nvals =... (7 Replies)
Discussion started by: sgradywhite
7 Replies

5. Shell Programming and Scripting

Help with ksh syntax error Unexpected Fi

Issue resolved, thanks (6 Replies)
Discussion started by: dangell82
6 Replies

6. Shell Programming and Scripting

syntax error: `$' unexpected

Hi all, Am very new to Unix and am currently Involved in Migrating some Shell Scripts from AIX 4 to Solaris 10. While using teh for loop am getting the below error: $ echo $SHELL /usr/bin/ksh $ for file in $(ls *SEBE*) syntax error: `$' unexpected while the same works without issue on... (4 Replies)
Discussion started by: paragkhanore
4 Replies

7. Shell Programming and Scripting

Syntax error near unexpected token `('

Guys , This is an output of my script errored out for "Syntax error near unexpected token `(' " Can someone tell me whats wrong with my script. Below is my original script pasted. #!/bin/bash Script Creation Date 01/21/2010 Author baraghun ... (7 Replies)
Discussion started by: raghunsi
7 Replies

8. Shell Programming and Scripting

unexpected syntax error

Hi, i am getting following syntax error ...kingly advice why is it coming ?? #!/bin/bash find . -name "common.log" if ; then echo "1" fi Himnashu@home /bin $ ./a.sh ./a.sh: line 7: syntax error near unexpected token `fi' ./a.sh: line 7: `fi' (9 Replies)
Discussion started by: himvat
9 Replies

9. Shell Programming and Scripting

sh: syntax error: `...' unexpected???

Hello all, I want to create a script that polls every hour a directory for the existence of a file. The file I look for is a `token` dropped by an external process at the completion of a successful FTP process. I wrote this script `checkfile.ksh`: #!/usr/bin/ksh if ] then mailx... (5 Replies)
Discussion started by: alan
5 Replies

10. Shell Programming and Scripting

Syntax Error: 'else' is not expected

We have a ksh script to insert data into our data warehouse. There are multiple if/then/else statements, most are not embedded. In this example, there is an if/then statement, and an embedded if/then/else/fi statement. The problem occurs with the closing else. I receive an error message as... (6 Replies)
Discussion started by: djschmitt
6 Replies

Featured Tech Videos