Visit Our UNIX and Linux User Community


Dleting a Device in AIX 4.3


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Dleting a Device in AIX 4.3
# 1  
Old 02-02-2001
Network Deleting a Device in AIX 4.3

I need to delete a TTY in my AIX 4.3 system. I have tried using the smit but everytime I try it, there is a message telling me that the device is in use and cannot be changed. How do I take the device "offline", so to speak, so that I can edit the settings and/or delete it.

V/R

Djassi
# 2  
Old 02-02-2001
The 'device in use' error comes from the fact that there is a process running which has an open/active file descriptor associated with the device. You must determine the process(es) which is(are) associated with the device and kill it(them).

If the device is a tty then you have to determine which tty is in use (mouse, modems, console, logins, etc) and make sure when you kill the process that you are not killing the shell you are working in. For example, if you are at a console and logged in to the system, you cannot kill that tty. If you do, you will be kicked off, because your shell process (associated with the tty) will die.

Enjoy the detective work! It not too hard of a detective-problem and should be rewarding finding out which TTYs are associated with what process Smilie
# 3  
Old 02-06-2001
Data Did the detective work, but no luck -- -REAL Dummy here!!!

I ran the ps -A command to display all the processes but I did not find any process associated with the TTY that I want deleted (TTY15) A serial Terminal interface. I don't want to kill processes arbitrarily.
# 4  
Old 02-09-2001
Tools Eureka!!! The Solution.

Well, I found the solution.

I used the pdisable command and took the TTY in question "off-line". And then used smit to edit and delete the TTY finally.

Thanks though, Neo.

Djassi
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #812
Difficulty: Medium
In CSS, the rgba() function define colors using the red-green-blue-accent (RGBA) model.
True or False?

7 More Discussions You Might Find Interesting

1. AIX

AIX - NIC device explanation need

Hello, I have some doubt about the NIC device on my AIX box. When using lsdev command / > lsdev -Cc adapter | grep en ent0 Available 03-00 2-Port 10/100/1000 Base-TX PCI-Express Adapter (14104003) ent1 Available 03-01 2-Port 10/100/1000 Base-TX PCI-Express Adapter (14104003) ent2... (11 Replies)
Discussion started by: Phat
11 Replies

2. AIX

AIX 7.2 - Error initializing a device into the kernel.

On a fresh bare metal (no LPARs) install of AIX 7.2 running cfgmgr is returning.. # cfgmgr Method error (/usr/lib/methods/cfgstorfworkcom -l sfwcomm2 ): 0514-040 Error initializing a device into the kernel. Method error (/usr/lib/methods/cfgstorfworkcom -l sfwcomm3 ): ... (1 Reply)
Discussion started by: c3rb3rus
1 Replies

3. AIX

AIX dump device not showing accurate size

I am trying to configure dump devices on my AIX server. Running 7100-03-04-1441. My dump device needs to be about 2GB in size. My PP Size is 1024MB, so I create the device with 2 PPs. When I run lslv on the dump device, it shows the 2 PPs, and a PP Size of 1024 megabytes. However, a dumpcheck... (4 Replies)
Discussion started by: paqman
4 Replies

4. HP-UX

Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)

Hi, Unable to make tape backup, please help. /opt/ignite/bin/make_tape_recovery -a /dev/rmt/?mn -I -v -m tar -x inc_entire=vg00 * Creating local directories for configuration files and archive. ======= 04/25/16 16:28:08 IST Started /opt/ignite/bin/make_tape_recovery. (Mon... (4 Replies)
Discussion started by: anuragr
4 Replies

5. Red Hat

Unable To Activate Ethernet Network Device in RHEL 5.5 - e100 device eth0 does not seem to be presen

Hi All, Could anyone please help to resolve the below problem. I installed RHEL5.5 in my desktop.But when i try to activate the ethernet connection then it gives me the error. I spent 2 days for the above and go through with several suggestion found by googling. But no luck. ... (0 Replies)
Discussion started by: Tanmoy
0 Replies

6. AIX

rmdev won't remove disk device AIX

Hi all, I'm attempting to remove some EMC hdisk devices which we recently had made available to one of our backup servers. This is an AIX 5.3 server. When I try doing an rmdev I get the following: root@********:/dev# rmdev -d -l hdisk495 Method error (/usr/lib/methods/ucfgdevice): ... (2 Replies)
Discussion started by: C.J.Hund
2 Replies

7. AIX

Telnet disconnects on handheld device AIX

I have intermec handheld device which is connecting to AIX Server on port 12431 or whatever. ( oracle application ) The handheld device connects for few seconds and then disconnects from the AIX server. Once it disconnects the handheld device automatically switches off. Are there any... (2 Replies)
Discussion started by: filosophizer
2 Replies

Featured Tech Videos