Visit Our UNIX and Linux User Community


get symbolic link file


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers get symbolic link file
# 1  
Old 11-12-2001
Question get symbolic link file

hi all,

I am trying to ftp and get some symbolic link file as it is instead of getting whatever it is pointing at. Is it do-able?

Thx in advance.
# 2  
Old 11-12-2001
Hmm... I don't believe that's possible.

Why would you want to do that in the first place? You could just make one of your own symbolic links pointing to the same thing or whatever else you want it to point to.
# 3  
Old 11-12-2001
Thx for your reply.

I am ftp'g a directory. There are "symbolic link" files in there that point to files under the same directory tree. If I can't just download the LINK only, I will ftp some files twice. They are big. Therefore, I am trying to see if there is any trick to avoid that from happening.
# 4  
Old 11-13-2001
You could just transfer the file once, and make your own symbolic link on your own system to point to that file. It would save time and save bandwidth and lots of hard drive space if these files are really huge.Smilie
# 5  
Old 11-13-2001
You might consider using tar (on the remote)
to first bundle all the files in the directory
you want to get. By default, tar ignores
symbolic links. You can use rsh (or somthing)
to execute tar on the remote. Now you can
ftp just the tar-ball and you have only
the files.
# 6  
Old 11-13-2001
I believe that by default tar takes symbolic links and restores them when you untar it as well. That might get you what you wanted.

(I was thinking you were ftping from a box that you didn't have shell access to so tarring up the directory didn't come to mind)
# 7  
Old 11-13-2001
Correct doeboy. The use of the word "ignore"
was wrong. What I should have said is that
by default tar will not "follow" symbolic links.
It does in fact store and recreate them
when unbundled.

Sorry for the confusion. Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #50
Difficulty: Medium
Matti Makkonen is considered to be the 'Father of SMS'.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX and Linux Applications

Tomcat 6.0 fails to read symlink(symbolic link) file

Hello all experts, Im in a situation where Tomcat simply does not want to read this file through the symlink.... I checked permissions..OK Also checked file & tomcat owner...all OK. This is what I have my /tomcat/conf/Catalina/local/appname.xml <Context> <Resource name="jdbc/black" ... (3 Replies)
Discussion started by: KingaKoopa
3 Replies

2. UNIX for Dummies Questions & Answers

Symbolic link

Hi, trying to understand more about symblic link, when I compiled a program called "match" in one folder ~/downloadsoftware/I want this program to be accessible like a system command by putting a symbolic link in /usr/bin/ Not by setting the $PATH method in .bashrc at this time. What I did is:... (4 Replies)
Discussion started by: yifangt
4 Replies

3. UNIX for Dummies Questions & Answers

[Solved] Symbolic link not allowed or link target not accessible

Hi everybody, I read about treads realted to this issue but they did not resovle issue given below. Please help me resolve issue given below I have html file under /srv/www/htdocs/actual_folder ls actual_folder/ test.html and following link works... (0 Replies)
Discussion started by: newbielgn
0 Replies

4. Shell Programming and Scripting

ls on a symbolic link

Hi all, Can anyone please confirm if the command below is the only way that I can get what the symbolic link is set to? mnlxd110(oracle)/db/posd2/dba$: ls -l | grep "^l" lrwxrwxrwx 1 oracle dba 28 Aug 9 2011 bdump -> diag/rdbms/posp1/posp1/trace mnlxd110(oracle)/db/posd2/dba$:... (7 Replies)
Discussion started by: newbie_01
7 Replies

5. Shell Programming and Scripting

Symbolic link to an empty file shows size 2

Hi, I have created an empty file and a symbolic link to a file. But when I issue the following commands, I am getting the output 2. stat -c "%s" linkfile du -hb linkfile Why this is happening? (4 Replies)
Discussion started by: royalibrahim
4 Replies

6. Shell Programming and Scripting

symbolic link to an executable file

I have a script within my home folder and want to be able to execute it without using the sh command. I know that if it was in ~/bin and executable I could do it just by typing the file name, but would rather keep it in the current file structure I tried creating a soft link in ~/bin,... (5 Replies)
Discussion started by: Jaloopa
5 Replies

7. Shell Programming and Scripting

symbolic link

Hi, i am trying to create sym links on sles 11 , but it seems i am doing something wrong. oracle@tests:/u01/app/oracle/oradata/ACIS> pwd /u01/app/oracle/oradata/ACIS oracle@tests:/u01/app/oracle/oradata/ACIS> ln -s /db/ACIS/dbase/dbf/ /u01/app/oracle/oradata/ACIS/... (2 Replies)
Discussion started by: tonijel
2 Replies

8. UNIX for Dummies Questions & Answers

How to find .dat file in symbolic link

Hi, I am trying to find all files in a directory that have .dat and .int extensions and removing them. rm -f `find ${MY_DIR} -type f -name '*.dat' -o -name '*.int'` This works fine if $MY_DIR is a regular directory. However when $MY_DIR is a symbolic link then this command fails. How... (1 Reply)
Discussion started by: neeto
1 Replies

9. UNIX for Dummies Questions & Answers

need some info about symbolic link and hard link

hello folks how y'all doin well i have some questions about symbolic link and hard link hope some one answer me i open terminal and join as root and i wrote ln -s blah blah then i wrote ls i see red file called blah blah but didn't understand what is this can some one explain and... (2 Replies)
Discussion started by: detective linux
2 Replies

10. UNIX for Dummies Questions & Answers

symbolic Link

question abt symbolic link ... i'm doing the following ... ln -s x.sh ./scripts/y.sh and cat ./scripts/y.sh it is giving following error cat: cannot open y.sh Any reason u an think of ? But it is working fine when i goto scripts directory and cretae the symbolic link. ... (1 Reply)
Discussion started by: bhargav
1 Replies

Featured Tech Videos