Visit Our UNIX and Linux User Community


Apache Web Server


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Apache Web Server
# 8  
Old 11-16-2001
As LivinFree said, port 80 is a root-privileged port, so you should start Apache as root. Or get away from the root-privileged port by changing it to something higher than 1024. The config file will be in Apache/conf directory, and will be either httpd.conf or httpds.conf. Do "ls -lu" on these two files to see which is being accessed. The line you want to change is "Port 80".
Jimbo
# 9  
Old 11-16-2001
Question

Livinfree & Jimbo,
Thanks a lot.

I am running apachectl as root only. but eventhough i am getting the same.

Also I tried as changing the Port 80 to Port 1080.

I got the results in the Log file as :

[Sat Nov 17 01:50:53 2001] [warn] pid file /usr/local/apche/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Nov 17 01:50:53 2001] [error] (22)Invalid argument: shmctl() could not set segment #7800
[Sat Nov 17 01:50:53 2001] [notice] Apache/1.3.20 (Unix) configured -- resuming normal operations

I cant understand about the error :
Invalid argument: shmctl() could not set segment #7800.

What should i do to proceed?
Anent
# 10  
Old 11-16-2001
Looks like you did not get a clean shutdown, still had some Apache processes running, and this new startup could not gain access to a shared memory segment.

Shut Apache, and make sure all Apache processes are gone:

ps -ef | grep -i apache

Kill any that are still hanging around. Then clean out the Apache/logs directory and try starting up again.
Jimbo
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #1005
Difficulty: Easy
Regarding a circle, one full turn of the circle is equal to 2 radians.
True or False?

9 More Discussions You Might Find Interesting

1. Web Development

Apache 2.4 web server - string manipulation

Hi, I have configured an Apache 2.4 web server for Kerberos authentication. I need to pass the user in an HTTP header to the back-end server. This can be achieved by:- # Set header to blank RequestHeader set KERBEROS_USER "" # Set header RequestHeader set KERBEROS_USER "%{REMOTE_USER}s"... (0 Replies)
Discussion started by: sniper57
0 Replies

2. HP-UX

Apache web server instalation error in HP-UX 11.31

Hi , I am getting an error while installing on a new hp-ux 11.31 server for the first time. I have troubleshooted to some extent and installed the C compiler which it was asking for and now a new error has arised. please find the below error, Any help would be appreciated. $ make Making all... (1 Reply)
Discussion started by: Prasad@hp-ux
1 Replies

3. Web Development

Unable to start the apache web server

Hi All, I'm getting this below error bash-4.1$ ./apachectl -k start (98)Address already in use: make_sock: could not bind to address hostname:18000 no listening sockets available, shutting down Unable to open logs I tried to change the port number, still same error: ... (5 Replies)
Discussion started by: raghur77
5 Replies

4. Web Development

Apache Web Server Config

Hi Gurus I am a newbie in Apache. I want to configure Apache Web server(A for reference) to receive all requests on Port-843 to be redirected to another Apache web server(B) and access a crossdomain.xml(located in /var/www/html) file there. I have put the following entries in... (0 Replies)
Discussion started by: Hari_Ganesh
0 Replies

5. Web Development

Apache Web Server - Invalid Response

Hi, I have a SCO Unix Openserver V6 server which is hosting a website with Apache V1.3 as the http server. The web site has an initial login screen which re-directs to another page once the user name and password has been verified. When connecting to the website and trying to login, it times... (0 Replies)
Discussion started by: Martyn
0 Replies

6. Solaris

Uninstall Apache web server

Hello, I have a Solaris 10 and it looks like it was installed with apache. I see some files in: Since I'd like to use CSWapache2 from OpenCSW I'd like to remove the one from SUN but I don't know which package name it has. Do you know how can I remove it ? Thanks R.F ---------- Post... (4 Replies)
Discussion started by: RobertFord
4 Replies

7. UNIX for Advanced & Expert Users

remote web server access (apache)

Hi, I have web server (apache) installed in server-1 and i want to view the web pages from diferent servers also while the web server is running only in one server ....(all the servers are connected to office LAN) right now all the servers have apache running......and CPU utilzation is at its... (2 Replies)
Discussion started by: aditya.ece1985
2 Replies

8. Solaris

Configure apache web server for coldfusionmx7

Hi, I have been trying to configure apache web server for coldfusion mx7 on solaris 5.8 using the command: ./wsconfig -server coldfusion -ws apache -dir /usr/local/apache/conf -bin /usr/local/apache/bin/httpd -script /usr/local/apache/bin/apachectl -coldfusion Then it prompted me: Apache... (1 Reply)
Discussion started by: sagolo
1 Replies

9. Solaris

Apache web server question

Hi - Maybe not the right forum for this but I will ask anyway.. I recently installed apache on my ultra 10 - solaris 9... Working okay - and I have some docs in my htdocs directory that I can access through a web browser.. Now I want to get a bit fancy and change the home page so I can... (2 Replies)
Discussion started by: frustrated1
2 Replies

Featured Tech Videos