Visit Our UNIX and Linux User Community


rsh and permission denied


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers rsh and permission denied
# 1  
Old 10-15-2001
Data rsh and permission denied

Dear All
I am using rsh command to work with a remote tape drive. I am getting the message 'permission denied'. What should I do to get rid of this message.
Best Regards
Reza
# 2  
Old 10-15-2001
Hammer & Screwdriver Re: rsh and permission denied

To get rsh working you should all of these:
- allow the remote computer to access the rsh server (see /etc/hosts.allow and your firewall)
- make the rsh daemon usable (usually in /etc/inetd.conf there is a line about "shell" service)
- put a "IN A" and a "IN PTR" and record in the DNS specifying the computer which access your server (if your remote machine cannot be accessed as hostname.domain.net you will not be able to use rshd from that machine)
- tell the server who is using remote shell from that address (hostname.domain.net) in "/etc/hosts.equiv"
- now try again Smilie

Quote:
Originally posted by Reza Nazarian
Dear All
I am using rsh command to work with a remote tape drive. I am getting the message 'permission denied'. What should I do to get rid of this message.
Best Regards
Reza
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #69
Difficulty: Easy
Grep stands for 'global regular expression process'.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Permission denied

when i run echo "User” > /dev/tty5 why do i get permission denied? :confused: (2 Replies)
Discussion started by: chinababy
2 Replies

2. Linux

Permission denied

I am using korn shell When I type in Telnet on cmd line, I get message "cannot execute" How can I get permission to execute command ? In which dir is telnet located ? I looked in /usr/bin dir. but its not there Thanks (1 Reply)
Discussion started by: paramshamnani
1 Replies

3. Linux

rsh permission denied

hi I have configured rsh-server and running rsh command on my fedora 14 machine while executing it shows permission denied, below is the output of the same. # rsh localhost date Permission denied. # but same works in other system # rsh localhost date Fri Nov 23 05:31:12 PST... (5 Replies)
Discussion started by: muzaffar.k
5 Replies

4. AIX

RSH intermittent error rshd: 0826-813 Permission is denied.

I am getting an error from one node in a set with RSH setup between them, node one will connect to node two every other time (consistently), however node to connects to node one every time without problem. Here is what I am seeing, makes no sense to me. Can anyone help? sbhcprdb01<root>: rsh... (6 Replies)
Discussion started by: JodyTek
6 Replies

5. Red Hat

Permission denied

Hi guys im new to this db i have a small prob while installing websphereportal6.1i think i was installed succesfully but the error im getting is while starting server. check this out # ./serverStatus.sh -all Error loading: /usr/wps61/AppServer/java/jre/bin/classic/libjvm.so: cannot... (1 Reply)
Discussion started by: varma917989
1 Replies

6. Red Hat

rsh denied on some boxes but not others

Hi. As root, I'm running rsh as root from a Solaris 9 machine to some RHEL 4 servers (supposedly all configured identically) but two of about 10 respond with permission denied. There is no firewall device between the Solaris 9 client and the RHEL servers. I'm doing something like this from the... (4 Replies)
Discussion started by: th1amigo
4 Replies

7. Shell Programming and Scripting

Permission denied while executing rsh

Hi All, I have two servers, say server1 and server2. I have put the entries of both servers in /.rhosts file of both servers. So, when I tried to run following from server1- rsh server2 "ls" Permission denied was printed on console. Can anyone help me out? Regards, akash mahakode (4 Replies)
Discussion started by: akash_mahakode
4 Replies

8. UNIX for Dummies Questions & Answers

Permission denied

I would like to copy data from local mechine to cluster. Basically, I typed scp -r DVD/ acount@cluster:/ it shows Permission denied. Could anyone please give me a clue to write permission on cluster, please? The poperty of where on cluster I'd like to put is drwxr-xr-x Any idea would... (1 Reply)
Discussion started by: su_in99
1 Replies

9. UNIX for Advanced & Expert Users

Permission denied

Hi, I can not execute a .env file $ . /Data/oracle/d03/mydbora/8.0.6/MYDB.env -bash: /Data/oracle/d03/mydbora/8.0.6/MYDB.env: Permission denied Even if : -rwxrwxrwx 1 oracle dba 2903 Mar 5 2007 /Data/oracle/d03/mydbora/8.0.6/MYDB.env Please help. Many thanks. (1 Reply)
Discussion started by: big123456
1 Replies

10. Shell Programming and Scripting

rsh permission denied

Hi Gurus, Trying to search in the forum but cant seem to find anything related. I'm trying to run this script DWH_Housekeep.sh from the another server This is my command: rsh -l hulft 140.32.12.161 /usr/TRS/script/DWH_Housekeep.sh permission denied I get permission denied. ... (7 Replies)
Discussion started by: lweegp
7 Replies

Featured Tech Videos