Visit Our UNIX and Linux User Community


problem with Solaris in Network configuration


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers problem with Solaris in Network configuration
# 1  
Old 10-09-2001
Bug problem with Solaris in Network configuration

WEe have installed Intel version of Solaris 8 in a machine .we skipped the network configuration at the begning.we selected unnetworked.Now we need to connect the same machine to a network.
We configured the Card using ifconfig but its taking the ip address itself as the Default G/W.
I need help in configuring the Default g/w so that it can be connected to the network.

PremkumarSmilie

Last edited by premkumar; 10-09-2001 at 03:52 AM..
# 2  
Old 10-09-2001
Hi..Prem

To put the machine in network u first put the network card then boot the machine......during booting it ask tht it is booting frm the first known bootable device that is the system hard disk and if u want to interrupt press any key to boot frm any other media......

Press any key to interupt the booting frm system harddisk it will once again scan for hardware config..and detect the new network card....and ask for the bootpath....now boot it frm the default system disk as before.............and during booting look for the network interface it is configuring like elxl0 or hme0 etc etc...

note that interface.....and after booting make one file /etc/hostname.<interface name> and put the ip address u want to give in tht file..and save it..

now u configure the network address.
ifconfig -a <interfacename> <ip> <mask><broadcast>

put the default GW in file /etc/defaultrouter

Try n learn

regards
praful
# 3  
Old 10-10-2001
Praful

i think Prem can do sys-unconfig and do the config once again .Prem if u give this command then the machine will reboot after it comes up it will reconfigure the things again on that time u can give the ip add and G/W.U can try this also if u wish to do.

Francis
# 4  
Old 10-10-2001
sys-unconfig will set up your IP connectivity, but does not prompt for the default gateway. You will have to create a /etc/defaultrouter file containing the IP of the gateway.
# 5  
Old 10-11-2001
thks praful,francis,98_1LE for u r suggestions and help.

PremkumarSmilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #540
Difficulty: Medium
In dynamically typed programming languages. instead of declaring a variable to have a particular type, the type of a variable is determined by an A.I. in the operating system.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Network interface configuration - Solaris 11

Hi, I am new in Solaris 11. I can't even make the NIC work. Here is the issue: Any help will be greatly appreciated. (6 Replies)
Discussion started by: aixlover
6 Replies

2. Solaris

Solaris Network Configuration

Hi How do I configure a network card in Solaris 10? using the command ifconfig, and also please advise me for persisting this ip address what are the files newly created and modify. I am a new baby in solaris:) (4 Replies)
Discussion started by: vipinmurali
4 Replies

3. AIX

Problem with NFS mount and network configuration between AIX and Windows 2003 servers

I m beginner on unix I want to move an unix aix post 5.2 on distant site for use catia V4 with a foundation of data accommodated by a serveur windows 2003 and an environment accommodated on the serveur aix. The computer was linked up by IP (122.0.0.8) with waiter 2003 (via NFS) and the waiter... (8 Replies)
Discussion started by: astiaous
8 Replies

4. Solaris

Problem in network configuration

Hi everybody, I have a very strange problem ; if somebody could help me it would be very kind. I'll try to explain my problem. I have 2 unix machines absolutely identical running solaris 9. For network reasons I need to change the IP address of the 2 machines. I proceed exactly the same on the... (11 Replies)
Discussion started by: aribault
11 Replies

5. Solaris

Problem with network printer on Solaris.

Hi All, We have configured an hp network printer on a Solaris-sparc machine. We are unable to print any files from this machine. The following are the other details: lpstat -p hpnic -l printer hpnic waiting for auto-retry. available. exec exit fault Form mounted: ... (0 Replies)
Discussion started by: shahshilpa
0 Replies

6. Solaris

common network problem under Solaris 10 ?

Hi there, I run a SunFire v245 with solaris 10. I run a custom ERP on that. my clients are connecting via telnet and run the application... my last "server" was a sun blade 100 with solaris 8, everything was running correctly. Since I have the new server, I have many problem with my... (5 Replies)
Discussion started by: Siffleu
5 Replies

7. Solaris

Solaris 10 network configuration problem with zone

I am seeking help from the gurus in this forum and hope that I can find answers soon. Anyone who provide the answers will be greatly appreciated. I have a sparc box with Solaris 10 on it. We install Solaris with zone structure. One global zone and two other zone. I installed Oracle DB on global... (6 Replies)
Discussion started by: duke0001
6 Replies

8. Linux

Linux network configuration problem

I have clients that will be connecting to a server (ServerA) through a switch. ServerA connects to the switch through eth0 and i use another ethernet card - eth1 to connect to the Internet through an ADSL router. The clients can access the internet with no problem, i have set up IP forwarding and... (2 Replies)
Discussion started by: robple11
2 Replies

9. UNIX for Dummies Questions & Answers

Network configuration in Solaris 8

Hi. I have installed Solaris 8 and I am trying to configure the network settings. For some reason every time I reboot, my card loses its configuration. I can run ifconfig and the only IP address bound to my card (on either interface) is 127.0.0.1. I can change that to a valid IP address on my... (8 Replies)
Discussion started by: Ask Me
8 Replies

10. IP Networking

solaris network problem

hello i had soloaris 8 installed . at the beggining it sees my network card( intel i815/82559 onboard)(my mainboard is GA-8IRXP); but during the installation when I fill the ip address and the dns at the end that i should confirm it says: no dns find (i'm sure about the dns... (4 Replies)
Discussion started by: hessam
4 Replies

Featured Tech Videos