Openbox unable to start on OpenBSD

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Openbox unable to start on OpenBSD
# 1  
Old 01-18-2014
Openbox unable to start on OpenBSD

The other day I installed the packages for Openbox on OpenBSD. I tried starting it from the command-line as a normal user with "openbox-session" and got the following error:

Openbox-Message: Failed to open the display from the DISPLAY environment variable.

I looked online and saw that setting the DISPLAY variable like this has fixed this problem for others:

DISPLAY=:0.0 openbox-session &

However, the same error still persists when I try to start OpenBox. I saw the variable wasn't remaining set, so I tried exporting it, but the same thing happens:

$ export DISPLAY=":0.0 openbox-session &" 
$ echo $DISPLAY
:0.0 openbox-session &
$ openbox-session
Openbox-Message: Failed to open the display from the DISPLAY environment variable.

Any suggestions?
# 2  
Old 01-18-2014
Originally Posted by Azrael
I looked online and saw that setting the DISPLAY variable like this has fixed this problem for others:

DISPLAY=:0.0 openbox-session &

This is a misunderstanding on your side. The DISPLAY variables content should probably be ":0.0" and what you see is a command where it is set this way, then started openbox in the background with this setting. Therefore:

$ export DISPLAY=":0.0 openbox-session &"

This is complete nonsense. If you want the DISPLAY variable to be ":0.0" (which means "use the local displays first screen for displaying your content") you should do it this way:

$ export DISPLAY=":0.0"
$ openbox-session &

The real problem, though, might not be addressed yet and you might want to read up about X-Windows concepts to get a picture of what your problem is. My suspicion is that either no X-Server is running on your machine or that it is running but simply forbids other sources to use it. Issue "xhost +" as the user under which the X-Server runs to disable access control and then try again. You will still have to set the DISPLAY variable to tell the openbox-application which X-Server to use.

For a (very very short) introduction to X-Windows concepts you might want to read this.

I hope this helps.

# 3  
Old 01-19-2014
First I should have stated I did try to set DISPLAY=:0.0 before the previously mentioned try:

$ export DISPLAY=":0.0" 
$ openbox-session Openbox-Message: Failed to open the display from the DISPLAY environment variable. 
$ echo $DISPLAY :0.0

I should have also stated that X is already installed and works with KDE. I was following a page from OpenBSD's support at the link below:

OpenBSDsupport -- Quick steps to an OpenBSD Desktop

However, some of the steps did not seem to work:

# sysctl -w kern.machdep=1 sysctl: second level name machdep in kern.machdep is invalid

Bakunin's suggestions did get me thinking though. I tried starting X in the background and then starting OpenBox:

$ xinit  &

X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: OpenBSD 5.3 i386 
Current Operating System: OpenBSD 5.3 GENERIC.MP#58 i386
Build Date: 27 February 2013  04:00:52PM
Current version of pixman: 0.28.0
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 19 03:25:26 2014
(==) Using system config directory "/usr/X11R6/share/X11/xorg.conf.d"
mtrr set d5000000 e00000 failed: Invalid argument

$ openbox-session
Obt-Message: Xinerama extension is not present on the server
which: hsetroot: Command not found.
which: esetroot: Command not found.

It looks like Openbox may be looking for some things that art not installed. As X starts, but no Openbox. I found that there are packages for both hsetroot and esetroot with Linux, but nothing for OpenBSD:

# pkg_add -r hsetroot
Can't find hsetroot
# pkg_add -r esetroot 
Can't find esetroot

Perhaps someone knows where to find these.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX Desktop Questions & Answers

Unable to start vncserver

Hi, While trying to connect vncserver, i am gettting below errors: sh: /home/$USER/.vnc/$HOSTNAME:2.log: Permission denied sh: /home/$USER/.vnc/$ Permission denied New '$HOSTNAME:2 ($USER)' desktop is $HOSTNAME:2 Starting applications specified in... (1 Reply)
Discussion started by: pandeesh
1 Replies

2. Solaris

Unable to start webconsole:console

Here is issue... bash-3.00# svcs system/webconsole:console STATE STIME FMRI maintenance 1:15:54 svc:/system/webconsole:console bash-3.00# svcadm clear svc:/system/webconsole:console bash-3.00# svcs -a |grep /system/webconsole offline* 1:20:44... (0 Replies)
Discussion started by: lingeshwaran
0 Replies

3. Solaris

Unable to start SQLPLUS

I upgraded my system to Solaris 11 and everything works but I can't start my database or what (I am a noob). OS: -bash-4.1$ uname -a SunOS Solaris11 5.11 11.0 i86pc i386 i86pc -bash-4.1$ isainfo -kv 64-bit amd64 kernel modules Database version is 11g2 Enterprise edition, installed on... (6 Replies)
Discussion started by: solaris_user
6 Replies

4. UNIX for Dummies Questions & Answers

unable to start shell script

Hi, Pleasse could someone advise why i'm getting this error below - No such file or directory dev6:$ ls -ltr -rwxr-xr-x 1 dev fix 4830 Aug 22 11:13 dev6:$ ./ : No such file or directory dev6:$ thank you (2 Replies)
Discussion started by: venhart
2 Replies

5. UNIX Desktop Questions & Answers

Unable to install OpenBSD 4.9

I'm unable to install OpenBSD 4.9 boot disk after having burnt the "install49.iso" file. On boot, it says: "CD-ROM : 90 Loading OpenBSD/4.9/i386 CDBOOT" and keeps repeating these two lines. Any solutions? Thank you. (1 Reply)
Discussion started by: ihavequestions
1 Replies

6. Solaris

Unable to start SunVTS on M5000

Please advise. Thank you bash-3.00# cd /usr/sunvts/bin/ bash-3.00# ls bios.bin stopsunvts vtsprobe cmos.bin javabridge.jar sunlink vtsreportgenerate dispatcher loadVtsServer svmVolDiskList vtstalk env6test... (6 Replies)
Discussion started by: incredible
6 Replies

7. IP Networking

Unable to start network interface

Hi (sorry for my bad English) I'm trying to configure an US Robotics (USR5423) wirless usb adapter on Fedora 9. the device is detected, and i'm trying to configure a wireless connection. When I want to activate the device using #service network restart or # /etc/init.d/network restart... (0 Replies)
Discussion started by: teis
0 Replies

8. Solaris

Unable to shutdown and start machine

Hello. I have just installed solaris on my PC (standalone). It allows to reboot. But IF I shut down and the restart by pressing the button - It does not show my solaris OS and I am then forced to perform fresh installation. Could you please let me know the fix for it - So that shutdown and... (3 Replies)
Discussion started by: panchpan
3 Replies

9. UNIX for Dummies Questions & Answers

unable to start sqlplus from unx

I want to execute sqlplus command from unix environment.Infact I enter the command Here is what I entered. $ pwd /u01/app/oracle/product/9.2.0_64/TSTGDPB/bin $ ls -l sqlplus -rwxr-x--x 1 oragdpb oinstall 1062664 Oct 18 2005 sqlplus $ whoami bpt3a1 $ sqlplus /bin/ksh: sqlplus: not... (1 Reply)
Discussion started by: MSHETTY
1 Replies

10. Solaris

unable to start SMC

hi can anyone clarify , to start SMC whether 3 and 4 cd's need to be install in solaris 10. byee selva (1 Reply)
Discussion started by: selvassd@gmail
1 Replies
Login or Register to Ask a Question