Problem in loading program correctly using SSH and X11 forwading

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem in loading program correctly using SSH and X11 forwading
# 1  
Old 12-25-2013
Problem in loading program correctly using SSH and X11 forwading

I'm trying to load a program remotely using SSH with X11 forwarding. I have no issue with loading xwindows and programs like firefox works fine. But one software that I use for my work has some issues when I load it up. For example, I can't see the pull-down menus etc, which show up when I load it locally. I also tried different computers and also using Cygwin/X. I'm using opensuse 11.4 though.

I don't know the details of the program I'm afraid but I believe that it requires openmotif.

# 2  
Old 12-27-2013
The app may be using UNIX sockets as if it was a local X, not all tcp. Try it using Xvnc with the viewer on an ssl tunnel. The X will be local, only the desktop viewer will be remote. Or try setting $ so the app thinks it is remote (all tcp).
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. IP Networking

Force SSH session without/disabling X11 forwarding.

I would like to disable X11 session forcefully. I have tried the following things: 1. Setting appropriate DISPLAY variable in the /etc/environment file to be "0.0" 2. I have tried setting the sshd_config parameter X11Forwarding to be "no" This session communication is happening by exchanging... (2 Replies)
Discussion started by: vaibhavvsk
2 Replies

2. UNIX for Dummies Questions & Answers

Is it possible that X11 can be forwarded through a SSH tunnel

I communicate with the server via a ssh tunnel, configured via Putty. Recently, I'm trying to forward the X11 through it, but it doesn't work. Is there any one work this way? Searched with google, but didn't find anything. Thx in adv. (2 Replies)
Discussion started by: sleepy_11
2 Replies

3. AIX

X11 Font problem

Currently ,we use Exceed,X-Win32,winaxe 7.7,Reflection X software for doing evaluation. 1.Chinese word problem When we use "more filename" to check the file in xterm command console mode from our client Window XP to IBM AIX can show the chinese word,but when we change to grahpic mode... (1 Reply)
Discussion started by: whbun123
1 Replies

4. UNIX for Dummies Questions & Answers

Problem with X11 Forwarding

Hello. I installed a Debian box, and its installed remotely. I need to boot up iceweasel from there to do a quick test. I log on using: ssh root@<IP> -X I have modified the /etc/ssh/sshd_config file, and added the X11Forwarding yes flag And yet I still get: Error: cannot open... (10 Replies)
Discussion started by: dynelight
10 Replies

5. Shell Programming and Scripting

Help loading a program into perl from a file on desktop

So I want to use this program that I have downloaded from: PaGE - Patters from Gene Expression However, I am not sure how to actually get in to and run the program... I can log into the server, and was assuming I needed to get the "" file into a folder some how, but not sure how to... (2 Replies)
Discussion started by: silkiechicken
2 Replies

6. UNIX for Dummies Questions & Answers

X11 problem

Hey guys, I'm on a Solaris 9 boxes and I setup Putty to do X11 forwarding I can get my Xmanager to connect and load Xwindows screens fine. But, sometimes if I lose my putty connection or the app im running crashes X freaks out and deletes my display, setting it to nothing. When I add my display... (2 Replies)
Discussion started by: kingdbag
2 Replies

7. Solaris

ssh X11 tunnelling error

Hello freinds. Recently installed solaris 10 on a "sun ultra 10" with all the included features in the 5 CD set except sendmail support which i never needed. I am trying to ssh into the servers at my school which I can very easily do using linux. It seems that there is something wrong with the... (2 Replies)
Discussion started by: aijazbaig1
2 Replies

8. Red Hat

X11 forwarding problem between 2 RHEL4 machines with SSH

X11 forwarding problem between 2 RHEL4 machines with SSH Already configured the following on both machines under /etc/ssh Under sshd_config: UsePAM no AllowTcpForwarding yes Under ssh_config: ForwardAgent yes ForwardX11 yes ForwardX11Trusted yes ----------------------------- Using... (1 Reply)
Discussion started by: panggou
1 Replies

9. Debian

X11 Forwarding Problem

I have 2 Debian boxes. In my client and my putty client, I have X11 fowarding turned on for both boxes. When I connect one, I can xterm with no problem back to my pc. On the other, I keep getting: xterm Xt error: Can't open display: xterm: DISPLAY is not set On both... (3 Replies)
Discussion started by: natter
3 Replies

10. OS X (Apple)

ssh forwarding to X11

Hi, I have issues with running graphical interfaces on my computer being remotely logged into a network via the -X option of ssh. My .cshrc shows DISPLAY=hostname:0 and I think there should be a different number instead of the 0. I changed the ssh_config file already to 'X11 forwarding yes', which... (0 Replies)
Discussion started by: ginese
0 Replies
Login or Register to Ask a Question