[Solved] ls -l in CentOS 6.4 after upload using sftp

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers [Solved] ls -l in CentOS 6.4 after upload using sftp
# 1  
Old 10-30-2013
[Solved] ls -l in CentOS 6.4 after upload using sftp

Hi everyone,
Something rather interesting just happened to me. I uploaded a file to a server through sftp. I closed the connection and then logged on to the server via ssh. So far so good.
When I typed ls -l in the remote server to retrieve a directory listing, the file that was previously uploaded is displayed as follows:
-rwxr-xr-x  1 root root  2777 Oct 29 23:10 nginx-centos6*

That is, with a trailing "*". I tried renaming the file but the symbol is still there. What gives?
Any tips will be more than welcome! Smilie
# 2  
Old 10-30-2013
Is your ls command aliased with, for example, -F?

An extract from /etc/DIR_COLORS:

# Extra command line options for ls go here.
# Basically these ones are:
#  -F = show '/' for dirs, '*' for executables, etc.
#  -T 0 = don't trust tab spacing when formatting ls output.

That's to say that the asterisk may merely be part of the output of ls and not part of the filename.
# 3  
Old 10-30-2013
[SOLVED] Ls -l in CentOS 6.4 after upload using sftp

Thank you so very much for taking the time to reply to this post! Yes, you are correct, it turns out that ls is aliased to:
alias ls='/bin/ls $LS_OPTIONS'

root@centos [~]# echo $LS_OPTIONS
--color=tty -F -a -b -T 0

Thanks again!

---------- Post updated at 09:08 AM ---------- Previous update was at 08:38 AM ----------

How do you mark a thread as SOLVED, by the way?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

File upload message in SFTP

Hi, Below script is running on AIX 7.1 ( 7100-04-05-1720 version ) server. Recently OpenSSH version installed on server got updated from OpenSSH_6.0p1 to OpenSSH_7.5p1 version. After this update we do not receive any file upload message after put/mput command in SFTP. sftp -b - user@server... (1 Reply)
Discussion started by: Juggernaut
1 Replies

2. Red Hat

[Solved] I am not able to hear any sound from CentOS 5.9

Hi, 1. I have installed Sound and media player for Centos 'Software Package Installer'. 2. I plugged my headphone in system 3. I am not able to hear sound . Headphone is working on windows machine. NOTE : Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio... (5 Replies)
Discussion started by: es_centos
5 Replies

3. Shell Programming and Scripting

Generate file and Upload to SFTP server.

Xperts, My requirement is something like this, I have a sql script which i need to embed in a shell. The sql (oracle) script will generate a .csv file in some Unix directory. the approximate file size is around 10 mb which i need to upload to an sftp server. My concern here is how to make... (5 Replies)
Discussion started by: Showdown
5 Replies

4. UNIX for Advanced & Expert Users

[Solved] Cannot install KVM guest on CentOS/RedHat

Hi, I've a CentOS Server and I need to create KVM guest machine without X. /usr/sbin/virt-install --name server1 --ram 4000 --vcpus=8 --file=/srv/virtual/server1.img --file-size=20 --cdrom /tmp/server1.iso --mac=52:54:00:fd:48:7c The iso was created with cobbler... So, now the machine is... (5 Replies)
Discussion started by: hiddenshadow
5 Replies

5. Shell Programming and Scripting

Expect Script for SFTP Upload

I am attempting to utilize an expect script (that is called from a parent bash script) to perform a file transfer over sftp. The script works except I cannot catch timeouts. I need to be able to tell in the parent bash script when the expect script has timed out, or completed successfully. It... (3 Replies)
Discussion started by: thaller
3 Replies

6. Shell Programming and Scripting

help to upload multiple files through SFTP

Hi Experts, Please help me to write the expect script for uploading multiple files in one shot . Below is my program that I have written. #!/usr/local/bin/expect -f #/home/kulbhushan/sftp_prog.sh # procedure to attempt connecting; result 0 if OK, 1 otherwise proc connect {passw} { expect... (1 Reply)
Discussion started by: kulbhushan
1 Replies

7. UNIX for Advanced & Expert Users

chrooted SFTP upload folder

Hi List, I have set up a chrooted SFTP setup following the instructions I found on tech republic: /blog/opensource/chroot-users-with-openssh-an-easier-way-to-confine-users-to-their-home-directories/229 I have successfully got it all working and I can download files when logged in via sftp... (0 Replies)
Discussion started by: landossa
0 Replies

8. Ubuntu

I want to upload file on remote machine in noninteractive mode through SFTP

Hi All, I want to upload file through SFTP in non interactive mode on remote server. please tell me what will have to do in oreder to do SFTP . (1 Reply)
Discussion started by: kulbhushan
1 Replies

9. Shell Programming and Scripting

How to Write sftp through "expect" for file upload ?

Hi Experts , I am new to unix programming please tell me how to write expect and hoe to call it for automated file upload process. help me really ! (0 Replies)
Discussion started by: kulbhushan
0 Replies

10. Shell Programming and Scripting

sftp file upload problem

Hi All, I am trying to upload a text file from HP unix to Windows tectia server using sftp, the text file shows with new line character after upload. For EG : abc.txt file contains 123 456 aftre upload it shows as 123 456 i am using sftp version 2.0 TQ, (4 Replies)
Discussion started by: phani1312
4 Replies
Login or Register to Ask a Question