Visit Our UNIX and Linux User Community


Configuring EPEL repo and setting it as default repo.


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Configuring EPEL repo and setting it as default repo.
# 1  
Old 09-10-2013
Configuring EPEL repo and setting it as default repo.

I am using RHEL 6, but with no RHN subscription. I tried installing the EPEL repo, it is enabled under yum repolist but when I try a sample search such as yum search nginx , there's a string of errno 14 PYCURL error 6 .

When I tried yum list installed, it didn't work because it defaults to the RHN repo and gave me this error : Cannot retrieve repository metadata (repomd.xml)

Hence, I tried disabling the RHN repo instead. yum-config-manager --disable InstallMedia

However, when I tried the same nginx search and yum list installed commands, this error appears : Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again.

Any guidance is greatly appreciated =) .
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #732
Difficulty: Easy
In BASIC, GOTO jumps to a numbered or labelled line in the program.
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Cannot proxy a file repo, complains its not version 4, but it is!

I have a Solaris 11.4 global zone (at the most recent SRU) where I am trying to install a Solaris 11 zone. To do this I need to have the system-repository and the zone proxy service started. I created a full (GA 11.4 with newest SRU rolled in) repo using "pkgrepo create" and the... (1 Reply)
Discussion started by: rtmg
1 Replies

2. Solaris

Solaris Repo Update

Hi Folks, Just a quick question on this, I've tried to run this a couple of times now - first time it failed I increased the swap. I'm not sure that increasing the physical memory will do any good, but will try later today - has anyone seen this or anything similar? SunOS fvssphsun01 5.11... (8 Replies)
Discussion started by: gull04
8 Replies

3. UNIX for Advanced & Expert Users

RPM Repo Cleanup

Greetings all, I have inherited this offline Red Hat YUM repo that contains over 42000 packages. You read that right. There are 71 kernels alone. The process that I've inherited has us reposync on an Internet-connected-server then sneaker-net the delta to our offline repo where we do a yum... (2 Replies)
Discussion started by: geoeldsul
2 Replies

4. Red Hat

RHEL 6, Spacewalk 2.3 unable to download RHEL 5 repo data

Hello all, I am having a bit of an issue on my Spacewalk installation. Some amplifying information is that it is Spacewalk 2.3 installed on a RHEL 6 machine and I am attempting to install/update a RHEL 5 channel/repository. I am fairly new to Spacewalk so I am still learning but this is what I... (3 Replies)
Discussion started by: jstone4646
3 Replies

5. Red Hat

Error connecting to repo server

Hi guys, I will really appreciate your help on this issue I am having. I built a repository on one of my servers using a red hat dvd . It is working fine on that server. When I create a repo file in a client server and try to connect to the server repository, I get this error ... (2 Replies)
Discussion started by: cjashu
2 Replies

6. UNIX and Linux Applications

SVN repo issues

We have about 5 different SVN repositories running on SVN 1.6.11 on top of CentOS Linux 6.3. I was asked to migrate our SVN server to a new server last week. We have a cron job that does a Full backup of each repo once a week, and every other night we do an incremental backup via svnadmin dump... (1 Reply)
Discussion started by: glev2005
1 Replies

7. Solaris

solaris 11 - creating a second IPS repo

I need some help getting a IPS repo setup for custom internal packages. we already have an IPS for the oracle solaris package. what I want is a repo called BOB that can be used for packages internal to company BOB. I think I have created a repo called BOB, but it's not setup in the network... (1 Reply)
Discussion started by: robsonde
1 Replies

8. UNIX and Linux Applications

Help with an svn repo and new mount points.

Forgive me if this seems convoluted, I am stuck in a shell all day long and don't get out much. History: We had issues with growing two RAID0 volumes at AWS, so we added two more volumes (RAID0) with larger capacity and rysnc'd 33G of data over after mounting. Facts: /dev/md0 40G 33G 7.6G... (3 Replies)
Discussion started by: Habitual
3 Replies

9. Red Hat

How to Create local YUM repo?

Hi friends, I am using RHEL5 . I have tried to create the local repo using createrepo rpm.But i have been facing a lot of errors and it is not working well. Can somebody tell me how to create the local repo? Thank you in advance. Regards, Prakashkumar.S (2 Replies)
Discussion started by: prakashkumar41
2 Replies
yum-debug-restore(1)													      yum-debug-restore(1)

NAME
yum-debug-restore - replay Yum transactions captured in a debug-dump file SYNOPSIS
yum-debug-restore DESCRIPTION
yum-debug-restore is a program which takes a gzipped file created by yum-debug-dump and acts on the information about installed packages contained within. GENERAL OPTIONS
--output Output the commands that would be run to stdout. --shell=<file> Output the commands that would be run to a file. --install-latest Ask yum to install the latest version of the given packages, instead of the version that was installed in the debug-dump file. --ignore-arch Ignore the architecture of the packages, so you can "restore" an i386 debug-dump on an x86_64 machine. --filter-types=[install,remove,update,downgrade] Only perform the given types of commands, so you can filter to just upgrades and installs. FILES
As yum-debug-restore uses YUM libraries for retrieving all the information, it relies on YUM configuration for its default values like which repositories to use. Consult YUM documentation for details: /etc/yum.conf /etc/yum/repos.d/ /var/cache/yum/ SEE ALSO
yum-debug-dump (1) yum.conf (5) http://yum.baseurl.org/ AUTHORS
See the Authors file included with this program. BUGS
There are of course no bugs, but should you find any, you should first consult the FAQ section on http://yum.baseurl.org/wiki/Faq and if unsuccessful in finding a resolution contact the mailing list: yum-devel@lists.baseurl.org. To file a bug use http://bugzilla.redhat.com for Fedora/RHEL/Centos related bugs and http://yum.baseurl.org/report for all other bugs. James Antill 15 December 2011 yum-debug-restore(1)

Featured Tech Videos