Visit Our UNIX and Linux User Community


Colors not being Interpreted


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Colors not being Interpreted
# 1  
Old 09-03-2013
RedHat Colors not being Interpreted

Hello, I am having an issue with ANSI colors in Redhat linux.

I am running a script where the colours have been set very early on as follows:
Code:
# Reset
Color_Off='\033[0m'       # Text Reset

# Regular Colors
Black='\033[0;30m'        # Black
Red='\033[0;31m'          # Red
Green='\033[0;32m'        # Green
Yellow='\033[0;33m'       # Yellow
Blue='\033[0;34m'         # Blue
Purple='\033[0;35m'       # Purple
Cyan='\033[0;36m'         # Cyan
White='\033[0;37m'        # White

# Bold
BBlack='\033[1;30m'       # Black
BRed='\033[1;31m'         # Red
BGreen='\033[1;32m'       # Green
BYellow='\033[1;33m'      # Yellow
BBlue='\033[1;34m'        # Blue
BPurple='\033[1;35m'      # Purple
BCyan='\033[1;36m'        # Cyan
BWhite='\033[1;37m'       # White

Later in the script these are used to color define sections of output by reffering to them using:
Code:
 ${White} blah blah blah ${Color_off}

Now this works fine on an AIX server I have already deplyed this too, but Redhat seems not to interpret these codes as the output is for example:
Code:
\033[0;37m blah blah blah \033[0m

The script runs in korn shell (ksh) and I have tried running it as bash although it breaks some other parts of the script and does not help with the color issue.

Has anyone experienced this or have any possibly solutions for me?
(Apart from removing the color coding as this is my backup option)
# 2  
Old 09-03-2013
Code:
Color_Off='\e[0m'
White='\e[1;37m'
echo "$White i am luminous now $Color_Off i am dull again"

# 3  
Old 09-03-2013
I've tried your suggestion but to not avail.

One thing I did try was just trsting colors at the command line with this:
Code:
echo -e "testing \033[0;37mCOLOR1\033[1;35mCOLOR2\033[m"

And that worked great, no problems. But when I run this script the codes are just spat back out and not interpretted as the colors I wanted
# 4  
Old 09-03-2013
echo does not interpret escapes on most systems!

Try printf. You'll need to add \n at the ends of strings.
This User Gave Thanks to Corona688 For This Post:
# 5  
Old 09-04-2013
That seems to have worked! Thank you very much. Such a simple solution to my hours of headscratching.

Now just need to get that \n in the correct place and I'm Sorted Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #653
Difficulty: Easy
Rocky Raccoon is the mascot of MINIX 3.
True or False?

10 More Discussions You Might Find Interesting

1. Programming

Ncurses colors

I am using ncurses to develop a user interface. Perhaps I should be using something else, but I am reasonably comfortable with ncurses and don't really want to climb another learning curve at this time. One problem I have dealt with for many years is ncurses' colors. I have simply been... (23 Replies)
Discussion started by: BillLee
23 Replies

2. Shell Programming and Scripting

Problem with eval a generated and interpreted variable name and its value

Heya I have modified $HOME/.config/user-dirs.dirs to my like and the variables are properly 'structured' (XDG_XY_DIR="$HOME/YZ"). Now since i wrote a script to do that part, i currently stuck at the part to create a new .gtk-bookmarks file. Regarding code snippet: (bold part beeing... (2 Replies)
Discussion started by: sea
2 Replies

3. Shell Programming and Scripting

awk print: howto single quote not interpreted!?

cat a | awk -F";" '{print "update db set column=' "$2" ' where column1=\""$1"\";"}' > ip-add.sql Hi! I'm a new user! i need to use single quote in the double quotes print string The apex between che "$2" should not be interpreted, but....how?! I'm trying to use \ but don't work correctly! ... (4 Replies)
Discussion started by: Re DeL SiLeNziO
4 Replies

4. HP-UX

Vim colors in HP-UX

I am using xterm on my HP-UX system (11i). Color is working in xtrem, i can see that with the -color option on ls. When I use vim's syntax high lighting, instead of colors, it uses underline and bold (which looks horrible). I added the following if &term =~ "xterm" if has("terminfo") ... (2 Replies)
Discussion started by: kheisler
2 Replies

5. Shell Programming and Scripting

using colors in mailx

I want to use notify_fail () { echo " " >> ${MSG} echo " Script failed n">> ${MSG} cat ${MSG}|mailx -s "t1.ksh Success: "name@domain.com" exit 1 } I want script failed to show in Red or different colors in the email that i sent to name@domain.com I serached several sites and also... (1 Reply)
Discussion started by: konark
1 Replies

6. UNIX for Dummies Questions & Answers

Colors

Is there a way with the bourne shell to have different types of files show up a different color when you do ls? (1 Reply)
Discussion started by: resullivan
1 Replies

7. UNIX for Dummies Questions & Answers

Directory colors

Hey guys, When I used a Solaris box way back I had directory, file , symbolic link colors, etc... I can't seem to find the .dircolors file and how i set it up for bash on Solaris... anyone remember how to do it? Thanks! (2 Replies)
Discussion started by: kingdbag
2 Replies

8. Linux

linux colors

what dog gone file is setting these colors! i dont see it in bashrc or bash_profile!! anyone know? alias cp='cp -i' alias l.='ls -d .* --color=tty' alias ll='ls -l --color=tty' alias ls='ls --color=tty' alias mv='mv -i' alias rm='rm -i' alias vi='vim' alias which='alias | /usr/bin/which... (1 Reply)
Discussion started by: BG_JrAdmin
1 Replies

9. Solaris

Console colors

Guys i used to the black background in BSD, now im using Sun Solairs, how can i change the background and font colors in console ?, i heard about setterm but i didnt get the right syntax, any ideas ? (5 Replies)
Discussion started by: XP_2600
5 Replies

10. UNIX Desktop Questions & Answers

colors

Hello, I am somewhat new to linux. I just installed Red Hat 7.2 and when I try to load gnome or KDE in colors above 8bit it will kind of lock up and display some wierd scrambled cable look. I have an ATI Radeon 7000. I check out my monitor settings they are fine. Is it the graphics card? I set my... (1 Reply)
Discussion started by: Sage3k
1 Replies

Featured Tech Videos