Visit Our UNIX and Linux User Community


ipcs command


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers ipcs command
# 1  
Old 09-26-2001
Lightbulb ipcs command

Does anyone know how to set the variables with the ipcs command?

I need to set the following variables:
Shared memory segments
message queues
semaphore arrays
all of these
# 2  
Old 09-26-2001
ipcs simply reports information on IPC resources.

There is no "command line" way to change the values for the
IPC resources (and there shouldn't be). Depending on the
system you are running, you may be able just to change the
system tunable parameter values and reboot. On other systems
however, you may have to edit the system tunable parameters
and rebuild your kernel. This procedure is extremly system/OS
dependent and not recommended if you are new to UNIX.
You can render your system unbootable if you make a mistake
(or at the very least, hose up system performance). If nobody
but you relies or accesses the system then feel free to
expierement but be ready to do alot of reading.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #950
Difficulty: Medium
The first academic work on the theory of self-replicating computer programs was done in 1949 by Alan Turing.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

How to relate ipcs id or cpid to process?

Hi, we have multiple database instances running on solaris server like db1, db2 and db3. Below shown ipcs -pmb shared memory segment output. Using cpid value I want to relate to the database instances db1, db2 and db3. Please let me know how to do this? $ ipcs -pmb IPC status from <running... (9 Replies)
Discussion started by: baladelaware73
9 Replies

2. UNIX for Advanced & Expert Users

Ipcs do not show MODE

The ipcs -q command output includes a MODE column which tells user if the process is waiting on read or write on the queue. I used this in scripts on many systems (Solaris, AIX, SCO) a snippet from man MODE (all) The facility access modes and flags: The mode consists of 11... (2 Replies)
Discussion started by: migurus
2 Replies

3. Solaris

8 character limit for ipcs command , any way to increase # of chars ?

Hello All, We have a working script which identifies and kills ipcs resources which havent been correctly killed during normal shutdowns. It is working fine and dandy however there are some issues now. Environment: SunOS 5.10 Generic_148888-03 sun4u sparc SUNW,SPARC-Enterprise ... (4 Replies)
Discussion started by: icalderus
4 Replies

4. Solaris

IPCS COUNT clear

How to clear IPCS queue count in server? (2 Replies)
Discussion started by: Arasu123
2 Replies

5. UNIX for Advanced & Expert Users

Question on output of ipcs command

Hi, I read the ipcs man page and am still very confused. Basically, I just want to know whether the output from the ipcs command below means these are the current "TOTAL" memory usage in bytes on the server? Is this correct? Thanks in advance. ipcs command output below: # ipcs... (2 Replies)
Discussion started by: newbie_01
2 Replies

6. AIX

ipcs -m displaying empty

I am trying to run myApplication which allocates Some amount of shared memory at startup. It failed because not available shared memory are available. But when i ran, ipcs -m it is displaying empty(i.e no shared memory allocated in system.) Why "ipcs -m" is displaying empty ? ... (5 Replies)
Discussion started by: ashokd001
5 Replies

7. Solaris

ipcs Help

hi, I need help with ipcs command on Solaris. What does it do and what are options b,m,o,q does. Here is the sample output of ipcs -oq and ipcs -bm IPC status from <running system> as of Sun Sep 7 23:07:59 GMT 2008 T ID KEY MODE OWNER GROUP CBYTES QNUM... (4 Replies)
Discussion started by: krabu
4 Replies

8. AIX

ipcs command with out output

hello i'm running on aix 5300-08-02-0822 hacmp 4 when i run ipcs command there is nio output. some one got this problem? best regards ariec (1 Reply)
Discussion started by: ariec
1 Replies

9. Programming

ipcs shows no result in cygwin

Hi, With reference to the thread below: https://www.unix.com/showthread.php?s=&threadid=13247 I have the same program on Cygwin ( unfortuantely win ;( ) My program runs ( offcourse with undesired output) The semget does not give any error, tho I have trapped in case if there is one.... (0 Replies)
Discussion started by: linuxpenguin
0 Replies

10. Programming

System V and POSIX IPCs

I am using SUN 0S 5.7. My application has a dozen programs running in this machine, each instance of a program having 2 POSIX message queues for itself. Totally around 90 POSIX message queues. Another small application uses a SYSTEM V shared memory and a message queue. We face a problem... (1 Reply)
Discussion started by: Deepa
1 Replies

Featured Tech Videos