Visit Our UNIX and Linux User Community


Oracle problem with HPUX 11.0


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Oracle problem with HPUX 11.0
# 1  
Old 09-26-2001
Java Oracle problem with HPUX 11.0

HI all

I think i can get a perfect solution for our problem here.
we r using oracle 7i on hpux 11.0 as a billing server .The thing is it used to get hanged sometime and we need to unmount and need to mount the oracle DB then we need to start the oracle process.The process running in that server also used to struck sometimes we r restartng the server itself.
Our harddisk capacity is 9gb with 9gb mirroring and a memory of 1.5Gb .our processor is of 440Mhz Risca based.

thanks in advance for any solution to overcome this problem and need the reason why its behaving like this..

FrancisHI all
# 2  
Old 09-26-2001
Hmm... We have had a few freak happeneings here at work with our HP-UX11/Oracle 8/9 servers. Some of them were related to a number of HP recommended patches we applied - one of the patches "broke" certain operations on our affected Oracle processes. Has anything changed, or been patched/unpatched before this started?

Also, we had a small flaw in one of our memory modules, this cause some wierd, wacky behavior at random times. Have you checked any hardware issues, or had any problems with other components of the server?

It's odd that unmounting/mounting disks and restarting Oracle helps. Is your disk local, or stored externally or over the network? Either way, have you checked the connectors? Is the server well-cooled?

And finally, does this happen all at once, or does performance degrade prior to downtime? If you can, have your DBA run a trace. He should be able to troubleshoot Oracle-specific problems, like exessive disk I/O or problems initializing shared memory.

Let me know how the progress goes - I'm very interested to see what it ends up being...
# 3  
Old 09-26-2001
ALll this happen at once since its working as a billing server it stops to push(replicate) the data to the particular LDAP server which creates a lot of issue .The harddisks are external but not a NAS.As we are running the a lot of applications in other servers they doesnt create any issues like this.Is ther any major compatiblity probs or like that ?.We are able to communicate with the server on that time so i think it may not be a probs with the processor or other H/W ..cooling and all everything is ok .

if u need any info pls get back to me..

Thks for effort
Francis

Last edited by edwin_francis; 09-27-2001 at 03:56 AM..
# 4  
Old 09-27-2001
Hmm, well, how are you moving this data to the LDAP server? I don't know you're specific situation, but I would personally use something like this:

1) shut down Oracle
2) copy the files to another name on the same
disk, if possible (it'll be faster this way)
3) Re-start Oracle
4) Transfer the copied files to the LDAP server
5) Remove the local copy of the files

This should leave you with only minutes of downtime, and make sure that a file copy / move doesn't disrupt operations. Would this be feasible? It could easily be scripted and set to run in the middle of the night...

This might not the best solution, but it might work...
# 5  
Old 09-27-2001
we r using a process named Pin channel export to push those datas to Ldap from the billing.
due to the large capacity of data handled by oracle dbase we r struggling to shutdown it.Usually it hangs for hrs and then we opt to restart the server itself . This of course decrease the life of our server itself .since we r a isp here we need to have this setup of servers working without any interruption.

Regds
Francis
# 6  
Old 09-27-2001
Hmmm, what is happening when Oracle is struggling to shut down? Is your disk going crazy? Next time you try to shut it down, try running the glance utility while it's shutting down - see how your machine is doing...

Also, are you using "shutdown immediate"? If it is just sitting there, it might be waiting for every process to stop using it before it will shut down.


You also might try searching otn.oracle.com for some information. I can't be sure that it's an Oracle problem or a server problem... It might be a combination of both.

Sorry I haven't been of too much help on this matter - I myself do not administer Oracle here, so I have no idea what troubleshooting measures would be best for your situation.
# 7  
Old 09-27-2001
We r using shutdown immediate only but getting hanged at the same screen .if u type CTRL+c and come out of it after some hrs then u need to restart the oracle DB which is impossible since its not properly made down.

Anyway thanks for u r suggestions and efforts .


Francis

Last edited by edwin_francis; 09-27-2001 at 08:20 AM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #752
Difficulty: Medium
BIOS is an acronym for Bootstrap Input/Output System.
True or False?

10 More Discussions You Might Find Interesting

1. HP-UX

Problem in Configuring kerberos Server on HPUX

Hi, I am getting this error during kerberos server setup in HPUX 11.31 : kdb_create: unknown LDAP backend error while adding master entry to the database ps -ef|grep ldap root 3905 1 0 13:11:36 ? 0:00 /opt/ldapux/bin/ldapclientd Unable to find out the meaning of this... (1 Reply)
Discussion started by: Amit Kulkarni
1 Replies

2. HP-UX

hpux-itanium 64 bit problem for libC

i am trying to build on hpux-itanium 64 bit platform. my application needs to link to 64 bit version of the library libCsup.so This library is present in /usr/lib/hpux64/libCsup.so I am specifying the location of this library as linker flags LDFLAGS := -Wl,-N -Wl,+s... (0 Replies)
Discussion started by: skyineyes
0 Replies

3. HP-UX

pwage-hpux-T for Trusted HPUX servers

I'm sharing this in case anybody needs it. Modified from the original solaris pwage script. This modified hpux script will check /etc/password file on hpux trusted systems search /tcb and grep the required u_succhg field. Calculate days to expiry and notify users via email. original solaris... (2 Replies)
Discussion started by: sparcguy
2 Replies

4. HP-UX

Having problem with mounting in HPUX

Hi Gurus, I'm using HP-UX B.11.23 system. I've been having some problem in mounting a filesystem that has been defined in /etc/fstab as shown below. fstab entries: /dev/vgsap/ora10264 /oracle/PRD/102_64 vxfs rw,suid,nolargefiles,delaylog,datainlog 0 2 /dev/vgsap/orasapreog... (2 Replies)
Discussion started by: superHonda123
2 Replies

5. Shell Programming and Scripting

Need Script to Use CPUs on a HPUX server to simulate Workload Manager on HPUX.

I am running HPUX and using WLM (workload manager). I want to write a script to fork CPUs to basically take CPUs from other servers to show that the communication is working and CPU licensing is working. Basically, I want to build a script that will use up CPU on a server. Any ideas? (2 Replies)
Discussion started by: cpolikowsky
2 Replies

6. HP-UX

Installation of Oracle on HPUX 11.31

I am having issues the below issues:- As per the documents Preinstallation Tasks I have linked the following files :- # cd /usr/lib # ln -s libX11.3 libX11.sl # ln -s libXIE.2 libXIE.sl # ln -s libXext.3 libXext.sl # ln -s libXhp11.3 libXhp11.sl # ln -s libXi.3 libXi.sl # ln -s... (0 Replies)
Discussion started by: grayhorns
0 Replies

7. HP-UX

Problem with HPUX as NIS-Client

Hi all! I am running an NIS Server with Linux. Now I want to configure a HPUX-Server to use this NIS Server. I have don all the configuration stuff exactly as described in the documentation. When I run YPWHICH, it shows me the right server and domain. If I run YPCAT passwd, I'll get the... (4 Replies)
Discussion started by: pepade
4 Replies

8. Filesystems, Disks and Memory

HPUX 10.20 and RAID ARENA EX3 shutdown problem

Hello, I am having a Problem with an Arena EX3 Raid on an HPUX 10.20 Workstation. Everything is working fine until I shutdown the Server and power off the Raid. Then I get a filesystem corruption on the Raid. This happens everytime. The Raid is configured as Raid Level 1. I would really... (1 Reply)
Discussion started by: nleuenbe
1 Replies

9. HP-UX

HPUX Login Problem on the console

Hi Everyone, I have an HP3000 server on which I am unable to login to the server.I connected the server to my laptop thru a serial cable and I am unable to login thru any user ..when i enter my login id ..the system gets me back to the login prompt without asking me for a password. Cud u pls... (1 Reply)
Discussion started by: hunk
1 Replies

10. Programming

HPUX and Compaq problem-urgent

Hi All Following is the lines of code which simply makes a structure of 1 bit member and 7 bit is unused.Then the structure is initialised with char pointer.The output on HPUX(BIG Endian) and Compaq(Little Endian) are different.On HPUX it gives zero and Compaq it gives 1. I never thought that the... (7 Replies)
Discussion started by: Shobhit
7 Replies

Featured Tech Videos