Visit Our UNIX and Linux User Community


Solaris Sparc5 and connecting with a PC via Hyper terminal


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Solaris Sparc5 and connecting with a PC via Hyper terminal
# 1  
Old 09-24-2001
Solaris Sparc5 and connecting with a PC via Hyper terminal

I am trying to connect to a sparc5 with my PC via a null modem cable from serial port to serial port. I do not have a sun monitor so I am trying to use my PC. I am unsuccessful in even making the basic connection to the sparc box. Any ideas on how to work around this?
# 2  
Old 09-24-2001
On many Sparc boxes, there is a single
25 pin, serial connector that actually has BOTH
serial termial ports (ttyA and ttyB) wired to
it. This required a "Y" adaptor so that the
pinouts are correct to your null modem.

Is this the case with yours?
# 3  
Old 09-25-2001
make sure you unplug the keyboard to enable the serial port.
# 4  
Old 09-26-2001
I have two 25 pin serial ports, A and B. Is this an odd config? I purchased the box from my company as they were retiring it from service.
# 5  
Old 09-26-2001
No it's not an odd configuration.
Some of the smaller boxes only have the single
connector. Fortunately, you don't have to deal
with that "Y" adaptor.

Have you tried unplugging the keyboard as
Optimus_P suggested?
# 6  
Old 09-26-2001
Unfortunately I don't have a keyboard. I will have to use my PC via hyperterminal to configure the sun box. Then I will have to work via telnet. Not much fun.
# 7  
Old 09-26-2001
It's not as easy as it should be. I have never figured out how to connect to the console through the ASCII console port using Windows HyperTerminal, but would be interested in how it works. I do have a cable with the correct pinout to go from the DB9 COM1 port on the PC to the DB25 console port on the Sun box, but don't know what the actual pinout is. I am sure you can find it on http://docs.sun.com/ .Most Sun boxes use the same pinout, the new Netra T1's use a Cisco pinout. Anyway, once you have the correct cable, I know that ProComm will connect with the setting at 9600 baud and 8,n,1. Once you can connect to the host (press enter for a prompt), you can change the input and output device to ttya. From the ok prompt, enter:
setenv input-device ttya
setenv output-device ttya

or from the shell as root:
eeprom input-device=ttya
eeprom output-device=ttya

On a side note, though I didn't spend much time on it, I was unable to get an Ultra 10 to talk on the serial port, it would not boot without a keyboard/monitor Smilie We have an Ultra 5 at work that has no video card and the serial port works fine.

Sorry I can't help more.

Last edited by 98_1LE; 09-26-2001 at 11:10 PM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #288
Difficulty: Easy
In Linux, Logical Volume Manager (LVM) is a device mapper target that provides sound card I/O management for the Linux kernel.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Wireless connecting via CLI/Terminal

Do you use the CLI a lot and encounter new Wi-Fi sources, but don't want to/can't remember the commands to connect to the Internet?? I'm lazy. I mean, that's what scripting is for, right?? Efficiency means obtaining the maximum result with maximum laziness. I wrote this small script a while ago and... (0 Replies)
Discussion started by: Huitzilopochtli
0 Replies

2. UNIX for Dummies Questions & Answers

Problem connecting FreeBSD VM(Hyper-v) to internet

I created a VM for FreeBSD on hyper-v and i am having trouble connecting it to the internet. My virtual machine config are as below: 100 GB HD 1GB RAM Generation 1 Two Network adapters 1. Legacy Network Adapter 2. Network Adapter both are connected to network switch "Internet" which... (2 Replies)
Discussion started by: Vishawdeep
2 Replies

3. Solaris

Solaris ssh client hangs when connecting to another Solaris machine

Got a strange problem. I have 4 Solaris servers all configured the same, Solaris 10 x86 update 10. When I try to ssh from one Solaris 10 server to another server ssh hangs. I have an identical server and when I try this everything works fine. The weird thing is if I am root on the server... (1 Reply)
Discussion started by: ccj4467
1 Replies

4. Solaris

connecting to internet from solaris 10

hi there, hope your chakras are all doing well :-) just installed solaris 10 on my laptop, all seems fine except the internet. How can i connect on a DSL line?. spent 7 days and 3 nights trying but couldnt find the starting point.... alikun (22 Replies)
Discussion started by: alikun
22 Replies

5. UNIX for Dummies Questions & Answers

Connecting Solaris 10 to the Internet

This seems to be a common problem. I just installed Solaris 10 and do not have an internet connection. I am not that savy with Unix/Linux, although I have been using Linux in the past, and have never had any sort of problem detecting my internet connection. I have tried some things, but did not... (9 Replies)
Discussion started by: eric cartman
9 Replies

6. Solaris

Connecting Solaris from Window OS

Hi Experts, Recently I've purchased on laptop in which Window's Vista is the OS they have installed. With one of my friends help I've installed Solaris 10 using VMware. Both are working fine. Now I want to use putty to connect to Solaris from Windows OS. Also I want to use Ultraedit to open... (7 Replies)
Discussion started by: ganapati
7 Replies

7. Solaris

Connecting Solaris to Airport network

Hi, I've been trying to find out for the past two days how to set my Solaris 10 to join wireless network (Airport base station with ACL and wep or wpa on). Using ethernet is a bit out of question as I don't have an ethernet cable that would reach the other side of the house. Solaris 10... (1 Reply)
Discussion started by: giax
1 Replies

8. Solaris

Sun Server Hyper Terminal

Anyone know how to connect to a sun server using serial cable my client PC is also a Sun !!! I have the cable , just do not know how to start a terminal session in Sun . (1 Reply)
Discussion started by: civic2005
1 Replies

9. UNIX for Dummies Questions & Answers

New UNIX user connecting SOLARIS to XP

I am a new UNIX user. I am trying to connect a Windows XP laptop to a SOLARIS server. I have added the XPs hostname and IP address to the /ETC/hosts file. I am connecting through a hub. I am not able to telnet or ping in either direction. If I ping the server IP address on the server, I receive a... (8 Replies)
Discussion started by: jkuchar747
8 Replies

10. UNIX for Advanced & Expert Users

connecting to unix through hyper terminal - as a dumb terminal

I just changed from windows NT to XP and I am no longer able to connect to my unix system. I used to use hyper terminal -- which acts as dumb terminal to my main frame unix system. I think one of the options used to be "direct to comX". This option isn't listed now. I use a serial port and the... (2 Replies)
Discussion started by: michelle
2 Replies

Featured Tech Videos