Shell.....


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Shell.....
# 1  
hi
well I started with linux a few days ago but had worked with UNix on an NT server before but I am really stuck now. I have MAndrake 7.2 and usually it would start up and then show the shell login but that would dissapear and the GUI for linux would start up but once time i quit to console and now when I start up it just goes straight into the shell, I have tried kstart which I was told could start kde up again but all it said was cannot connect to X server

plz help Smilie

thanks
# 2  
Have you tried to shut down the server and reboot?

If you shut down and reboot and the problem persists, you have changed something which does not allow the Xserver to communicate or startup. There can be many reasons for this including network permissions or Xserver configuration errors.
# 3  
hmm well I havent changed any set ups and have tried init 5 which is meant to do it but as it loads the screen flickers and returns to the shell, I have tried rebooting and shutdown etc but are there any flags I should add to it that would start up the GUI and the nice colourful linux screen again? Smilie

Thanks
# 4  
I would contact Mandrake directly. Did you try calling or writing them?

The reason I suggest calling them is that debugging X problems take a lot time and it will be hard to do over the forum. Lots of files are required, including logfiles, network related files, X server config files.

It might just be easier for you do to a complete reinstall of the Mandrake software.

You could also use the FIND command to look at all the files that changed after it was working (look at the manpage on FIND for this) and see what configuration files might have been accidentally changes.
# 5  
thanks

well after much looking round on the mandrake site it gave me a url to a help site ;
http://www.mandrakeuser.org/

there they had some X setup tips and tried setup and things then I tried the startx command and it did what init 5 usually does but it showed an error after it failed saying it couldnt load a font and now I think before I restarted I did change the font, is there anyway I can change the font selection or setup?

thanks again Smilie
# 6  
Yes, not being able to find the a font could cause X to die. You need to find the X config file for the X server and change the font entry to one the system recognizes or exists (or find the fonts you choose and install them).

This is not a very easy task. Font packages are difficult, but you might be able to do it with patience Smilie

If you have not installed a lot of custom software, it might easier to do a new Mandrake install and be more conservative about changing default fonts. That might actually be faster than chasing down the font error.

If you are brave and want to try fixing it. Go to the directory /usr/lib/X11 and look the XF86Config.* files and start from that file and directory. Be careful. It is easy to make a mistake here that is hard to correct.
# 7  
You probably dont need to reinstall the whole system, just the missing font packages. Anyway, take alook at the bottom of this page: http://www.mandrakeuser.org/xwin/xtroub.html

It seems to be describing exactly your problem. Good luck.

 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #844
Difficulty: Medium
Bittorent, Gnutella and other distributed file transfers systems use do not user peer-to-peer, by default.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Pass C shell array to another C shell script(csh) and shell(sh)

Dear Friends, Please help me on this my script name is send.csh In this i have written the statement like this set args = ( city state country price ) I want to pass this array to another c shell called receiver.csh. and i want to use it in this c shell or how to pass to... (2 Replies)
Discussion started by: SA_Palani
2 Replies

2. UNIX for Dummies Questions & Answers

Shell script to read lines in a text file and filter user data Shell Programming and Scripting

sxsaaas (3 Replies)
Discussion started by: VikrantD
3 Replies

3. Shell Programming and Scripting

Any shell or hack that makes the shell command line take vi commands?

basically i'm tired of hitting the left arrow a few dozen times when correcting a mistake or modifying a history command i'd like to use vim style key shortcuts while on the command line so that a 55 moves the cursor 55 places to the left... and i want all the other vi goodies, search of... (3 Replies)
Discussion started by: marqul
3 Replies

4. Shell Programming and Scripting

calling 'n' number of shell scripts based on dependency in one shell script.

Hello gurus, I have three korn shell script 3.1, 3.2, 3.3. I would like to call three shell script in one shell script. i m looking for something like this call 3.1; If 3.1 = "complete" then call 3.2; if 3.2 = ''COMPlete" then call 3.3; else exit The... (1 Reply)
Discussion started by: shashi369
1 Replies

5. Shell Programming and Scripting

simple shell - how to get a parameter typed in a shell script

Hi, I am new to unix and using linux 7.2. I would like to create a script that would make it easyer for me to run my java programms. At the moment I have to type java myJavaprogram I am trying to write a script that will allow me to type something like this "myscript myJavaprogram" or maybe... (4 Replies)
Discussion started by: cmitulescu
4 Replies

6. Shell Programming and Scripting

How to run cmds after changing to a new env (shell) in a shell script

Hi, I am using HP-UNIX. I have a requirement as below I have to change env twice like: cadenv <env> cadenv <env> ccm start -d /dbpath ccm tar -xvf *.tar ccm rcv .... mv *.tar BACKUP but after I do the first cadenv <env> , I am unable to execute any of the later commands . ... (6 Replies)
Discussion started by: charlei
6 Replies

7. Shell Programming and Scripting

Help need to make a shell script run for ffmpeg vhook watermaking in shell

i have a small problem getting a batxh shell script to run in shell this is the code the problem seems to be centered around the ffmpeg command, something maybe to do with the ' ' wrapping around the vhook part command this is a strange problem , if i take the ffmpeg command and... (1 Reply)
Discussion started by: wingchun22
1 Replies

8. Linux

How to Start a Shell as Login shell instead of ordinary shell

Hi I tried with bash --login option. but the output is siva:~$ bash --login siva:~$ is there any way to make the shell ask for user id and password ( and login as different user instead of using sudo / su ) Thx in advance Siva (3 Replies)
Discussion started by: Sivaswami
3 Replies

9. AIX

Difference between writing Unix Shell script and AIX Shell Scripts

Hi, Please give me the detailed Differences between writing Unix Shell script and AIX Shell Scripts. Thanks in advance..... (0 Replies)
Discussion started by: haroonec
0 Replies

10. Shell Programming and Scripting

How to run unix commands in a new shell inside a shell script?

Hi , I am having one situation in which I need to run some simple unix commands after doing "chroot" command in a shell script. Which in turn creates a new shell. So scenario is that - I need to have one shell script which is ran as a part of crontab - in this shell script I need to do a... (2 Replies)
Discussion started by: hkapil
2 Replies

Featured Tech Videos