Visit Our UNIX and Linux User Community


Accessing Multi Hard Disk & theme


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Accessing Multi Hard Disk & theme
# 1  
Old 09-09-2001
Question Accessing Multi Hard Disk & theme

Hie,

Im having 2 Questions. Please help.

- Do Anyone know how to accessanother HDD using Linux? Ive tried many ways before but unable to do so. Im using 2 HDD, The main Hdd/Partition where my unix is are using Seagate HDD 20GB , another HDD is using Maxtor 20GB. From my seagate Hdd where my Linux is , i wanted to go to my Maxtor HDD where all my files and my C projects are. Can anyone help me with this.

- Does anyone know how to make my Linux ( Linux 2.2-16) to always use KDE as the default theme. Im having problem where, whenever im using Linux / started, at the Login i need to select the theme. If i didnt select the theme, it diects me to GNU. I wish to always use KDE. Is there any possibilities to do so.?

Hope i could have some answers.
Thank you guys.
# 2  
Old 09-09-2001
mount and profile

Access to other disks and filesystems are by mounting the disks using the mount command.

Default applications started by the shell are often specified in the /etc/profile file for all users and in .profile for specific users. This depends on the shell you are using, specified in the /etc/passwd file.
# 3  
Old 09-09-2001
mounting and profile

Hie Neo,
as u said earlier, that the system drives need to be mounted, using the mount command. Ive tried before. but unable to do so. Even thou im running as root. It keep on giving me an invalid bash command. And another thing im confused is which is my Second HDD. i can see there hda, hdb, Hd1, hdd, hd2, hd3, hd4, hd5, hd6 under my /dev . If its under /mnt im sure i can configure it out. But this looks quite complicated. Any idea or help perhaps.

thanks
# 4  
Old 09-09-2001
Please post the output of this command:

df

and also:

dmesg

From there we can help easily.
# 5  
Old 09-11-2001
Also, could you post the output of your error message along with the exact command you used? Copy and paste would probably be best there...
# 6  
Old 09-11-2001
Question

Hie Neo and LivinFree,
As i asked before for the Question of accessing Multiharddisk, ive been told to post the output of df and dmesg. Here im attaching you the df & dmesg outputs from my system. Hope my problem can come to a conclusion.

df output:

Filesystem 1k-blocks Used Available Use% Mounted on
/dev/hda5 12405000 1042040 10732812 9% /
/dev/hda2 23333 2480 19649 12% /boot
/dev/fd0 1423 0 1423 0% /mnt/floppy
/dev/hdd 626268 626268 0 100% /mnt/cdrom


dmesg output:

Linux version 2.2.16-22 (root@porky.devel.redhat.com) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release))
#1 Tue Aug 22 16:49:06 EDT 2000
Detected 350794 kHz processor.

Console: colour VGA+ 80x25

Calibrating delay loop... 699.60 BogoMIPS

Memory: 63884k/66496k available (1048k kernel code, 412k reserved, 1088k data, 64k init, 0k bigmem)

Dentry hash table entries: 262144 (order 9, 2048k)

Buffer cache hash table entries: 65536 (order 6, 256k)

Page cache hash table entries: 16384 (order 4, 64k)

VFS: Diskquotas version dquot_6.4.0 initialized

CPU: Intel Pentium II (Deschutes) stepping 02

Checking 386/387 coupling... OK, FPU using exception 16 error reporting.

Checking 'hlt' instruction... OK.

POSIX conformance testing by UNIFIX

mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)

PCI: PCI BIOS revision 2.10 entry at 0xfb480

PCI: Using configuration type 1

PCI: Probing PCI hardware

Linux NET4.0 for Linux 2.2

Based upon Swansea University Computer Society NET3.039

NET4: Unix domain sockets 1.0 for Linux NET4.0.

NET4: Linux TCP/IP 1.0 for NET4.0

IP Protocols: ICMP, UDP, TCP, IGMP

TCP: Hash tables configured (ehash 65536 bhash 65536)

Linux IP multicast router 0.06 plus PIM-SM

Initializing RT netlink socket

Starting kswapd v 1.5

Detected PS/2 Mouse Port.

Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled

ttyS00 at 0x03f8 (irq = 4) is a 16550A

ttyS01 at 0x02f8 (irq = 3) is a 16550A

pty: 256 Unix98 ptys configured

apm: BIOS version 1.2 Flags 0x07 (Driver version 1.13)

Real Time Clock Driver v1.09

RAM disk driver initialized: 16 RAM disks of 4096K size

SIS5513: IDE controller on PCI bus 00 dev 01

SIS5513: not 100% native mode: will probe irqs later

ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hdaSmilieMA, hdbSmilieMA

ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdcSmilieio, hddSmilieMA

hda: ST320413A, ATA DISK drive

hdb: Maxtor 52049H4, ATA DISK drive

hdd: ATAPI CDROM, ATAPI CDROM drive

ide0 at 0x1f0-0x1f7,0x3f6 on irq 14

ide1 at 0x170-0x177,0x376 on irq 15

hda: ST320413A, 19470MB w/1024kB Cache, CHS=2482/255/63

hdb: Maxtor 52049H4, 19470MB w/2048kB Cache, CHS=4945/128/63

Floppy drive(s): fd0 is 1.44M

FDC 0 is a post-1991 82077

md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12

raid5: measuring checksumming speed

raid5: MMX detected, trying high-speed MMX checksum routines

pII_mmx : 779.526 MB/sec

p5_mmx : 818.388 MB/sec

8regs : 601.980 MB/sec

32regs : 337.566 MB/sec

using fastest function: p5_mmx (818.388 MB/sec)

scsi : 0 hosts.

scsi : detected total.

md.c: sizeof(mdp_super_t) = 4096

Partition check:

hda: hda1 hda2 hda3 < hda5 hda6 >

hdb: [PTBL] [2482/255/63] hdb1

autodetecting RAID arrays

autorun ...

... autorun DONE.

VFS: Mounted root (ext2 filesystem) readonly.

Freeing unused kernel memory: 64k freed

Adding Swap: 72252k swap-space (priority -1)

usb.c: registered new driver usbdevfs

usb.c: registered new driver hub

usb-ohci.c: USB OHCI at membase 0xc4826000, IRQ 5

usb.c: new USB bus registered, assigned bus number 1

usb.c: USB new device connect, assigned device number 1

hub.c: USB hub found

hub.c: 2 ports detected

es1371: version v0.22 time 16:53:18 Aug 22 2000

es1371: found chip, vendor id 0x1274 device id 0x5880 revision 0x02

es1371: found es1371 rev 2 at io 0xe000 irq 10

es1371: features: joystick 0x0

es1371: codec vendor STM (0x53544d) revision 4 (0x04)

es1371: codec features Headphone out 20bit DAC 18bit ADC

es1371: stereo enhancement: no 3D stereo enhancement

Linux agpgart interface v0.99 (c) Jeff Hartmann

agpgart: Maximum main memory to use for agp memory: 28M

agpgart: Detected SiS 620 chipset

agpgart: AGP aperture is 64M @ 0xd8000000

parport0: PC-style at 0x378 [SPP,PS2]

parport_probe: failed

parpot0: no IEEE-1284 device present.

lp0: using parport0 (polling).

hdd: ATAPI 40X CD-ROM drive, 128kB Cache

Uniform CD-ROM driver Revision: 3.10

hdd: ATAPI 40X CD-ROM drive, 128kB Cache
-

Hope there is a conclusion on this problems.

Thanks
# 7  
Old 09-12-2001
Geez, I don't know why I didn't think of this before, but try this also:
whereis mount
/enter/full/path/to/mount

Then, you may want to add that to your default PATH variable by adding a line like this to your .profile or .bash_profile (whichever you're using - for Linux, probably bash):
export PATH=${PATH}:/enter/full/path/bin
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #520
Difficulty: Easy
In general, any number in base-10 can be written as the summation of powers of 10 multiplied by the numbers 0 through 9.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Solaris 8 - Accessing Hard Drives

Hi, I have two SCSI Hard Drives in a Sun Solaris 8 server as shown below. I would like to access Disk1 and look at its contents, directory structure and files. How do I change my default directory from Disk 0 to Disk 1 and vice versa? Thank you. (5 Replies)
Discussion started by: ssabet
5 Replies

2. Linux

C++ Code to Access Linux Hard Disk Sectors (with a LoopBack Virtual Hard Disk)

Hi all, I'm kind of new to programming in Linux & c/c++. I'm currently writing a FileManager using Ubuntu Linux(10.10) for Learning Purposes. I've got started on this project by creating a loopback device to be used as my virtual hard disk. After creating the loop back hard disk and mounting it... (23 Replies)
Discussion started by: shen747
23 Replies

3. SCO

declare disk driver for IDE hard disk

hi I've a fresh installation of SCO 5.0.7 on the IDE hard disk. For SCSI hard disk I can declare, for example blc disk driver using: # mkdev hd 0 SCSI-0 0 blc 0but it works for IDE hard disk? (3 Replies)
Discussion started by: ccc
3 Replies

4. Filesystems, Disks and Memory

Problem with accessing my 2nd hard drive

Hello I am having a problem with being able to use my 2nd hard drive as my new os doesn't recognize it. it is /dev/hdb2 and it shows as It is still in my system. it is a 73 gb hard drive and it is useless to me now. I used to have windows XP and had no problem with it,I have since changed to... (2 Replies)
Discussion started by: Donald Spauldin
2 Replies

5. SCO

I need a help with accessing the hard drive

Hello guys, I have got from a friend a hard disk which was used in the SCO OpenServer. He needs some data from it. I have no clue how to copy its content with Linux or Windows-I have tried few Linux distros but the result is always the same-the file system is not recognized so can't be mounted.... (4 Replies)
Discussion started by: kataro
4 Replies

6. Ubuntu

Accessing all of the hard drive...

Hi, I just downloaded and installed Ubuntu yesterday. It's the first time I have used it, so bear with me. I think I figured out how to get my sound drivers to work (X-Fi)... I had downloaded some OSS drivers, bout to go test them. But what I really want to know is... I have 2 hard drive,... (2 Replies)
Discussion started by: blind melon
2 Replies

7. Solaris

Problem Accessing disk

Basically Im Absolutely New to Opensolaris (Started Using It This Morning), Im Following A Tutorial On How To Access NTFS Partitions. Device Driver Utility Finds It And Says Everythings Fine With It DISK : ST3160022ACE Capacity : 160G Driver ... (7 Replies)
Discussion started by: xXCanisLupusXx
7 Replies

8. Filesystems, Disks and Memory

USB Pen Drive & Hard Disk

Hi Guys, I have an external USB Hard Disk Drive on which I have 3 partitions and it works fine under Windows XP but when I am using Red Hat Linux 5 I don't see any icon for this USB HDD. Also I am not able to browse my USB Pen Drive. However, I can use it under Mandrake Linux without any... (4 Replies)
Discussion started by: indiansoil
4 Replies

9. Filesystems, Disks and Memory

The best partitioning schem for a 250GB Sata hard drive & a 75GB SCSI hard drive

Hi I have 2 75GB SCSI hard drives and 2 250GB SATA hard drives which are using RAID Level 1 respectively. I wana have both FTP and Apache installed on them as services. I'm wondering what's the best partitioning schem? I wana use FC3 as my OS, so, I thought I can use the 75GB hard drive as the /... (0 Replies)
Discussion started by: sirbijan
0 Replies

10. UNIX for Dummies Questions & Answers

Multi disk hardware

Hi all, I purchased a pci controller card and a 3rd hard drive to put Linux on my machine. The card did not enable me to boot to the 3rd drive so I could not get Mandrake to install. My motherboard is a Gigabyte GA-7DXR+. Can anyone point me to a reasonable card/connector which will allow me... (2 Replies)
Discussion started by: onestepto
2 Replies

Featured Tech Videos