Getting the cc to work on unixmail


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Getting the cc to work on unixmail
# 1  
Network

Hi,
I am currently working on a VMS Oracle Forms application that requires mails to be sent from a unix mail box having built up the mail message from some SQL statements which is the mailed to the unix box.
I have it all working mighty fine, including the attachments necessary, but, for the life of me I cannot get it to send to the CC address.

I have the following SQL :-
SELECT 'To: <'||'&var7'||'>'||chr(10)||
'Cc: bevs_williams@carrotmail.com'||chr(10)||
'From: '||<snip>

And the To, From and the body works fine, (I use my work
email for '&var7') but it will not send to the Cc address.
Have I got the To,Cc and From in the right order? When I
receieve my mail, it does have the address bevs_williams@carrotmail.com on the line, but I don't get the mail.
Any pointers would be very much appreciated.
Regards,
Bev.
# 2  
Question

You need to post a copy of a text message with header information after all the SQL statements are done and the message is composed and ready to be sent. It would also be helpful to see the exact command that the UNIX platform is using to send the message.
# 3  
Neo,
This is the very top of the text file that is sent from
the vms instance by vms mail to the unix address which
then sends it on.

To: <ba.willia@elsevier.co.uk>
CC: <r.stevenson@elsevier.co.uk>
From: Mr A. Wood <a.wood@elsevier.co.uk>

Kidlington, 21 December 2000


I'm afraid I have had to snip the rest of the file due to
sensitive information.I have tried other combinations - putting the cc after the from but to no avail.

In the vms script this starts the SQL which creates the
letter into a .lis file.

START PTS_M111_EMAIL.SQL
then
$ CONVERT/FDL=PTS$FDL:STREAMLF PTS_M111_EMAIL_9999.LIS PTS_M111_EMAIL_9999.LIS
$ PURGE/NOLOG PTS_M111_EMAIL_9999.LIS
$ uuencode :== $ut_exe:UUENCODE
$ uuencode terms1.pdf
$ APPEND terms1.UUE PTS_M111_EMAIL_9999.LIS
$ MAIL/SUBJECT="Your paper SYNMET 54546 submitted to Synthetic Metals" pts_m111_email_9999.lis "pts.relay@elsevier.co.uk"

The pts.relay address will then forward on the mail using the .lis file top create the To from, cc and header.
This is the first time that cc has been required, but the rest works just fine.
# 4  
Thanks. Thanks for the header field. Still need the mailer. What mailer is the system using? elm? mailx? sendmail?


# 5  
Power

Neo,
I have managed to track down someone that is going to check that the cc part of email is supported in the script that is run, so hopefully I will get some joy from them. Thanks for your help and I hope you have a great Christmas and New Year.
Regards,
Bev.

[Edited by bevs_williams on 12-21-2000 at 10:27 AM]
# 6  
Since the UNIX platform sends the message, the UNIX mailer is the key to how RFC822 information (SMTP header information) is parsed. Not all mailers are equal. When you find out what mail is used and where it is being called, this will help you troubleshoot the problem.
# 7  
Quote:
This is the very top of the text file that is sent from the vms instance by vms mail to the unix address
There's the problem...you're using VMS! Smilie

 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #106
Difficulty: Easy
A kernel is at the heart of the Linux OS; and this kernel acts as an interface between the user and underlying hardware.
True or False?

10 More Discussions You Might Find Interesting

1. IP Networking

Discussion at work, would a router work pluging a cable in wan1 and lan1?

hi all. and sorry for the random question, but this sparkled a raging flame-war at work and i want more points of view situation a router, with linux of some sort, dhcp client requesting for ip in wan1 (as usual with wan ports) dhcp server listening in lan1, and assigning ip (as usual... (9 Replies)
Discussion started by: broli
9 Replies

2. Shell Programming and Scripting

My script work on Linux but not work in sunos.

My script work on Linux but not work in sun os. my script. logFiles="sentLog1.log sentLog2.log" intial_time="0 0" logLocation="/usr/local/tomcat/logs/" sleepTime=600 failMessage=":: $(tput bold)Log not update$(tput rmso) = " successMessage="OK" arr=($logFiles)... (7 Replies)
Discussion started by: ooilinlove
7 Replies

3. IP Networking

NIC will not work, but it did work.

I have a client machine that was built and loaded with SCO UNIX 2.1.3, (yes it is old). The machine worked fine on the closed network that I tested on in my shop. I then had to change it to the network that it would be connected to. Below is the host file, router and subnet mask file that I usually... (0 Replies)
Discussion started by: NC user
0 Replies

4. Shell Programming and Scripting

ls -d does not work

Hi falks, I need to dispaly a list of only directories . As it written in the manual ,the command to do it is 'ls -d'. When i issue 'ls -d' i'm getting: tornado.orca.ent:DB10g :/home/oracle/Create_Database > ls -d . Is anyone have any idea why id does not display directories ,or maybe... (11 Replies)
Discussion started by: nir_s
11 Replies

5. Linux

Come and work for me! (UK)

********nothing too see here!!!****** (2 Replies)
Discussion started by: TonyChapman
2 Replies

6. UNIX for Dummies Questions & Answers

cant get this to work

whoami | grep < $1 | echo $1 trying to write a script that finds out who the user is and then takes occurences of that username from a file that is passed as an argument and then displays it (6 Replies)
Discussion started by: iago
6 Replies

7. UNIX for Advanced & Expert Users

how does this work....

1|foo|bar 2|usa|ll 3|usa|vg 4|usa|vg 5|bar|vg 6|usa|vg 7|usa|ll 8|uk|nn 9|foo|manu|bar 10|uk|bb 11|foo|mm 12|kuwait|jkj 13|kuwait|mm 14|dubai|hh awk '/foo/,/bar/' test_file1----command run at the prompt output should have been the first 3 lines...... 1|foo|bar (1 Reply)
Discussion started by: bishweshwar
1 Replies

8. UNIX for Dummies Questions & Answers

Script doesn't work, but commands inside work

Howdie everyone... I have a shell script RemoveFiles.sh Inside this file, it only has two commands as below: rm -f ../../reportToday/temp/* rm -f ../../report/* My problem is that when i execute this script, nothing happened. Files remained unremoved. I don't see any error message as it... (2 Replies)
Discussion started by: cheongww
2 Replies

9. UNIX for Advanced & Expert Users

how does this work???

can someone tell me the meaning of this commnad, If you want to see a grand total of CPU time for a program when it finishes running, you can use the time command. At the Unix prompt, enter: time java myprog Replace myprog with the name of the program you are running. The following is an... (1 Reply)
Discussion started by: ldpathak
1 Replies

10. Shell Programming and Scripting

Will this work?

I'm trying to check if files already exist in a directory. They have the same basename (exsyctr1), but 4 different extensions. If the files exist, then I make backups of them, then copy them from another directory ($livecomp/data) to the current one ($copycomp/data). If they don't exist, just... (5 Replies)
Discussion started by: Ypnos
5 Replies

Featured Tech Videos