Visit Our UNIX and Linux User Community


Unmatched 'then'


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Unmatched 'then'
# 15  
Old 09-04-2001
The 'here' doc is the statements between EOF and EOF.

I am pretty sure the quoting is the problem because I vaguely remember bumping into it myself. Unfortunately I don't have access right now to one of the servers where we store similar scripts, so I can't check. Try to add the double quotes.
# 16  
Old 09-04-2001
Quote:
Originally posted by akpopa
Smilie Smilie Smilie Smilie

Now I am getting the 'then' unmatched again.

Here is exactly what the statement looks like:

if [ "$all_recs" = "NEW" ]
then

# Flush the staging table
echo "=== Cleaning the staging table..."
sqlplus -s $connect_string > /dev/null << EOF
begin
iws_clean_staging_pkg.iws_clean_staging_prc;
end;
/
EOF
fi;
Code:
#! /bin/ksh
all_recs=&ltenter your patern here&gt
connect_string=&ltenter your patern here&gt

if [[ $all_recs -eq "NEW" ]]; then

# Flush the staging table
echo "=== Cleaning the staging table..."
sqlplus -s $connect_string > /dev/null << EOF
begin
iws_clean_staging_pkg.iws_clean_staging_prc
end
EOF

fi

this is the way i would write it. i dont know why u had ";" after staging_prc or end and a continue to next line where EOF was. my suggestion one to many ";" not enuff "[]"; invalid if compairson operator.

also you can man test for more info. I would suggest that you get a copy of Learning the Korn Shell by oreilly as a great start to ksh shell scripting and for genearl knowledge about ksh. makes a great referance book.

Last edited by Optimus_P; 09-05-2001 at 12:17 AM..
# 17  
Old 09-04-2001
Doh

Forget the double quotes. I just remembered that we use 'su -c' in our scripts and then double quotes are required. Sorry for the mess Smilie
# 18  
Old 09-04-2001
patvdv--No problem about that, it gave me something new to try on this mess.

Optimus_P--I tried your suggestion, it still gives the 'then' unmatched error (Error Line number had moved up to that of the if line).

I did everything the way I did it because I am making some changes to someone---who is of course unavailable---elses code. They had some similar structures so I basically just adapted it for mine. These structures had the semi colon's and the '/' and worked just fine. As a matter of fact, everthing inside the if statement of mine works fine so long as it is not placed inside the if statement.

Thanks for trying and I appreciate your reading suggestion.

# 19  
Old 09-04-2001
an example

Hi Amber,

Let just try this by example.
Here is an example (excerpt)of a Bourne Shell
script (should run in ksh no problem) that I
use against Oracle 8.

========= snip snip ===========================

if [ $PHASE -gt 1 ] ; then
sqlplus -s $ORACLE_CONNECT_STRING << EOF
set heading off
set verify off
set feedback off
set serveroutput on
declare cnt number;
begin
select count(*) into cnt from VIS_LOC_AGG;
dbms_output.put_line('Table VIS_LOC_AGG has: ' || to_char(cnt) || ' records.');
select count(*) into cnt from LOCATION_AGG;
dbms_output.put_line('Table LOCATION_AGG has: ' || to_char(cnt) || ' records.');
end;
/
EOF
fi

========= snip snip ===========================

...this code outputs to stdout but I could have
easily redirected to some file (/dev/nul).
I hope this helps Smilie
# 20  
Old 09-04-2001
I have tried it that way as well with no luck. It's so strange, it's got to be some minor little thing, but for the life of me I can't figure out what it is. I am going to start fresh in the morning and see if that helps.

Thank you all for your help and suggestions.

Amber
# 21  
Old 09-05-2001
amber i apoligize i have just updated my last post please note that your variables should not start with a $.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #875
Difficulty: Medium
The primary mission of UNIX.com is to be a shell script writing forum.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

2. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

3. Email Antispam Techniques and Email Filtering

Procmail recipe: blocking 'unsubscribe and opt-out' messages....

Here is a crude procmail recipe that I quickly created (NOT a procmail recipe expert, btw) that has been catching lots of spam (current second after the charset_spam recipe posted earlier): :0B * .*If.you.do.not.wish.to.receive...* more_spam :0B * You.requested.to.receive.this.mailing... (0 Replies)
Discussion started by: Neo
0 Replies

4. IP Networking

BELKIN 'F5D5020' 16bit PCMCIA - FreeBSD HOWTO

Hey all, I've bought a few bits from Belkin who seem quite happy to support FreeBSD! Last time I bought a UPS from them and it's still going well :D I saw this on their website that the 16bit PCMCIA card was supported under FreeBSD: http://www.belkin.com/network/F5D5020.html I went to my... (0 Replies)
Discussion started by: WIntellect
0 Replies

5. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

6. Filesystems, Disks and Memory

HELP! The '/var/adm/message' file increase every few seconds???

Hi, guys, I have a big problem. I've got a sun solaris 4.1.4 workstation, and the /var/adm/message file will add one row every few seconds. It soon becomes a large file. I wander if there are some mistakes configuring the workstation. the /var/adm/message is as follow: ... (1 Reply)
Discussion started by: cloudsmell
1 Replies

7. UNIX for Advanced & Expert Users

Terminal 'Local Echo' lost on Modem Dial-out

Can anybody help me? I am developing a utility for automating message paging to a BT alphanumeric pager. I am using a USR 56K Fax-modem connected to /dev/cuab on a Sun Ultra-10. I am using the UNIX 'tip' utility to connect to the modem and I have configured the modem as follows: Baud Rate:... (2 Replies)
Discussion started by: mybeat
2 Replies

8. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

9. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies

10. UNIX for Dummies Questions & Answers

How to subtract 2 hours from 'date' in shell ( /bin/sh ) script ?

I write a sh script that zip and copy to tape all files that older then 2 hours. 1. The way I choose is - touch a file with "now - 2 hours", then use fine with '! -newer' 2. Do you have any other idea to do it ? tnx. (1 Reply)
Discussion started by: yairon
1 Replies

Featured Tech Videos