How to Untar tar.gz to particular directory


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers How to Untar tar.gz to particular directory
# 1  
Old 05-29-2012
How to Untar tar.gz to particular directory

Hi Guys,

I am able to untar a tar.gz file. But it is again extracting the tar file to further child directory.

I even tried the below command to untar it to particular directory.
Code:
tar -zxvf gme_dly_sls_20120515035335.txt.tar.gz -C /sites/VSTAR/site/live/ftp/GMEUROPE

I am getting the below errors.

Code:
tar: appl: Cannot mkdir: Permission denied
tar: appl/data/VSTAR/global_daily/input/GME/gme_dly_sls_20120515035335.txt: Cannot open: No such file or directory
sites/VSTAR/site/live/ftp/GMEUROPE/globaldaily_download/gme_dly_sls_20120515035335.ctl
tar: sites: Cannot mkdir: Permission denied
tar: sites/VSTAR/site/live/ftp/GMEUROPE/globaldaily_download/gme_dly_sls_20120515035335.ctl: Cannot open: No such file or directory
tar: Exiting with failure status due to previous errors

Can somebody help me out here.

Cheers!!!!
# 2  
Old 05-29-2012
Start by looking if the archive was created with relative OR absolute path:
Code:
gzcat gme_dly_sls_20120515035335.txt.tar.gz | tar - tvf - | more

If its absolute PATH you are doomed...( well it becomes very hard ...)
# 3  
Old 05-29-2012
As advised above, first check whether the archive was created with absolute paths. If it was, then do not proceed with tar. Either get the archive re-created with relative paths (recommended) or consider using the unix pax command to unpack the archive and alter the target paths (not easy - try with test data first).

Quote:
tar -zxvf gme_dly_sls_20120515035335.txt.tar.gz -C /sites/VSTAR/site/live/ftp/GMEUROPE
The directory in the -C command must exist already. All tar does is issue a "cd" to that directory and then start extracting files. If the archive contains absolute paths, the -C parameter is irrelevant. If the directory does exist, make sure that you are using the root account or an account which has permission to create subdirectories with arbitary permissions.

Please remember to post what Operating System and version you are running.
# 4  
Old 05-29-2012
Hi Guys, thanks for your answers,,,

Yes the tar is created using the absolute (/usr/...... ) path only.
The path /sites/VSTAR/site/live/ftp/GMEUROPE is already present.. maybe i should try with pax command. Smilie

can somebody help me out with pax... its the first time i am hearing the command. Smilie
# 5  
Old 05-29-2012
Something like
Code:
pax -s '/\/usr\//.\//' -r < inputfile

I think. The -s expression is a regex like '/original/replacement/'. A lot of backslashes needed to get /'s in there unfortunately.

Last edited by Corona688; 05-29-2012 at 03:45 PM..
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Untar only folder structure from a tar ball

I have a tar file hello.tar which is 95 GB. hello.tar has many files and folders including some tar files as well. I wish to create a new tar ball which should maintain only the folder structure of hello.tar and the tar ball within the hello.tar So basically the idea is to untar... (2 Replies)
Discussion started by: mohtashims
2 Replies

2. Shell Programming and Scripting

scp/untar .tar file in parallel issue

Hi Guys, I am facing a strange issue while doing parallel (using & for background) scp/untar operation from my unix box to multiple unix boxes... I am getting tar : unexpected EOF in archive error the code is as follows.,,, for i in 10 do sh -c "scp <command> ; ssh tar -xf <tar> -C... (4 Replies)
Discussion started by: mihirvora16
4 Replies

3. Red Hat

tar/untar over ssh

I use red hat linux. I have two linux server . I want to use tar over ssh to tar and untar the file. The server A , have IP 10.1.1.a ,there is dir a and contain files. The server B have IP 10.1.1.b , there is dir b and contain file . So, in above case ,how can I tar over ssh sunc that the file... (0 Replies)
Discussion started by: chuikingman
0 Replies

4. UNIX for Advanced & Expert Users

tar and untar the files using single line

Hi, i want tar the files from one location and untar it to other location using single line. Can any one help me zip and unzip using single line command. (2 Replies)
Discussion started by: venikathir
2 Replies

5. UNIX for Dummies Questions & Answers

untar a tar file

how can I untar a file without extracting it? sample: file.tar to file thanks, lara (1 Reply)
Discussion started by: lhareigh890
1 Replies

6. UNIX for Dummies Questions & Answers

tar and untar commands

I have a script to ftp, archive and delete files. I used tar command to archive files from a list and then all files were removed from name1/name2/name2/. find /name1/name2/name2/ -name "*.txt" -print > filelist.log while read line do if ; then tar cvf $tarfile $line else ... (3 Replies)
Discussion started by: Lenora2009
3 Replies

7. Shell Programming and Scripting

Script to untar latest tar file

I am trying to put together a script that will check for the latest file in a directory then extract it. The extraction and the scheduling I can do, but am not sure how to get it to check for the latest file. These files are uploaded every evening by an external party and the previous days files... (3 Replies)
Discussion started by: stheologo
3 Replies

8. UNIX for Advanced & Expert Users

Tar utility (untar a .tar file) on VxWorks

Hi All Can someone pls guide me if there any utility to compress file on windows & uncompress on vxworks I tried as - - compressed some folders on windows ... i created .tar ( to maintain directory structure ) and compressed to .gz format. - on VxWorks i have uncompressed it to .tar... (1 Reply)
Discussion started by: uday_01
1 Replies

9. UNIX for Dummies Questions & Answers

Untar a TAR file at different location

Hi, I want to UNTAR a TAR file at different location. Is it possible? My TAR file contains the files with absolute path. Malay (5 Replies)
Discussion started by: malaymaru
5 Replies

10. UNIX for Advanced & Expert Users

gnu tar applying user:group to untar

When I, or any other user, tar -xzvf file.tar.gz the resulting uncompressed directory/file has the owner:group of a user on my system, but not that of the user who untared it. How can this be? Is there a .conf file for gnutar that I'm not aware of? Details: --> running RedHat 7.1 --> 45... (4 Replies)
Discussion started by: vancouver_joe
4 Replies
Login or Register to Ask a Question

Featured Tech Videos