Visit Our UNIX and Linux User Community


permission denied??


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers permission denied??
# 1  
Old 08-09-2001
permission denied??

i'm trying to set up my internet connection and i was told i need to edit the file
/etc/ppp/pap-secrets
but i get a permission denied message...why??
# 2  
Old 08-09-2001
Maybe u did not login as root
or maybe u do not have write access
# 3  
Old 08-09-2001
i did login as root...but i'm not sure if i have write access...how can i check?
# 4  
Old 08-09-2001
hi justchillin,

if you do a "ls -l" at your promt, you will get to see something like this...

"drw-r--r-x" or "-rw-r--r-x".

Here after 'd' next 3 characters represent the root. In the above case "rw-" indicate that the root has Read, and Write permissions.
Similarly you can check for your desired file as

ls -l {filename}
In your case it should be
ls -l pap-secrets

Jay.

Last edited by Jayathirtha; 08-09-2001 at 02:40 AM..
# 5  
Old 08-09-2001
Tools factoid "caution on root logon"

A word of caution....... it is NOT adviseable to surf the internet or to be logged on for extended periods of time with "Root" permissions.

Why? :???

Well, if somebody gains control of your machine, and you have "super-user" powers, they do too! Think of the implications here.

Solution Smilie
You can open a terminal and temporarily logon as "root" and do what you need to do, then close that terminal and/ or logoff the terminal and you have an ordinary account again.

Smilie Smilie Smilie TipSmilie Smilie Smilie
Most folks do a dual boot to a unix flavor so as to keep the windows partition. If this windows partition was compromised prior to the unix install then, the unix partition is also open to exploit.
One should try to do a clean install on a machine without a dual boot partition if one possibly can,however; this is not always possible.


joetech



# 6  
Old 08-09-2001
thanks for the replies i will try that out when i get home tonight...
# 7  
Old 08-10-2001
ok well i tried and it didn't work...i have edited all the individual files but how do i get them to run each time i try to connect to the internet (i think that is what is supposed to happen)...i still get "modem is busy" messages???

oh, and how do i know if my ethernet card is configured properly??

i don't know any unix guru's so i'm relying on you all...

thanks

 

Previous Thread | Next Thread
Test Your Knowledge in Computers #677
Difficulty: Medium
The IEEE does not test equipment for compliance with their standards.
True or False?

10 More Discussions You Might Find Interesting

1. Ubuntu

Permission denied

Trying to get date into the txt file. It says Permission denied. echo $(date +%I:%M:%S_%D) >> /tmp/systemd_suspend_test_err.txt exec 2>> /tmp/systemd_suspend_test_err.txt if ; then # Do the thing you want before suspend here echo "we are suspending $(date +%I:%M:%S_%D)." elif ;... (5 Replies)
Discussion started by: drew77
5 Replies

2. UNIX for Dummies Questions & Answers

Permission denied

when i run echo "User” > /dev/tty5 why do i get permission denied? :confused: (2 Replies)
Discussion started by: chinababy
2 Replies

3. Linux

Permission denied

I am using korn shell When I type in Telnet on cmd line, I get message "cannot execute" How can I get permission to execute command ? In which dir is telnet located ? I looked in /usr/bin dir. but its not there Thanks (1 Reply)
Discussion started by: paramshamnani
1 Replies

4. Shell Programming and Scripting

Permission denied

I created a user so that when he logs in he will be directed to a menu /etc/passwd user1:x:115:1:Support -SysAd:/export/home/user1:/export/home/suppotrmenu/script.sh However when I logged in remotely from another server by ssh user1@1.1.1.1 , it saysexport/home/suppotrmenu/script.sh:... (4 Replies)
Discussion started by: lhareigh890
4 Replies

5. Red Hat

Permission denied

Hi guys im new to this db i have a small prob while installing websphereportal6.1i think i was installed succesfully but the error im getting is while starting server. check this out # ./serverStatus.sh -all Error loading: /usr/wps61/AppServer/java/jre/bin/classic/libjvm.so: cannot... (1 Reply)
Discussion started by: varma917989
1 Replies

6. UNIX for Dummies Questions & Answers

Permission denied

I would like to copy data from local mechine to cluster. Basically, I typed scp -r DVD/ acount@cluster:/ it shows Permission denied. Could anyone please give me a clue to write permission on cluster, please? The poperty of where on cluster I'd like to put is drwxr-xr-x Any idea would... (1 Reply)
Discussion started by: su_in99
1 Replies

7. UNIX for Dummies Questions & Answers

Why do I keep getting .:Permission denied?

I'll start off by saying that I know very little about Unix - however, I do know that I have a .profile file in my home directory, and that I should be able to invoke it by typing . profile. However, when I do this for ANY .filename, I get ".: Permission denied". I'm pretty sure that there is... (12 Replies)
Discussion started by: bbersani
12 Replies

8. UNIX for Advanced & Expert Users

Permission denied

Hi, I can not execute a .env file $ . /Data/oracle/d03/mydbora/8.0.6/MYDB.env -bash: /Data/oracle/d03/mydbora/8.0.6/MYDB.env: Permission denied Even if : -rwxrwxrwx 1 oracle dba 2903 Mar 5 2007 /Data/oracle/d03/mydbora/8.0.6/MYDB.env Please help. Many thanks. (1 Reply)
Discussion started by: big123456
1 Replies

9. UNIX for Dummies Questions & Answers

Permission Denied

I just started computer science at UW Milwaukee. When I access the university Solaris system from PuTTY, I get permission denied when I try to access the file I wrote. Now I really have no idea what I'm doing, I just don't understand why I get permission denied in my won directory. Thank You ... (0 Replies)
Discussion started by: howeezy
0 Replies

10. UNIX for Dummies Questions & Answers

./ Permission Denied.

Could someone tell me why I am getting a permission denied message when I attempt to run this on an out file? Thanks! (8 Replies)
Discussion started by: trouscaillon
8 Replies

Featured Tech Videos