Problem to upgrade CPAN

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem to upgrade CPAN
# 1  
Old 08-14-2011
Problem to upgrade CPAN

Hi all,

Since yesterday, I'm trying to upgrade CPAN on my Synology sevrer, because I have the next message in CPAN shell :

cpan> install cpan
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
CPAN: Compress::Zlib loaded ok
Going to read /root/.cpan/sources/modules/02packages.details.txt.gz
  Database was generated on Sun, 14 Aug 2011 01:37:48 GMT
CPAN: HTTP::Date loaded ok

  There's a new version (v1.9800) available!
  [Current version is v1.7601]
  You might want to try
    install Bundle::CPAN
    reload cpan
  without quitting the current session. It should be a seamless upgrade
  while we are running...

CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
Going to read /root/.cpan/sources/modules/
Going to write /root/.cpan/Metadata
Warning: Cannot install cpan, don't know what it is.
Try the command

    i /cpan/

to find objects with matching identifiers.

But it is impossible for me to upgrade it. Whatever I'm writing in shell, I have this same message.

When I'm writing "perl -MCPAN -e shell", I had the next message, is it normal ???
Synology> perl -MCPAN -e shell
Terminal does not support AddHistory.

There seems to be running another CPAN process (pid 5403).  Contacting...
Other job not responding. Shall I overwrite the lockfile? (Y/N) [y]

Could you help me please ?
I don't know what should I do now ?

Thanks for your help. Mikael.

Last edited by mikael2235; 08-15-2011 at 02:59 AM..
# 2  
Old 08-14-2011
post output from:

ps -ef|grep 5403|grep -v grep

# 3  
Old 08-14-2011
Synology> ps -ef|grep 5403|grep -v grep
ps: invalid option -- e
BusyBox v1.16.1 (2011-06-29 11:49:19 CST) multi-call binary.

Usage: ps

Report process status

        w       Wide output

Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. AIX

AIX 7.1 Upgrade problem

Hi all, I'm getting errors while booting AIX 7.1 after upgrade I have used FLRT tool for the process with the following input values shown in the attached photo. titled FLRT After reboot for the upgrade process system hangs and no response as shown in screenshot named AIX7.1-NormalBoot I... (13 Replies)
Discussion started by:
13 Replies

2. Solaris

Problem in SVM after live upgrade

Hi I am new to live upgrade. I would like to tell you about my new setup, where my boot disk(c0d0) is mirrored with secondary disk(c0d1). I have remove the secondary whole disk(C0d1) from the mirror, so that I can do live upgrade on this secondary disk. I have done live upgrade on s0 partition... (3 Replies)
Discussion started by: amity
3 Replies

3. Shell Programming and Scripting

cpan installation

Hi All, I need to install perl module using cpan, so befor that i checked cpan is installed or not . i tried , and got below output.but it is not clear to me. can u plz explain me. I dont know what the exactly cpan is useful. and in below why it is trying to create directory. $ cpan... (2 Replies)
Discussion started by: aish11
2 Replies

4. Solaris

Problem with live upgrade creation: Telling me metadevices do not exist

Hi I am having a problem creating my live upgrade environment. Here is the error I get: root@server:/# lucreate -c SOL10_18May -n SOL10_19May -z /lu_excludelist -m /:dev/md/dsk/d0:ufs -m /var:/dev/md/dsk/d4:ufs -m /export/home:/dev/md/dsk/d6:ufs -m -:/dev/md/dsk/d3:swap -C... (0 Replies)
Discussion started by: notreallyhere
0 Replies

5. Shell Programming and Scripting

Error while trying to install from CPAN

Hi i was trying to install Text::CSV from cpan... it seemed to have downloaded everythign properly but was not able to run the make file... do u have any idea as to why this happened?? Install: ============================= If you install Text::CSV_XS v.0.70, it makes Text::CSV faster. ... (5 Replies)
Discussion started by: VGR
5 Replies

6. Shell Programming and Scripting

Perl - problem with CPAN module XML::Simple

Hi All, I am trying to run the following program #!/usr/bin/perl # use module use XML::Simple; use Data::Dumper; # create object $xml = new XML::Simple; # read XML file $data = $xml->XMLin("dump.xml"); # print output print Dumper($dump); At first i had the error mesage saying... (5 Replies)
Discussion started by: userscript
5 Replies

7. Shell Programming and Scripting

CPAN: using only wget to d/l modules?

Is there a way to tell CPAN not to use Net::Ftp and the ftp binary? I want to only use wget to download perl modules. (2 Replies)
Discussion started by: dangral
2 Replies

8. Solaris

DVD drive problem after upgrade to Solaris 10

After upgrading to solaris 10 (from sol 8) on a SUN Blade 1500, it seems that the dvd/cd-rom does not accept dvds nor cds in the dvd drive. After I insert a dvd/cd in the drive, the disk is simply ejected (!) Is it possible that the upgrade made the system not being able to recognize these... (2 Replies)
Discussion started by: miket
2 Replies

9. AIX

Disk upgrade problem

I've tried to upgrade the 9gb drives in our F50's to 18gb. The system with original drives would boot up in about 4 min., but with the 18gb drives takes 17 min. Running 4.2.1. What am I missing here?? (5 Replies)
Discussion started by: mooshkie
5 Replies
Login or Register to Ask a Question