check service is running at boot

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers check service is running at boot
# 1  
Old 06-28-2011
check service is running at boot


am having solaris 10, and i would like to know if the NTP service is running when the OS staritng?on the other hand how can i make it start at the boot up?note the ntp is managed by the SMF in solaris 10.

thanks a lot
# 2  
Old 06-28-2011
# svcs -a | grep ntp

should show you the status. for more detailed information, you can use,
# svcs -l svc://network/ntp

to enable it, i.e. make it start at boot time, provided you have done the proper configurations,
# svcadm enable svc://network/ntp

# 3  
Old 06-28-2011
so as the service is enabled, it will start automatically as the system is rebooted right?

---------- Post updated at 06:22 AM ---------- Previous update was at 06:20 AM ----------

these the info i got:

bash-3.00$ svcs -l ntp
fmri svc:/network/ntp:default
name Network Time Protocol (NTP)
enabled false
state disabled
next_state none
state_time Sat May 14 08:25:01 2011
restarter svc:/system/svc/restarter:default
dependency require_all/error file://localhost/usr/sbin/ntpq (online) file://localhost/usr/sbin/ntpdate (online)
dependency require_any/error svc:/network/service (online)
dependency optional_all/error svc:/milestone/name-services (online)

its disabled,but am not sure if i enabled it and the system reboot it will start automatically?
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. AIX

Start script or service with boot on AIX 7.2

I have installed apache2, but not run with boot in AIX 7.2, how to make it run ? in AIX 7.1 i used : mkitab "apache:2:once:/usr/IBMAHS/bin/apachectl start > /dev/null 2>&1" ### ---> not work in AIX 7.2 (i use 0 in once, because appear emoticon when use :once) Did you know that you can use... (4 Replies)
Discussion started by: penchev
4 Replies

2. Shell Programming and Scripting

Checking to see if windows service is running

Hi I have created a PowerShell script which successfully checks whether windows service pgsql-9.2 is running. I have tried to call that PowerShell script with a shell/bash script within a LINUX machine but have been unsuccessful. Is there a way of a shell/Perl script to check whether a... (5 Replies)
Discussion started by: simpsa27
5 Replies

3. Solaris

Checking if service is running

Hi, For audit reasons, I need to stop the web server service in some Solaris servers. The port that is listening for this service is port 10000. This is the output that shows the port 10000 is open in the server : # netstat -an | grep 10000 49640... (6 Replies)
Discussion started by: anaigini45
6 Replies

4. Red Hat

How a service is always running ?

Hi How ssh service at all levels always running in her file /etc/inittab? vi /etc/inittab 10::respawn:/etc/init.d/sshd I added this line & save run init q But it did not (6 Replies)
Discussion started by: mnnn
6 Replies

5. Red Hat

Service restart and check if running

Hello, I'l like to create a script that restart a service (/etc/init.d/httpd restart) and also check if after restart the service is actually running. Sometimes it happen that at the first try the service fails to restart. Thanks (2 Replies)
Discussion started by: bazzola
2 Replies

6. Linux

How to check a particular service is running on Linux?

We are using TeamSite application. Its a content management system application. How can I check if TeamSite service is running or not using ksh onn Linux platform ? On Windows its easy, I can do services.msc and entire list will come up. How to check it in Linux ? I tried using 'ps -ef', it... (4 Replies)
Discussion started by: paramshamnani
4 Replies

7. HP-UX

Found service running during audit

Hello all! During a network audit, I came across a host running a service on a high port (34604). Not recognizing the port, I used a tool called 'amap' (THC-AMAP - fast and reliable application fingerprint mapper) to fingerprint it. This tool also did not fingerprint it correctly, but did... (2 Replies)
Discussion started by: dan.king
2 Replies

8. Solaris

How to be sure the dns service is running ?

Well, i changed my lan card and finally i got it up and running, i have /etc/resolv.conf with domain nameserver and it was working with me earlier with the old lan card, with the new one i added it ip using auto-dhcp and its received an ip from my dhcp and it can ping... (4 Replies)
Discussion started by: XP_2600
4 Replies
Login or Register to Ask a Question