Sendmail process "Toomany" system slowing down

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Sendmail process "Toomany" system slowing down
# 1  
Old 06-25-2011
Sendmail process "Toomany" system slowing down

Hello Experts

I have M4000 Solaris 10 server, from few many days there are too many sendmail and mail.local process starting on server and each time i need to kill mannualy using pkill send mail, some time there will 600 of them taking 30mb memory for each and hence slowing down the server, here is sample of process

HTML Code:
 root  7062  7061   0 07:01:58 ?           0:00 mail.local -l
    root  7060  7059   0 07:01:58 ?           0:00 mail.local -l
    root  6739  6540   0 07:00:52 ?           0:01 /usr/lib/sendmail -bl -q15m
   smmsp  5532  5531   0 06:30:50 ?           0:02 /usr/lib/sendmail -Ac -q15m
    root  6966  6739   0 07:01:27 ?           0:00 /usr/lib/sendmail -bl -q15m
    root  6540     1   0 06:54:20 ?           0:00 /usr/lib/sendmail -bl -q15m
    root  7052  7051   0 07:01:55 ?           0:00 mail.local -l
    root  7065  6739   0 07:01:59 ?           0:00 /usr/lib/sendmail -bl -q15m
 infodba  1794  1725   0 22:17:08 pts/1       0:00 -ksh
    root  7059  6739   0 07:01:58 ?           0:00 /usr/lib/sendmail -bl -q15m
    root  7035  6739   0 07:01:51 ?           0:00 /usr/lib/sendmail -bl -q15m
    root  5137  4284   0 06:20:05 pts/4       0:00 bash
    root  7067  6739   0 07:02:00 ?           0:00 /usr/lib/sendmail -bl -q15m
    root  6541  6540   0 06:54:20 ?           0:02 /usr/lib/sendmail -bl -q15m
    root  6937  6936   0 07:01:21 ?           0:00 mail.local -l
    root  7037  6739   0 07:01:52 ?           0:00 /usr/lib/sendmail -bl -q15m
when i do "pkill sendmail" it will kill send mail but still there will be be couple of hundread "mail.local" like below Smilie

HTML Code:
 root 21898     1   0 01:49:20 ?           0:02 mail.local -l
    root  1262     1   0 04:55:23 ?           0:01 mail.local -l
    root 23541     1   0 02:19:35 ?           0:01 mail.local -l
    root 29603     1   0 04:19:36 ?           0:01 mail.local -l
    root 24275     1   0 02:35:43 ?           0:01 mail.local -l
    root  1502     1   0 04:59:04 ?           0:00 mail.local -l
    root 22605     1   0 02:03:34 ?           0:02 mail.local -l
    root 29120     1   0 04:11:44 ?           0:01 mail.local -l
i did check mail and it was showing a cronjob alert, i even disabled the cron. but still these mail process keeps growing with time

Appreciate all the and questions if any


after doing all these here is again new process started

smmsp 7176 1 0 07:02:21 ? 0:00 /usr/lib/sendmail -Ac -q15m

After kill all process, and i login as user infodba i get alert i have a mail
will give this output

----- Transcript of session follows -----
infodba... Deferred: Connection refused by []
Message could not be delivered for 5 days
Message will be deleted from queue
Content-Type: message/delivery-status
Reporting-MTA: dns;
Arrival-Date: Sun, 19 Jun 2011 18:36:05 +0530 (IST)
Final-Recipient: RFC822;
Action: failed
Status: 4.4.7
Remote-MTA: DNS; []
Last-Attempt-Date: Sun, 26 Jun 2011 06:57:27 +0530 (IST)
Content-Type: message/rfc822
Return-Path: <infodba>
Received: (from infodba@localhost)
by (8.14.4+Sun/8.14.4/Submit) id p5JD65ID000485
for infodba; Sun, 19 Jun 2011 18:36:05 +0530 (IST)
Date: Sun, 19 Jun 2011 18:36:05 +0530 (IST)
From: infodba
Message-Id: <>
To: infodba
Subject: Output from "cron" command
MIME-Version: 1.0
Content-Type: text/plain
Your "cron" job on ie10ux014
/tcpdv1_ie10/tcadmin/bin/listusers 2>&1
produced the following output:
You MUST BE LOGGED in as infodba to run this shell script, exiting...


but i have already disabled this, but still why i am recieving mail/alert?

Last edited by karghum; 06-25-2011 at 10:46 PM.. Reason: more details
# 2  
Old 06-26-2011
If you don't need sendmail, then disable it by running:
svcadm disable smtp:sendmail

# 3  
Old 06-26-2011
Deferred: Connection refused by []
Message could not be delivered for 5 days
You are still receiving these emails because they have been queued for up to 5 days and have been unable to deliver to the intended recipent.

The default "sendmail" does not give up easily.

To view the queue:

Either your email configuration is faulty or the target address is wrong. It can't send mail to for some reason.

I also suspect that there is a cron examining the mail queue which may be running from a script which is not exiting. Just a theory.
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

What does "force devmap reload" as in "multipath -r" means for my system and stability of my system?

Cannot present unpresented disks back again. On a test server tried this as a solution "multipath -r" and it worked. Too worried to try it in production before I know all the information. Any info would be appreciated! Also some links to the documentation on this specific issue could help a... (1 Reply)
Discussion started by: jsteppe
1 Replies

2. Shell Programming and Scripting

Bash script - Print an ascii file using specific font "Latin Modern Mono 12" "regular" "9"

Hello. System : opensuse leap 42.3 I have a bash script that build a text file. I would like the last command doing : print_cmd -o page-left=43 -o page-right=22 -o page-top=28 -o page-bottom=43 -o font=LatinModernMono12:regular:9 some_file.txt where : print_cmd ::= some printing... (1 Reply)
Discussion started by: jcdole
1 Replies

3. Shell Programming and Scripting

awk "date" and "system" command

Hello experts! I need your help please I have a file.txt of which I want to extract 3rd and 4th columns with date with the form e.g.: 2016-11-25 03:14:50and pass them to "date" command, but also append the 9th column in a file as well. So I want to execute date -d '2016-11-25 03:14:50' ... (2 Replies)
Discussion started by: phaethon
2 Replies

4. UNIX for Dummies Questions & Answers

Using "mailx" command to read "to" and "cc" email addreses from input file

How to use "mailx" command to do e-mail reading the input file containing email address, where column 1 has name and column 2 containing “To” e-mail address and column 3 contains “cc” e-mail address to include with same email. Sample input file, email.txt Below is an sample code where... (2 Replies)
Discussion started by: asjaiswal
2 Replies

5. Shell Programming and Scripting

Checking running process status using "grep" on multiple servers in load sharing system.

Suppose i have 3 different servers say x,y and z. Im running some process say ABC and 40 instances for the same is being created. In load sharing suppose on server x, 20 instances are running server y, 10 instances are running server z, 10 instances are running. While checking the... (1 Reply)
Discussion started by: ankitknit
1 Replies

6. UNIX for Advanced & Expert Users

Sendmail: how to restrict delivery based on "to" or "from"?

Hello, I manage a large sendmail server that handles more than 20,000 pieces of mail per day. It's a bit unusual in that all this mail is only being sent to and from 4 local accounts. (It's an automated transaction processing system, whereby users submit a transaction via email attachment). ... (2 Replies)
Discussion started by: lupin..the..3rd
2 Replies

7. Shell Programming and Scripting

awk command to replace ";" with "|" and ""|" at diferent places in line of file

Hi, I have line in input file as below: 3G_CENTRAL;INDONESIA_(M)_TELKOMSEL;SPECIAL_WORLD_GRP_7_FA_2_TELKOMSEL My expected output for line in the file must be : "1-Radon1-cMOC_deg"|"LDIndex"|"3G_CENTRAL|INDONESIA_(M)_TELKOMSEL"|LAST|"SPECIAL_WORLD_GRP_7_FA_2_TELKOMSEL" Can someone... (7 Replies)
Discussion started by: shis100
7 Replies

8. Red Hat

"service" , "process" and " daemon" ?

Friends , Anybody plz tell me what is the basic difference between "service" , "process" and " daemon" ? Waiting for kind reply .. .. (1 Reply)
Discussion started by: shipon_97
1 Replies

9. UNIX for Dummies Questions & Answers

Explain the line "mn_code=`env|grep ""|awk -F"=" '{print $2}'`"

Hi Friends, Can any of you explain me about the below line of code? mn_code=`env|grep ""|awk -F"=" '{print $2}'` Im not able to understand, what exactly it is doing :confused: Any help would be useful for me. Lokesha (4 Replies)
Discussion started by: Lokesha
4 Replies
Login or Register to Ask a Question