Visit Our UNIX and Linux User Community


Command not found error


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Command not found error
# 1  
Old 06-06-2011
Command not found error

I have a program called abc installed in /usr/local/bin.
My path is as follows:
Code:
# echo $PATH    
/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin

However, when entering the abc command, the following error appears:
Code:
# abc
abc: Command not found

When entering the command with the full path, the program does start:
Code:
# /usr/local/bin/abc
abc>

How do I make abc start from the command line without having to type in the full path?

Last edited by figaro; 06-06-2011 at 07:17 PM.. Reason: Removed typo
# 2  
Old 06-06-2011
First type:
Code:
which abc

Then you can change the order of your PATH to include the directory where "abc" is located before the location of the other "abc".
# 3  
Old 06-07-2011
Thank you for your answer. In this particular case:
Code:
# which abc
/usr/local/bin/abc

# 4  
Old 06-07-2011
Put in your script. do not export PATH=/sbin:/bin:..... directly.
Code:
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
export PATH

abc

# 5  
Old 06-08-2011
Thank you for your response. Can you explain exactly what the code does and which part needs to be executed? Thank you in advance.
# 6  
Old 06-08-2011
Quote:
Originally Posted by figaro
Thank you for your response. Can you explain exactly what the code does
Sets PATH to /sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
Quote:
and which part needs to be executed?
All of it
# 7  
Old 06-08-2011
Assuming that the "export" does not fix your problem, please check the output from:
Code:
alias
ls -lad /usr/local/bin/abc
file /usr/local/bin/abc



Ps: We have all assumed that you are using a modern Bourne-like Shell (e.g. bash) on a mainstream Operating System. If it is something unusual like BusyBox or "csh" please state your environment.

Last edited by methyl; 06-08-2011 at 09:09 PM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #396
Difficulty: Medium
HP-UX was the first Unix to offer access control lists for file access permissions as an alternative to the standard Unix permissions system.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Error : command not found

Hi , I am an Oracle developer. trying to write a shell script to compile all the forms that are modified in last 1 hour. Script Body cat cmp.sh for f in `find ./*fmb* -mmin -60`; do "`frmcmp_batch.sh userid=ba/ba@testdb batch=yes module=$f module_type=form compile_all=yes... (2 Replies)
Discussion started by: imrandec85
2 Replies

2. Shell Programming and Scripting

Command not found error 'then'

Could you let me know if my path is having bourne bash echo $PATH /u01/app/oracle/product/10.2.0/db_1/bin:/usr/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/oracle/bin $ which bash /bin/bash $ which ls alias ls='ls --color=tty' /bin/ls Below is... (3 Replies)
Discussion started by: csguna6
3 Replies

3. UNIX for Dummies Questions & Answers

Command not found error

$ cat nu who | wc -l $ ls -l nu -rwxr-x--- 1 _ _ 11 Jul 30 12:37 nu //the nu is displayed in green color $ nu bash: nu: command not found I am using a book from 1986 on Unix System V, Release 3, and the Unix system I am connecting to is from my college. Below is the notes from the book:... (4 Replies)
Discussion started by: chip
4 Replies

4. Shell Programming and Scripting

while loop error. (command not found)

can any1 please tell me what is problem with following code: i=1; cat test| while read CMD; do Var$i=$CMD; or Var$i=$(echo $CMD) ; let i++ doneI keep getting error : line 4: Var1=sometext: command not found (2 Replies)
Discussion started by: kashif.live
2 Replies

5. Linux

command not found error

I installed in VM the Mandriva Linux. But when I fire the make command it gives me command not found error. Seems make is not installed. I also checked in Mandriva control center and no development package is seen there. Will pls let me know how to proceed and get make and other development... (2 Replies)
Discussion started by: rupeshkp728
2 Replies

6. UNIX for Advanced & Expert Users

BreakPoint Command Not found error

I have Suse linux-2.6.31.5-0.1. When I try to set breakpoint in application or kernel modules it gives me command not found error. For instance when I typed the command b xyz.c:47 it gives me an error: "If 'b' is not a typo you can use command-not-found lookup the package that contains... (4 Replies)
Discussion started by: rupeshkp728
4 Replies

7. Shell Programming and Scripting

command not found error

hello every time i run the following code for val in fileX fileY fileZ do $val=`ls -l $val | awk '{print $5}'` done i got error message command not found , i tried to add ' and " but nothing works its only worked wen remove $val= but i want the name of the file and the value ... (9 Replies)
Discussion started by: mogabr
9 Replies

8. Shell Programming and Scripting

Command not found error!

Hello everyone, I am using Linux and tcsh shell. I am trying to run a free open source program( which is in the form of a binary file), but every time I run it it gives me an error saying: newhtsg_v1.0:Command not found. I have set permission also for the same. What else can I do to make... (4 Replies)
Discussion started by: ad23
4 Replies

9. Red Hat

Command Not Found Error?

Hi, I am beginer to Linux. I have installed Redhat Linux AS 4.0 on my System.Later I created a User Oracle10g for Installing Oracle.Then I logged onto Oracle10g user and crated a Bash Profile and when I run that profile there was an error in that Profile. from then If I type any of Linux Command... (2 Replies)
Discussion started by: praswer
2 Replies

10. UNIX for Dummies Questions & Answers

Error ^M not found while using read command

Hi guys, i have a script called readnametest.i had written like this # !/bin/ksh echo "enter your name please" read x; echo " your name is $x" i am getting an error like "readnametest.ksh: ^M: not found." while executing this one.Could any one please explain me on why this... (4 Replies)
Discussion started by: raoscb
4 Replies

Featured Tech Videos