Visit Our UNIX and Linux User Community


Um, this is lacking sense


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Um, this is lacking sense
# 1  
Old 08-03-2001
Question Um, this is lacking sense

Hello, and good day


I'm somewhat confused with the workings of the Linux operating system, more specifically RedHat 7.1.

The story began a few weeks ago when I downloaded SuSe 7.2, but failed at installation, then Caldera 2.4, then 3.1. Finally I landed upon RedHat 7.1--a fabulous choice.

I've run into a few dilemmas, with this OS. I've exhausted my other resources and I've not been able to understand their instructions.

My problems are as follows: Firstly, my configuration PIII 700Mhz, two 20GB hard drives, (one with Linux and windows ME, the other basically storage)

Now the problem: I can't get to Windows ME!, the boot process begins and loads RedHat 7.1, the screen asks whether I would like to boot to DOS, or Linux. The Linux boot is fine, but DOS just does not work, it just hangs and does nothing. The screen displays 'loading DOS' and that's it.

Second problem, I connect to the internet using ADSL (Bell Sympatico High Speed Edition) on my windows machines I use a PPPOE program called Access Manager, I think there is a PPPOE program bundled with RedHat. I believe I have set it up correctly, for the fact that I was able to get on the net and browse until I rebooted? I don't understand now I'm not able to!

Oh, and while I'm here, how do I install a program. I've been looking for those damn .exe files, but obviously they're nowhere to be found, and I don't know how to install a program.

Thankyou all in advance,




JD


Oh, yes, I have attempted searches for this information, but answers that I find I can't comprehend, so be gentle Smilie
# 2  
Old 08-03-2001
on installing a program:

in linux, if the file ends in .rpm, you can do this:

--
rpm -i filename.rpm
--

i for install.




on the booting problem:

if you can't fix this and you need to get some files from your windows partition, you can do that from linux. you need to find out where your windows partition is in the /dev directory. it might be hda2. well, the first hard drive is hda# and the second is hdb# the third hdc# and so on, # being partition number, or something along those lines. keep in mind i'm not sure about how your hard disk partitions are named. you need to look in /dev yourself and guess/check.

--
mkdir /windows
mount /dev/hda2 /windows
cd /windows
--

uh yea. if anyone reads this and anything i said is wrong, please correct me.

okay,
-nydel
# 3  
Old 08-03-2001
Most likely, if you installed Linux second, your windows should be located on /dev/hda1. Secondly, did you partition your drive before installing Linux? I've installed Mandrake without first partitioning through windows or DOS and it attempted to partition the drive during the Mandrake setup. It failed miserably and I had to reinstall windows. As stated above, you can mount the windows partition from Linux and retrieve your files.

And a note on installing... since you appear to be a newbie, I doubt this will make a lot of sense to you unless you've done any kind of programming... BUT, you can download source files, complile them, and create the executables yourself if you don't have the RPMs. And since you downloaded the RH package, I'm guessing it didn't come with all the RPMs that a distro pack comes with. But hey, if this doesn't help, or you don't understand, please post back.
# 4  
Old 08-05-2001
ahhhhhhhhhhhhhh

I've tried your suggestions, and i cant seem to find anything about windows in the /dev directory. I did however, find many different hda's but when i clicked on them nothing happened. When i typed /dev/hda1 into Konqueror, a window poped up asking what i would like to open the file with?

I did make a partioin before I installed linux. I made it with Partion Magin 4.0, I set it so it would make it a linux partition.

But one thing that is EXTREMLY scary, is that prior to intallation, I used PQDI to make a drive image and burned it onto CD's. This was my bakcup in case all else failed. BUT the boot disks dont work! It asks me to insert a valid system disk! i dont even know what that means.

And if all i need is a few files from windows, could I not then get them from my windows restore CD's?

Could anyone give me some imput on my situation, please.

Thanks for any help,



JD
# 5  
Old 08-05-2001
reinstall windows. maybe that would do something.

as for getting your windows files from linux, you need to do this:

open a terminal. it sounds like you're using kde so you should be able to get one somewhere on the k-menu or on the taskbar.

when you get a terminal do this:

<b>su</b>

it will prompt you for the root password, so type it in. then do

<b>mkdir /windows</b>
<b>mount /dev/hda1 /windows</b>
<b>cd /windows</b>
<b>ls</b>

this should list all of your windows files. if it doesn't, installation of linux might have messed up you windows partition, or something like that.

you can take one of two approaches now. first, you can copy the entire contents of your windows partition to /usr/win like this:

<b>cp /windows /usr/win</b>

or you can just copy whichever files you want

<b>mkdir /usr/win</b> (do this only once)
<b>cp /windows/<i>path&filename</i> /usr/windows</b> (do this for each folder/file)

have a lot of fun...



okay,
-nydel

Last edited by nydel; 08-05-2001 at 08:08 PM..
# 6  
Old 08-06-2001
Quote:
Originally posted by nydel
mkdir /windows
<b>mount /dev/hda1 /windows</b>
cd /windows
ls

It should be :
<b>mount -t vfat /dev/hda1 /windows</b>

Otherwise it will fail to mount windows partition.
# 7  
Old 08-06-2001
Re: ahhhhhhhhhhhhhh

Quote:
And if all i need is a few files from windows, could I not then get them from my windows restore CD's?

[/B]

Make a Linux bootdisk ( dd if=/newest-kernel of=/dev/fd0 )

Get a dos boot floppy with fdisk on it, and boot from it and type "fdisk /mbr". If windows works fine after a reboot, boot linux using the bootdisk and edit /etc/lilo.conf ( make sure boot=/dev/hda in lilo.conf). Run /sbin/lilo. It should display "added Linux and windows" message if everything ok.

 

Previous Thread | Next Thread
Test Your Knowledge in Computers #759
Difficulty: Medium
Commodore filed for bankruptcy in 1994 and its assets were purchased by a German PC manufacturer who created the subsidiary company Amiga Technologies.
True or False?

8 More Discussions You Might Find Interesting

1. AIX

Sense Data Layout

On AIX 7.1 we have errors with SC_DISK_ERR4 label. In document "Fibre Channel Planning and Integration: User's Guide and Service Information" I can find SENSE Data description in section "PCI Fibre Channel Adapter, SCSI-3 Protocol (Disk, CD-ROM, Read/Write Optical Device) Error Log Sense... (1 Reply)
Discussion started by: Dmitriy
1 Replies

2. UNIX for Advanced & Expert Users

sar -d output... does not make sense

Can someone explain the correlation between how sar names the disk drives and how the rest of the OS names the disk drives? sar lists my disk drives as sd0, sd1, sd2, etc..... while format lists my disk drives as c1t0d0, c1t1d0, c1t2d0,etc... And also why sar shows 8 disks but format... (2 Replies)
Discussion started by: s ladd
2 Replies

3. UNIX for Dummies Questions & Answers

Homework questions, book is lacking answers?

Hey you guys, There's a couple questions I cannot find the answers to anywhere in this book for my Operating Systems class, hopefully you guys could help. I believe we are in the Bourne shell. 1. Match each description to the appropriate type of variable Used in shell programs ... (7 Replies)
Discussion started by: KyleBucket
7 Replies

4. Shell Programming and Scripting

diff result makes no sense

Hi, I have written a small shellscript Imagine dbalt.txt already existed... " .... touch report.txt lynx -dump "http://site.com/index.htm" > site1.txt lynx -dump "http://site.com/index2.htm" > site2.txt grep -E 'Nummer: |EUR' site1.txt > preis1.txt grep -E 'Nummer: |EUR' site2.txt >... (2 Replies)
Discussion started by: Blackbox
2 Replies

5. UNIX for Dummies Questions & Answers

trying to make sense of rsync output...

I'm running the following rsync command to sync a directory between the 2 servers: rsync -az --delete --stats /some_dir/ server_name:/some_dir I'm getting the following output: Number of files: 655174 Number of files transferred: 14221 Total file size: 1138531979331 bytes Total... (0 Replies)
Discussion started by: GKnight
0 Replies

6. Solaris

Sense Key: Media Error

Hi all, We have below WARNING in /var/adm/messages file from our Solaris server. WARNING: /sbus@1f,0/SUNW,fas@e,8800000/sd@0,0 (sd0): Error for Command: write(10) Error Level: Fatal Requested Block: 16745265 Error Block: 16745269 Vendor: SEAGATE Serial Number:... (8 Replies)
Discussion started by: summerboy
8 Replies

7. UNIX for Dummies Questions & Answers

Simple grep - Not sure it makes sense!

I have 3 files in directory mydir named as follows, I run the sequence of commands shown below and I have questions at the result. File names are: ABC_GP0 ABC_GP0.ctl ABC_GPX Commands and results: $ ls /mydir/ | grep * <-- (q1) I get nothing - OK $ ls /mydir/ | grep... (5 Replies)
Discussion started by: GNMIKE
5 Replies

8. Linux Benchmarks

Linux Benchmarks Makes No Sense

I created two computers with identical hardware, and run the benchmark programs in both starting at the same exact time. What makes no sense is that the computer that has the lower average index (121) finished the race a good 30 minutes ahead of the computer wich showed the higher avg index... (0 Replies)
Discussion started by: philip_38
0 Replies

Featured Tech Videos