Visit Our UNIX and Linux User Community


How to mount fat16 partition


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers How to mount fat16 partition
# 1  
Old 07-23-2001
How to mount fat16 partition

Hello,

I am trying to mount a FAT16 and FAT32 partition on an already installed Redhat system.

I have tried to edit the fstab and mtab, and to put in the data I got from fdisk, but it just says cannot find it.

The information given by fdisk on /dev/hda is:
Code:
Device        Boot  Start     End      Blocks      Id     System
/dev/hda1    *           1     100     201568      6        FAT16
/dev/hda2             101     658   1124928      5        Extended
/dev/hda5             626     658       66496    82        Linux Swap
/dev/hda6             101     625   1058337    83        Linux

my /etc/fstab contains:
Code:
LABEL=/        /                     ext2        defaults                           1  1
/dev/fd0        /mnt/floppy    auto        noauto,owner                 0  0
none             /proc              proc         defaults                          0  0
none             /dev/pts         devpts     gid=5,mode=620            0  0
/dev/hda5     swap              swap       defaults                          0  0
/dev/cdrom   /mnt/cdrom     iso9660   noauto,owner,kudzu,ro  0  0

my /etc/mtab contains:
Code:
/dev/hda6  /  ext2  rw  0  0
none   /proc  proc  rw  0  0
none  /dev/pts  devpts  rw,gid=5,mode=620  0  0
automount(pid539)  /misc  autofs  rw,fd=5,pgrp=539,minproto=2,maxproto=3  0  0

I have been trying to figure out the changes myself but this is about the only subject I cannot locate *any* info on. This computer only has a FAT16 partition, but I also have another one that has a FAT32 partition that I would like to access, I poresume the methods are the same....

Cheers in advance

Last edited by Yogesh Sawant; 10-21-2010 at 07:35 AM.. Reason: added code tags
# 2  
Old 07-23-2001
Computer

I found it myself at last:

for anyone interested here is the solution:

if you know which hard drive the partition is on then use fdisk on that drive ('fdisk /dev/hda' for me) and type 'p' to get a list of partition info.

next you need to locate which poartition, I need to access hda1.

quit fdisk and make a directory to use as a mount point ('/home/win' for me)

edit the fstab to include the line
Code:
/dev/hda1           /home/win                vfat    defaults        0  0

and voila next time I boot, it is recognised.
If I just want to mount it once, I type:
Code:
mount -t vfat /dev/hda1 /home/win

or mount -t [filesystem] [device] [mount point]

Happy days,

Last edited by Yogesh Sawant; 10-21-2010 at 07:35 AM.. Reason: added code tags
# 3  
Old 07-23-2001
Hi,

Have you tried adding the following to your /etc/fstab file:
Code:
/dev/hda1 /mnt/msdos msdos  auto

I think the msdos file type should work okay for fat16 filesystems.

For fat32 filesystems you'll need to add vfat for the fs type.

i.e. a partition named /dev/.hda8 add the following to fstab:
Code:
/dev/hda8 /mnt/fat32 vfat  auto

Of course you'll need to ensure that the mount directories have been created before mounting the directories.

To mount the fat16 partition you'd type:
Code:
mount /mnt/msdos

or
Code:
mount /dev/hda1

I hope this helps.

Andy Smilie

Last edited by Yogesh Sawant; 10-21-2010 at 07:36 AM.. Reason: added code tags
# 4  
Old 07-23-2001
cheers,
The above solution is working fine for me, and I set file type to vfat (fat was not recognised as an option to mount) but it works fine for me.
When I tried DOS as a filesystem, it was rejected, I see now that I should have used MSDOS.
Cheers for the tip,
# 5  
Old 07-23-2001
That's okay.

Supported modules for your system's kernel can be found in:
/lib/modules/kernelversion*

* kernel version can be found from the /proc/system/kernel/osrelease file.

The exact location for modules can vary, on my system fs modules are in
/lib/modules/2.4.6/fs

Andy Smilie

 

Previous Thread | Next Thread
Test Your Knowledge in Computers #304
Difficulty: Easy
sed is a stream editor and is used to perform basic text transformations on an input stream (a file or input from a pipeline).
True or False?

10 More Discussions You Might Find Interesting

1. OS X (Apple)

Can I mount partition at given dir path

Hi, In Linux, I had modified fstab file which used to mount ~/Music, ~/Pictures, etc with disk partitions containing corresponding content or binding directory located at other partition. But I am wondering can I do same in El-Capitan as well? No linking! /media/L-Store/Desktop/Documents ... (0 Replies)
Discussion started by: ezee
0 Replies

2. AIX

Can't mount a partition

Hello, today i get some aix errors (can't lock files and strange things) then i umount FS to do a fsck but i get these errors root@omega / > fsck -p /dev/fslv06 The current volume is: /dev/fslv06 Unable to read primary superblock. Unable to read either superblock. I readed on this page... (9 Replies)
Discussion started by: thorin666
9 Replies

3. UNIX for Dummies Questions & Answers

Mount UEFI partition

I want to gain read/write access to a Windows 8 partition from a linux live cd. Prior to Windows 8, I used ntfs-3g to mount the partition from the command line. The "Fdisk -l" command does not seem to be able to read efi partitions. There must be some new strategy for linux users. This is... (6 Replies)
Discussion started by: jamarsh
6 Replies

4. UNIX for Dummies Questions & Answers

mount extended partition

Hello, Im new here, and may be my question is stupid, but... Today I run PGP Desktop decript on my 2nd partition ( D:\ ) and when decript finish, I restart my PC.Now when I try to open D:\ its give me: D:\ is not accessable and I lose my files :( So I load Linux live CD ( knoppix ) and try to... (1 Reply)
Discussion started by: mrowcp
1 Replies

5. Red Hat

Grub Error 17: Cannot mount selected partition.

I dualboot Ubuntu and Fedora in one hard drive. Below are the scenario. First, installed Ubuntu 10.4 on the entire disk (40GiB of size). Then, shrink the Ubuntu installation to equal size to free up space for fedora. Second, installed Fedora 13 using the option "Use free space on selected... (2 Replies)
Discussion started by: etcpasswd
2 Replies

6. Solaris

can not mount the selected partition

Dear Brothers First i installed suse linux with the following partition. my hd0 size is 75gb hdc1 swap 1 gb hdc2 native linux 39gb For the rest of the 35 gb i did not create any partition. so i planned to install solaris 10x86 on that free space. When i installed the solaris i... (1 Reply)
Discussion started by: sayed_021
1 Replies

7. UNIX for Dummies Questions & Answers

I've created a partition with GNU Parted, how do I mount the partition?

I've created a partition with GNU Parted, how do I mount the partition? The manual information at http://www.gnu.org/software/parted/manual/parted.html is good, but I am sure about how I mount the partition afterwards. Thanks, --Todd (1 Reply)
Discussion started by: jtp51
1 Replies

8. SCO

/ partition is mounted but not present in mount

Hello , I 've got a problem with the root partition on my SCO 5.0.5 . When I check the disk with df or mount , I can 't see the root filesystem . # mount /stand on /dev/boot read only on Tue Sep 05 16:13:51 2006 /home on /dev/home read/write on Tue Sep 05 16:14:41 2006 But , if I try... (3 Replies)
Discussion started by: npn35
3 Replies

9. Solaris

how to mount other partition?

dear all, that is my problem : c0d0p1 is nt, c0d0p2 is solaris and other on extended partition is pcfs, so how can i mount it somewhere? because i dont know which one connect from raw to block dev. /dev/rdsk/c0d0p? any help would be great... :) (6 Replies)
Discussion started by: stdout
6 Replies

10. Solaris

can't mount a partition

Hello, I have a problem on my sun station, that run solaris7. To free temporarly a little space on /, I moved a few empty folders (mnt, net, awk, tftpboot) to the /home partition. Unfortunately the system froze just after this...maybe I should not have move this files, I don't know, I am a... (3 Replies)
Discussion started by: nabulus
3 Replies

Featured Tech Videos