Visit Our UNIX and Linux User Community


bash: setting arrays


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers bash: setting arrays
# 1  
Old 07-19-2001
bash: setting arrays

Ok, I searched the threads a couple of times but couldn't find anything really relevant. Here's my problem, maybe you can help:

I am running version 1.14.7 of the bash shell, on Red Hat Linux. I am trying to set an array like so:

bash$> letters=(x y z)

spaces are between the letters but not between the parenthesis and the equals

Now, on version 2.01.1 running on a Sun machine that command works fine, the array set properly, but for some reason it won't take on the older version. This must mean that i'm doing it wrong and the old version has a different way to set arrays. If someone knows the answer as to whether or not you can do this on the old version and how it's done, i would really appreciate it.

The catches are that the one system is not mine and I don't have the authority to upgrade the bash shell to the newer version, and the scripts I wish to create and run must be run on the system with the old bash shell. I've also checked the bash manual for this old version and didn't really find anything of use. Maybe I missed something, please help if you can. Thanks.

K
# 2  
Old 07-19-2001
Have you tried explicitly seeting the values:

letters[0]="x"
letters[1]="y"
letters[2]="z"


# 3  
Old 07-20-2001
Yes, i tried setting it explicitly but it won't take it. It gives me back the line:
letter[0]=x: command not found

I've tried doing it other ways also (w/ and w/out quotes, setting the variable to a single letter first i.e. letter=x then setting the next index
letter[1]=x) Just different things to that effect and i haven't found one that works yet.

Any more suggestions would be greatly appreciated.
# 4  
Old 07-20-2001
I would consider upgrading to the newer version then:

http://www.rpmfind.net/linux/RPM/red...4-11.i386.html
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #930
Difficulty: Easy
In computing, an epoch is a date and time from which a computer measures determines the release date of the operating system.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Compare bash arrays issue

Hello everyone, I need help comparing 2 arrays. the first array is static; the second array is not .. array1=( "macOS Mojave" "iTunes" ) cd /Volumes array2=( * ) # output of array2 macOS Mojave iTunes Mac me The problem occurs when I compare the arrays with the following code - ... (6 Replies)
Discussion started by: trexthurman
6 Replies

2. Shell Programming and Scripting

Using arrays in bash using strings to bash built-in true

I have the following code and for some reason when I call the program using /home/tcdata/tatsh/trunk/hstmy/bin/bash/raytrac.bash --cmod=jcdint.cmod I get hasArgument = hasArgument = true Somehow the array element is returning even though I have not chosen the option. ... (41 Replies)
Discussion started by: kristinu
41 Replies

3. Shell Programming and Scripting

bc,getopt and arrays in bash

trying to sum elements in an array using bc and getopt,i have a file with names and thier vaules if the names appears 3 times i should multiply its value with 3 then find the sum of all the elements together cat foo.txt max 2.3 henry 3 fransis 4.5 max 2.3 henry 3 max 2.3 it should... (1 Reply)
Discussion started by: elginmulizwa
1 Replies

4. Shell Programming and Scripting

Yet another bash arrays question

Hi all, I have a file that contains many lines, but only a few are of my interest, so I'm cutting it with grep + awk, and the result I get is for example line 0 line 1 line 2 line 3 line n Now I want to store each line in an array "cell" so I can use it later calling to ${array},... (2 Replies)
Discussion started by: TuxSax
2 Replies

5. Shell Programming and Scripting

subtraction in bash arrays

hi i am using bash shell to perform some subraction. here is what i have: i have a while loop and am using i as a counter. diff= `expr ${ARRAY1} - ${ARRAY2}` for example array1 has -0.7145 and array2 has -0.7041. when i try the above command, i get expr: non-numeric argument. any... (6 Replies)
Discussion started by: npatwardhan
6 Replies

6. Shell Programming and Scripting

arrays and while loops in bash

hi guys, i have an array called ARRAY which has elements in it... i am trying to assign elements of ARRAY to master_array.. i get a =: command not found error.. i=0 while do ${master_array}=${ARRAY} ((i++)) done is there something i am missing? (4 Replies)
Discussion started by: npatwardhan
4 Replies

7. Shell Programming and Scripting

arrays not printing properly in bash

hi guys, i wrote this script and it takes some fields from a file and puts it into three different arrays. The first array works just fine but when I try to use the second array (ARRAY1) all i get is a blank value on the screen.. this works fine..i get ARRAY value on the screen just fine ... (1 Reply)
Discussion started by: npatwardhan
1 Replies

8. Shell Programming and Scripting

arrays in bash

hi guys, i have the following script and when i run it i get blank lines on the screen.. i am trying to display the contents of array var.. #!/usr/bin/bash var=`awk 'NR>20&&NR<31' try.sum | awk '{print $4}'` echo "${var}" (1 Reply)
Discussion started by: npatwardhan
1 Replies

9. Shell Programming and Scripting

Searching Bash Arrays

Hi, I am writing a bash shell script. I would like to execute a statement only if an array contains a specific value. For example: array=(1 3 5 7) I would like to execute the statement only if the value 3 is present in ${array}. Thanks for any help, Mike (1 Reply)
Discussion started by: msb65
1 Replies

10. Shell Programming and Scripting

Arrays in bash.need help

:confused: Is it possible to delete array elements dynamically.For instance,consider an array( a b c d ) ,now can i delete array (the third element 'c').So that the array becomes array(a b d).. Thanks in advance!! (1 Reply)
Discussion started by: tj23
1 Replies

Featured Tech Videos