Visit Our UNIX and Linux User Community


No permission to execute file


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers No permission to execute file
# 1  
Old 07-19-2001
No permission to execute file

I am logged in as root and am trying to execute a file called x_cleanup_equdata but keep getting the message
ksh: x_cleanup_equdataNEW: 0403-006 Execute permission denied.
I did FTP this file from another server using GET, would this make the difference?
I tried chmod 666 but still no luck. any ideas?
Thanks
# 2  
Old 07-19-2001
Hammer & Screwdriver

You was on the right way with chmod .. but you took the wrong numbers: for executing a file you should use 777.

4=read
2=write
1=exec

so If you combine 4 + 2 you come to 6 and thats only read + write ... so add 1 to 7 and exec is also included.

hope this helps
br
# 3  
Old 07-19-2001
Sure does. Thanks. I never used this forum before so was unsure of a response and looked up a unix manual and found the command chmod +x [filename]. This also worked by the way but your way is more descriptive of how to chnage pemrissions.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #456
Difficulty: Easy
An application programming interface (API) is a graphical-based interface for viewing client-server data.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Execute permission for shell script

Hi All, I am not able to figure out what is the problem with calling a shell script within a shell script. i have given all the permissions to both schell scripts. but when i am seeing the log file error is coming like weekly_us_push_rpts_tst.sh: ./vacation_quota_summary_detail.sh: Execute... (9 Replies)
Discussion started by: krupasindhu18
9 Replies

2. Red Hat

Use of Execute permission for folder

Hi All, What is the use of execute permission for a folder. I know "for execute a file(script file) we have to provide execute permission to that respective file".But what is the use to give execute permission to folder.Is it equal to read permission ? Regards, Mastan (1 Reply)
Discussion started by: mastansaheb
1 Replies

3. Debian

Execute permission problem

Hello, I need to install a program from a DVD. It uses a sh script called setup. root@ragnok: head -2 /media/cdrom0/setup #!/bin/sh root@ragnok: ls -l /media/cdrom0/setup -r-xr-xr-x 1 root root 4688 Nov 8 08:38 /media/cdrom0/setup root@ragnok: /media/cdrom0/setup bash:... (2 Replies)
Discussion started by: snorkack59
2 Replies

4. UNIX for Dummies Questions & Answers

Provide execute permission to a user

Hi, I have a shell script(test.sh) and need to give execute permission for this shell script to user group cobr_sftp and oracle. Could you please help as to how to give this permission. I have already given full access(777) to script test.sh. Does this mean all the users/user group can access... (1 Reply)
Discussion started by: abhi_123
1 Replies

5. UNIX for Dummies Questions & Answers

How I acted as other can execute file which its permission is -rw-rw-r--

I am other user who want to execute a file that its permission is -rw-rw-r-- how do I execute that file. (2 Replies)
Discussion started by: thsecmaniac
2 Replies

6. Shell Programming and Scripting

Problem with execute my file permission

Here is my script. 1 echo -n "Enter file name : " 2 read file 3 chmod 777 $file 4 && W="write = yes" || W="Write = no" 5 chmod 777 $file 6 && X="Execute = yes" || X="Execute = No" 7 chmod 777 $file 8 && R="Read = yes" || R="Read = No" ... (0 Replies)
Discussion started by: qral_hdr
0 Replies

7. Shell Programming and Scripting

How to execute a script without giving x permission to the file?

How to execute a script with out giving x permission to the file? (7 Replies)
Discussion started by: praveen_b744
7 Replies

8. AIX

rm: execute permission denied in AIX

Hello All, We have an existing ssh set-up between 2 Unix servers ( Server A and Server B). Recently, we've had a problem where we cannot delete files (via app engine and even manually, after connecting thru ssh) on Server B. We manage Server A but Server B is handled by a different group, as a... (1 Reply)
Discussion started by: chipahoys
1 Replies

9. Shell Programming and Scripting

Only Execute Permission for Others...

This might be very silly question but i dont know y is it so... i Have script I have Given the permissions in the following manner... -rwxrwx--x 1 root system 3 Jun 08 15:46 temp I want no one to see what is present in that but should be able to execute it.. but when... (3 Replies)
Discussion started by: pbsrinivas
3 Replies

10. Shell Programming and Scripting

without execute permission

how can a script run without execute permissions. when i run myscript as : sh a.sh it was working but when i say simple a.sh its not working since it has no x permission.but how about fist case? (1 Reply)
Discussion started by: Raom
1 Replies

Featured Tech Videos