Root filesystem filling up!

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Root filesystem filling up!
# 1  
Old 11-09-2009
Root filesystem filling up!

Hi all.
New to the forum and new to Unix admin... / filesystem filled up and I can't find where the large files are. Any help will be apppreciated:

# df -k
Filesystem            kbytes    used   avail capacity  Mounted on
/dev/dsk/c1t0d0s0    8063580 7941745   41200   100%    /
/proc                      0       0       0     0%    /proc
mnttab                     0       0       0     0%    /etc/mnttab
fd                         0       0       0     0%    /dev/fd
swap                 3687032     168 3686864     1%    /var/run
/dev/dsk/c1t0d0s6    8063580 6509257 1473688    82%    /opt
/dev/dsk/c2t0d0s0    285588236 229480788 56107448    81%    /u02
swap                 3836600  149736 3686864     4%    /tmp
/usr/home/oracle     8063580 7941745   41200   100%    /home/oracle
                     10490104  175764 10314340     2%    /u05/msgdata
                     214529640 182823721 31705919    86%    /u01/arch/vprd2/primary
/usr/home/oracle     8063580 7941745   41200   100%    /home/oracle
rcw-it-nas2:/backup  1429328808 732615268 696713540    52%    /u04
/export/home/csa     8063580 7941745   41200   100%    /home/csa
# uname -a
SunOS rcworaprd 5.9 Generic_112233-07 sun4u sparc SUNW,Sun-Fire-480R

I do some of the du-dk commands but nothing huge stands out. Need help asap.

Last edited by pludi; 11-09-2009 at 02:38 PM.. Reason: code tags, please...
# 2  
Old 11-09-2009
Do you have logfiles on the root filesystem? Try running find looking for large files
that were recently modified

find / -mtime+3 -type f -size +10000 -exec ls -l {} \;

# 3  
Old 11-09-2009
Nothing under / that stands out.
I run the du -ak * | sort -nr | more command from /home/oracle and all I get is about 140 MB used space. The / fs is 8 GB. when I run that command from / I get a ton of /proc output. Could there be anything like a process holding onto something in there?
# 4  
Old 11-09-2009
You have to check the filesystem hosted path and maximum used space in %
using the below command

df -k . | sort +4rn
The above command will listout the maximum used path and filesystem

Then you have check the maximum used filesystem path and check which file used more space in the directory using below command df -k . | sort +4rn

Then you have to ziped the maximum size file if its not current active processed file.

# 5  
Old 11-09-2009
I figured it out.

Apparently some Oracle dbf files were created under a new directory that was one level below a mount point:


where server1 is it's own mounted filesystem so they created a directory called server2 but it's not mounted so it created it under /.

This slowly filled up / as data was written to the db.

My du -ak * | sort -nr command eventually led to the discovery, I just needed to sift through all of the output to find it.

Thanks to all who assisted.
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Solaris

Cannot tell what is filling up root (/) partition on Sol10

I can see that my root partition is down to single-digit GB free out of 134GB root partition on a larger server with many SAN, NFS, LOFS mounts etc mounted at the root (/) partition. How can I specifically tell which directories is causing the most utilization in my root (/) partition? (3 Replies)
Discussion started by: ckmehta
3 Replies

2. Linux

root filesystem goes readonly

I see this when tried to create a dir using root fstab entries are pretty normal tried to remount with rw but it is still the same block device /dev/sda2 is write-protected ---------- Post updated at 04:57 PM ---------- Previous update was at 03:51 PM ---------- fstab entry ... (4 Replies)
Discussion started by: robo
4 Replies

3. Solaris

Root partition filling up

I have a T1000 Sparc server that has a relatively small root partition which is 24Gb and a larger partition dedicated to /export/home that is approximately 100 Gb. We have a lot of data going to /var/audit and to /var/core/corefiles. Is there any non-destructive way to redirect files from... (4 Replies)
Discussion started by: goose25
4 Replies

4. Solaris

Resizing the Root Filesystem

Is it possible to increase the root filesystem size without reboot ?? (4 Replies)
Discussion started by: gowthamakanthan
4 Replies

5. AIX

how to find whats filling up Root Directory

Hi guys I am running AIX 5.3 and a newbie to it. And I am getting reports telling me that the Root Directory is reaching almost max capacity, can someone give m some advice to find out what files are causing it to grow? , or how I can identify the growing files? Thanks (6 Replies)
Discussion started by: ryanbsc@gmail.c
6 Replies

6. Solaris

Root Filesystem

Hi, Can we install root file system on other than 0th slice???? (5 Replies)
Discussion started by: tirupathiraju_t
5 Replies

7. UNIX for Advanced & Expert Users

diff command filling /var filesystem space

Hi, I am using diff command to check difference between two files.Both files are very big and when i execute this command /var temp space is filled up almost 99%. Can any one please tell me is there any way i can specify directory name which has more space so that diff can use that dir for... (2 Replies)
Discussion started by: ukatru
2 Replies

8. Solaris

Filesystem filling up and no clue as to why!

df shows that the filesystem is filling up and the usage is 94%. However when I actually traverse to the directory I du shows only about 10% of the space occupied! Below is the output of df and du: >>>df -kh /cbmdata/00 470M 393M 29M 94% /cbmdata/00 >>>/cbmdata/00>... (3 Replies)
Discussion started by: zombiezparadize
3 Replies

9. UNIX for Advanced & Expert Users

Mounted Root Filesystem

In my Solaris 10 based server, I have noticed the following mounts when a use DF -K /dev/dsk/c0t0d0s0 5062414 3213876 1797914 65% / / 5062414 3213876 1797914 65% /net/se420 I understand the first mount because it appears in my vfstab file and is the mount of root that I would expect.... (1 Reply)
Discussion started by: jimthompson
1 Replies
Login or Register to Ask a Question