Visit Our UNIX and Linux User Community


del 1st 2 lines


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers del 1st 2 lines
# 1  
Old 11-03-2009
del 1st 2 lines

filename.txt

Code:
VOL1000499
HDR1ACHTAP           
101 031100225 0311002250911030803A094101WACHOVIA BANK OF 
5200MASTER PAY GROUP                    4231352166PPDAP PAYMENT      091026   1031100220000001
6221110000123756570069       00071351691000-     4022 FISHER HEALTHCARE       0031100220000001
6221110000123756570069       00030000001000-     4022 FISHER HEALTHCARE       0031100220000002


currently, i head -2 filename.txt, and using grep -v line1 and line2

is it a better way to del the 1st 2 lines ?

Last edited by vgersh99; 11-03-2009 at 02:11 PM.. Reason: code tags, please!
# 2  
Old 11-03-2009
Code:
sed -n '3,$p' myFIle

look into sed1liners.
# 3  
Old 11-03-2009
1. use tail

Code:
tail -n +3 filename.txt

2. sed
Code:
sed '1d;2d' filename.txt

or

Code:
sed '1,2d' filename.txt

# 4  
Old 11-03-2009
thank you much. all solutions worked.
# 5  
Old 02-23-2010
Bug

Try the below sed command for deleting the first two lines in the file.

sed '3,$!d' file
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #402
Difficulty: Medium
The term 3D printing originally referred to a powder bed process employing standard and custom inkjet print heads.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Del Line if specific issue

HI Guys I have below input : PO 121255 SorkO_RM_,rlsmel=310_410_3_11104_43831 PO 125564 SorkO_RM_,rlsmel=007G43823 I want delete line which have "_" after = Sign Output : PO 125564 SorkO_RM_,rlsmel=007G43823 (2 Replies)
Discussion started by: pareshkp
2 Replies

2. UNIX for Dummies Questions & Answers

append following lines to 1st line, every 3 lines

I have output like this: USER_ID 12/31/69 19:00:00 12/31/69 19:00:00 USER_ID 12/31/69 19:00:00 12/31/69 19:00:00 USER_ID 12/31/69 19:00:00 12/31/69 19:00:00 USER_ID 12/31/69 19:00:00 12/31/69 19:00:00 ... where USER_ID is a unique user login followed by their login timestamp and... (6 Replies)
Discussion started by: MaindotC
6 Replies

3. Shell Programming and Scripting

not del a file not affecting other permissions

i was faced by a question from a friend. i found it very tricky. all my months of learning unix i never can figure it out still. heres the question he faced me with. wondering if you all can help me figure a solution. ill let him know the forums helped me out :D What command would you use... (10 Replies)
Discussion started by: sunny231
10 Replies

4. UNIX for Dummies Questions & Answers

del lines

i have file that looks like this: 031000503 2000049262784 LCK00000050 i want to look like this: 031000503 2000049262784 LCK00000050 i'd like to del 10-15 Please use code tags! (6 Replies)
Discussion started by: lawsongeek
6 Replies

5. Shell Programming and Scripting

awk to del files

Hi, I want to delete files but it has space beween name & .log For ex -rw-r--r-- 1 root other 5429 Mar 19 2008 \AnjuP .log -rw-r--r-- 1 root other 1352 Mar 21 2008 \ranjap .log -rw-r--r-- 1 root other 1355 Mar 29 2008 \varghp .log so if I run ls -ltr | head -3 | awk '{print $9 $10}... (8 Replies)
Discussion started by: tuxian
8 Replies

6. Shell Programming and Scripting

need to delete all lines from a group of files except the 1st 2 lines

Hello, I have a group of text files with many lines in each file. I need to delete all the lines in each and only leave 2 lines in each file. (3 Replies)
Discussion started by: script_op2a
3 Replies

7. UNIX for Dummies Questions & Answers

How to del word by random input?

Hi, I got big problem. a line contains like this: Hell "A,B,C", how to delete A or B or C by using sed or other tools? I do not have any idea. Many thanks. (2 Replies)
Discussion started by: lemon_06
2 Replies

8. UNIX for Dummies Questions & Answers

route del trouble

Hi, I'm having trouble deleting a route: # route del 192.168.0.0 SIOCDELRT: Invalid process # route del -net 192.168.0.0 SIOCDELRT: Invalid argument The route is in the table: # route Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 ... (1 Reply)
Discussion started by: spaesani
1 Replies

9. UNIX for Dummies Questions & Answers

how tp del progs

ermm... wats the general commands to uninstall programs.....izzit rpm -e cos it keep telling me package not installed..... anyway anyone know any good links for licq for redhat 9.0 shrike ... cos downloaded one ... dun seems to be working ... trying to get rid of it appreciate if anyone can... (3 Replies)
Discussion started by: kaya
3 Replies

Featured Tech Videos