Visit Our UNIX and Linux User Community


Compiling Kernel for an Embedded System


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Compiling Kernel for an Embedded System
# 1  
Old 10-26-2009
Error Compiling Kernel for an Embedded System

-----Edit-----

My original post was long and confusing. To sum it up, I am wondering how to do the following Debian based commands on an RPM type system.

dpkg -i XXX.deb
update-initramfs -k xxx -c
update-grub

I hope someone can provide some insight. Thanks in advance!

--------------

Hey, I'm new and stumbled on this forum while looking for a solution to what I think may be a unique problem. I hope someone may be able to advise me.

I am trying to compile a special kernel for an embedded system in order to boot it with various distributions. The only reason I am having to go through all this trouble is b/c the system refuses to boot the installer discs. The only work around I can come up with is to install on a regular computer, update it with a specialized kernel, and then boot it on said embedded system.

I know this solution works with Debian based distributions. We have compiled a special kernel, and just update initramfs before moving the storage medium to the embedded system, however I am having a very hard time doing this with Redhat based distributions. I can compile the kernel into an RPM using our master config file, and it installs correctly, however the problem is that I can't update the initrd image. when I run the mkinitrd command, it complains of missing modules.

Can a guru out there please provide help/advice?

Thanks in advance.

Last edited by b4sakenxx; 10-27-2009 at 02:33 AM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #425
Difficulty: Medium
C# 1.0 was first released in December 2002.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Missing Modules After Compiling Kernel

I'm a little embarrassed after all these years I've never really successfully compiled my own kernel. I used this guide to make the following files: linux-headers-5.1.9_5.1.9-1_amd64.deb linux-image-5.1.9_5.1.9-1_amd64.deb linux-libc-dev_5.1.9-1_amd64.deb When I first booted into this... (4 Replies)
Discussion started by: Azrael
4 Replies

2. UNIX for Advanced & Expert Users

drbd module compiling error for Kernel

Hi I am trying to install drbd8 via apt-get on ubuntu10 sudo apt-get install drbd8-source password for vishals: Reading package lists... Done Building dependency tree Reading state information... Done drbd8-source is already the newest version. drbd8-source set to manually installed. 0... (0 Replies)
Discussion started by: vishal_vsh1
0 Replies

3. UNIX for Dummies Questions & Answers

Error while compiling the kernel 3.3.1.

Hi I m using redhat 6 with kernel release 2.6.32-71.el6.i686 I have downloaded latest kernel 3.3.1 from kernel.org . when i run make module_install i get below error. # make modules_install /usr/src/kernels/linux-3.3.1/scripts/depmod.sh: line 37: 11314 Killed ... (0 Replies)
Discussion started by: pinga123
0 Replies

4. Linux

kernel compiling

Hello, I have several questions to get awnsered about the newer linux kernels (2.6.25) and above. 1st question: Ive read that the newer kernels you can compile the marvell sd8686 driver from the source. can anyone confrim this? only binaries i see for that driver are for 2.6.24 and im already... (0 Replies)
Discussion started by: old noob
0 Replies

5. Solaris

Which file is read by kernel to set its default system kernel parameters values?

Hi gurus Could anybody tell me which file is read by kernel to set its default system kernal parameters values in solaris. Here I am not taking about /etc/system file which is used to load kernal modules or to change any default system kernal parameter value Is it /dev/kmem file or something... (1 Reply)
Discussion started by: girish.batra
1 Replies

6. Linux

Automate compiling of linux kernel

Hi, I'm a newbie at kernel compilation. Currently trying to do a bash script to automate the compiling process of the linux kernel. I'm having some problems with automating the configuration. I know its possible to load an existing .config file in the make menuconfig screen prompt. But... (3 Replies)
Discussion started by: aloe_vera
3 Replies

7. UNIX for Dummies Questions & Answers

Compiling Mach 3.0 Kernel

Hi, I am very new to this. I would like to compile the Mach 3.0 kernel. Can someone explain, step-by-step, how to turn all the Mach 3.0 kernel code into a single binary file that will run directly on an x86 computer? Also, once (and if) I get it working, what software works on it? My goal is... (2 Replies)
Discussion started by: dublinus
2 Replies

8. Red Hat

Compiling 2.6 Kernel. :confused:

Dear Linux Masters, I need ur help in the following: 1. Compiling 2.6 kernel. 2. my Redhat system is 2.4 kernel how to add 2.6 kernel. 3. I need minimum feature in 2.6 ( most probably related to networking) Please let me know if any sites to download 2.6 kernel. Can u all please help me... (2 Replies)
Discussion started by: ashokmeti
2 Replies

9. UNIX for Advanced & Expert Users

problem when compiling and installing the kernel

hello; i'm trying to install a new kernel in fedora core 5 i'm using the following command: /usr/src/linux-2.6.15.1# make && make modules && make modules_install && make install but i always have the following error: ld: édition de lien finale en échec: Aucun espace disponible sur le périphérique ... (1 Reply)
Discussion started by: jalil smail
1 Replies

10. UNIX for Advanced & Expert Users

How to add user on Embedded System

The directions below were provided by someone on the unslung mailing list. unslung is a linux OS for LinkSys's $100 NSLU2 NAS controller. I'm posting the query here because (1) I think it is really a generic linux/unix questions (2) I did not get a response in the unslung mailing list. I... (1 Reply)
Discussion started by: siegfried
1 Replies

Featured Tech Videos