Visit Our UNIX and Linux User Community


Solaris10 rrdtool compile issues


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Solaris10 rrdtool compile issues
# 1  
Old 09-22-2009
Solaris10 rrdtool compile issues

Hi all,

I'm trying to install rrdtools on a sparc solaris10 system for use with Nagiosgraph. I inititially just added the rrdtools package from sunfreeware but this package doesn't include the directory that Perl needs.

I've been told that compiling from source is my only option. I;m trying to compile rrdtools version 1.3.8.

When I run ./configure I see the following:

Code:
Find 3rd-Party Libraries
checking for cairo_font_options_create in -lcairo... no
checking for pkg-config... pkg-config
ANDREWS pkg-config \n
checking for cairo_font_options_create in -lcairo... no
configure: WARNING:
----------------------------------------------------------------------------
* I could not find a working copy of cairo-png. Check config.log for hints on why
  this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
  so that compiler and the linker can find libcairo and its header files. If
  you have not installed cairo-png, you can get it either from its original home on

     http://cairographics.org/releases/

  You can find also find an archive copy on

     http://oss.oetiker.ch/rrdtool/pub/libs

  The last tested version of cairo-png is 1.4.6.

       LIBS=-lm  -lrt -lcairo -lpng12 -lz -lm  
   LDFLAGS=-L/usr/local/lib -L/usr/local/include -L/usr/local/lib    
  CPPFLAGS=-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -INONE/include/cairo -I/usr/local/include/cairo -I/usr/sfw/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -I/usr/local/lib -D_REENTRANT -D_REENTRANT -INONE/include/cairo -I/usr/local/include/cairo -I/usr/include/libpng12 -I/usr/sfw/include/freetype2 -I/usr/local/include

cario-png.pc exists in /usr/local/lib/pkgconfig on my system. It would seem from the above that this directory is listed under both the LDFLAGS and CPPFLAGS so now I'm stuck!

Any ideas?

Also if I do pkg-config --list-all I see cairo in the output...

I've been looking at this for over a week now and I'm making little progress so any help would be appreciated.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #761
Difficulty: Medium
Every core of a multi-core CPU has a dedicated L1 cache and that cache is usually shared between the cores
True or False?

8 More Discussions You Might Find Interesting

1. Solaris

Need help to compile and create python64 bit (2.7.9) on Solaris10

Hi, I am trying to build python(2.7.9) 64 bit from source on solaris10. Using the below to compile ./configure CFLAGS=-m64 LDFLAGS=-m64 But getting errors like below while executing make make: Fatal error: Command failed for target `libinstall' OS info: isainfo -v 64-bit amd64... (9 Replies)
Discussion started by: Sumanthsv
9 Replies

2. Shell Programming and Scripting

Python-rrdtool try except rrdtool.error module object has no attribute error

I have this code that gives this error on Linux and will be grateful if you can help import rrdtool try: ret_asd = rrdtool.update(myfile.rrd,'N:%s:%s' %(metric1, metric2)); except rrdtool.error, e: print e When i run the above i get the below error except... (1 Reply)
Discussion started by: kaf3773
1 Replies

3. Red Hat

Why do we use RRDtool in MRTG?

Hi Guys, Why do we use RRDtool in MRTG? I have implemented MRTG for some routers, I have read some notes about RRDTOOL also but don't know what is use of these tool. Any one one please explain me the use of RRDTOOL in their own words? (1 Reply)
Discussion started by: manalisharmabe
1 Replies

4. UNIX for Dummies Questions & Answers

rrdtool question

Hi, DEF:clients=cccam.rrd:kliensek:AVERAGE DEF:activeclients=cccam_actclient.rrd:activeclients:AVERAGE "LINE1:clients#0000FF:Connected clients" COMMENT:" \n" "LINE2:activeclients#99FF00:Active clients" COMMENT:" \n" GPRINT:clients:LAST:'Current'\%5.0lf%s COMMENT:" \n"... (2 Replies)
Discussion started by: adriankoooo
2 Replies

5. UNIX for Dummies Questions & Answers

Compiling gcc to compile make to compile yaboot

I have just installed OpenBSD on a 333MHz PPC iMac G3. It has a 6GB HDD that has been partitioned as 1GB MacOS 8.5.1, 3GB MacOS X 10.3.9, 2GB OpenBSD 4.8. I now need to install a bootloader so that my computer can recognize the OpenBSD partition at startup. I have been trying to install... (0 Replies)
Discussion started by: t04st3r
0 Replies

6. AIX

Compile PHP in AIX: Loading issues

Finally I was able to compile PHP on AIX. When I try to load from Apache, I get the below error. /install/usr/local/apache2/bin:>apachectl -f /install/usr/local/apache2/conf/httpd.conf -k stop httpd: Syntax error on line 53 of /install/usr/local/apache2/conf/httpd.conf: Cannot load... (0 Replies)
Discussion started by: KarthikKannan
0 Replies

7. Solaris

Compile issues on Core Solaris 10

Hello All! I am trying to compile sudo-1.7.2p1 on Solaris 10 (Core Install). I get the follow error when I run "./configure": checking for grep that handles long lines and -e... configure: error: no acceptable grep could be found in /usr/sbin:/usr/bin:/usr/ccs/bin:/usr/sfw/bin:/usr/xpg4/bin I... (5 Replies)
Discussion started by: pingmeback
5 Replies

8. HP-UX

compiling the RRDtool

I tried to compile the RRDtool on HP-UX (IA56). I have gcc-3.4.3 and perl 5.8.0 I got this: Writing Makefile for RRDs cd perl-shared && make /opt/perl/bin/perl /opt/perl/lib/5.8.0/ExtUtils/xsubpp -typemap /opt/perl/lib/5.8.0/ExtUtils/typemap RRDs.xs > RRDs.xsc && mv... (2 Replies)
Discussion started by: Kalin
2 Replies

Featured Tech Videos