Visit Our UNIX and Linux User Community


UNIX Application install


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers UNIX Application install
# 1  
Old 09-17-2009
UNIX Application install

Hi,

I am currently installing an application (tar ball) on a server that involves ftp from my computer to the server directory (unix). Once it is deployed, I am now responsible to getting it to run. Using putty, i telnet/ssh to the remote node and type in the following command: vi .kshrc. I then add the necessary block of text indicating path and home directory for application
eg:
# Module Name
export MODULEName_HOME=${server_HOME}/type/moduleName/current
PATH=$PATH:$MODULEName_HOME/bin

once this is done i logout the current session and log back in through putty.

I then need to update the softlinks to the correct application version and do so by:
1. cd $MODULEname/..
2. rm -rf current (delete the file, if it is present)
3. ln -s W_X_Y_Z current (e.g. ln -s 2_0_0 current)
And finally i type in: moduleNamectl start
After all this is completed. I still end up with an error message within the ctl log stating: Error occurred during initialization of VM
Could not reserve enough space for object heap
If anyone has any opinion on how to fix this problem or perchance an error in my method.

Let me know,

Any help is great.

Thanks
# 2  
Old 09-17-2009
UNIX Application Install

This sounds like you're installing a java app, and when you start it java is trying to grab more memory than what your system has available. Check the startup script for the java command, and one of the arguments is probably the memory size. Try changing that, but beware that it may affect the app's performance.
# 3  
Old 09-17-2009
Re: neildemo

From what you understand, you're right by saying its a java app, however from there, how would i be able to access the startup script that you were mentioning?
# 4  
Old 09-17-2009
Depends, what OS/distribution is this server running?
# 5  
Old 09-17-2009
"And finally i type in: moduleNamectl start" Look at the file 'moduleNamectl'. When you pass the argument 'start' to it, it most likely either runs java with a bunch of options, or calls another script that runs java. You want to find the arguments that are being passed to the java command. I don't remember the exact argument for setting the memory size, but you can probably just google that.
# 6  
Old 09-17-2009
It is a SunOS 5.10 Generic

---------- Post updated at 06:37 PM ---------- Previous update was at 04:47 PM ----------

So i did as you said and brought down the memory heap level on the machine, and it is still giving me the same error?
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #563
Difficulty: Medium
The comparison operators are only used for comparing numerical data types.
True or False?

7 More Discussions You Might Find Interesting

1. Red Hat

Unable to install 32 bit application on 64 bit OS

Hi, I am new to Linux OS. My question is that "is it possible to install 32 Bit application on 64 Bit OS?" I have the following Redhat OS on VMware workstation. OS - Red Hat Enterprise Linux Server release 6.2 | 2.6.32-220.el6.x86_64 While installing the application I am getting the... (2 Replies)
Discussion started by: poga
2 Replies

2. Solaris

Unix solaris hanged, cannot get the application

Hi , I need your help on the my unix (solaris system was down) when i enter console login ans password could not opearte their application . i tried reboot many times but still same error was occurred. Please refer the attcahed file , how i need to solve this issue?:wall: I 'm not... (2 Replies)
Discussion started by: Thamil
2 Replies

3. Solaris

Can I Install the Gani Network Driver Using the Application that Came on the CD?

When I boot up the Solaris 10 5/09 install CD and select 'Solaris' from the GRUB menu that comes up, a menu loads. Option 5 is 'Apply Driver Updates'. Can I install the Gani driver using that? I tried using the tar file (the way it came) that I wrote to a floppy but when I asked it to look at the... (8 Replies)
Discussion started by: Bradj47
8 Replies

4. HP-UX

Install application on UNIX cluster

Hi everyone, I have a new engagement where in I would need to install an inhouse server application in a HP_UNIX cluster. Please let me know how this should be done. Satish (4 Replies)
Discussion started by: satish_000
4 Replies

5. UNIX for Dummies Questions & Answers

Unix Using Hosting - Using application

Hello Guys, Let me start by saying... I know very little about Unix/Linux, but for a non-profit organization I've been asked to do a task, that is a far amount out of my knowledge. About my host: DreamHost.com Unix/Linux Based Best Plan Okay heres what I need to do. Upload a version of... (2 Replies)
Discussion started by: maceffects
2 Replies

6. UNIX for Dummies Questions & Answers

sudo: application install question

I need to install an application on my Sun station and need root privleges to do so. I was given sudo privileges and was told to issue the following command. bash-2.03$ sudo init 0 I've read the man pages for init and understand the purpose of that command. My questions are: 1. From the... (2 Replies)
Discussion started by: forbin24
2 Replies

7. UNIX for Dummies Questions & Answers

UNIX Database / Application Installation

Greetings, forgive me if this is listed in another thread somewhere, I am short on time. I am being interviewed for the position of UNIX Database and Job code installer for a consulting firm. I have never installed or worked on a native UNIX system. I have been running Linux (RH,SuSE,Slackware)... (3 Replies)
Discussion started by: OllieTech
3 Replies

Featured Tech Videos