Visit Our UNIX and Linux User Community


Non root login problems in AIX


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Non root login problems in AIX
# 1  
Old 09-08-2009
Non root login problems in AIX

Hi All,

I have setup a non root user on AIX 5.3, using smit. When I try logging on as that user my login screen just disappears. I am using PUTTY. I login to the same box as root no problems. I have tried re-creating several different usernames but get the same effect I have also telneted from a box at the same location and get the same result, the screen just disappears. I have used other emulators, like TERRA TERM, used ssh and it gets to the prompt but immdediatley disappears.

Any help would be appreciated
# 2  
Old 09-08-2009
AIX is a bit tricky..
when you have created (with smit I assume..) an account, you need to, as root "validate it" that is by starting to set a passwd for the user:
Code:
passwd <user>

Only every times root modifies a user's password, It will ask at next connexion to change it again...
unless you type:
Code:
pwdadm -c <user>

# 3  
Old 09-09-2009
hi vbe,

you are correct i did setup the user as root and i did change the password fot that user.. it is no different on how i have done this before
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #82
Difficulty: Easy
DOS was based on Unix.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Not able to login AIX server but able to login thru console.

Hi, i am able to login to AX server thru console but not able to login directly thru server. also the server is not ping-able with other server. filesystem is fine. and OS version is AIX 5.3. please let me know if you need any specific log. thx in advance. Scriptor (2 Replies)
Discussion started by: scriptor
2 Replies

2. Red Hat

Su root or login root

Hi, I find there is some customized linux with application. When I use login account root and type the password. It is not allow to login. But if I login with specified user and password. Then I use command "su - " and type root passwd. It allow you to switch to "root" account . Or if i... (14 Replies)
Discussion started by: chuikingman
14 Replies

3. AIX

User Account Login Login on your AIX server

I want to learn AIX. I would like to find someone who would be willing to give me a login to their AIX home lab server. My intent is to poke around and discover the similarities and differences of AIX compared to other *NIXs. I am a UNIX admin so I can think of what some immediate concerns may... (1 Reply)
Discussion started by: perl_in_my_shel
1 Replies

4. AIX

AIX Disable direct root login problems

I have disabled rlogin for root successfully , but after that i could not login to root from console and could not su to root from other users as it responded as expired account I did not have any admin user but I have managed to recover the situation by accessing rootvg before mounting it, but... (5 Replies)
Discussion started by: majd_ece
5 Replies

5. UNIX for Dummies Questions & Answers

Root problems??

So when I log in as root on my eMac (running tiger, 10.4.11), some things don't work or reluctantly work. Examples: Computer:/Users/mat/Desktop root# pico test.doc Error opening terminal: network. Computer:/Users/mat/Desktop root# emacs test.doc Error opening terminal: network. ... (3 Replies)
Discussion started by: razordp
3 Replies

6. HP-UX

Cannot login root

With my SSH, my HP-UX cannot login to root. It will come out a message su: unknown id: root. But I can login by user oracle. I also cannot login to console either by using root or oracle anymore. What shall I do. (5 Replies)
Discussion started by: surizan
5 Replies

7. AIX

Can't login root account due to can't find root shell

Hi, yesterday, I changed root's shell in /etc/passwd, cause a mistake then I can not log in root account (can't find correct shell). I attempted to log in single-mode, however, it prompted for single-mode's password then I type root's password but still can not log in. I'm using AIX 5L version 5.2... (2 Replies)
Discussion started by: neikel
2 Replies

8. AIX

Problems with disabling remote root login

Hello! I'm going through security checklist for AIX 5.3 and i just can't disable remote login for root through ssh. What i did: - in /etc/security/user i added a line: rlogin = false which works fine when i try to login through telnet - after installation of openSSH i edited... (3 Replies)
Discussion started by: veccinho
3 Replies

9. Answers to Frequently Asked Questions

Lost root password / Can't login as root

We have quite a few threads about this subject. I have collected some of them and arranged them by the OS which is primarily discussed in the thread. That is because the exact procedure depends on the OS involved. What's more, since you often need to interact with the boot process, the... (0 Replies)
Discussion started by: Perderabo
0 Replies

10. UNIX for Dummies Questions & Answers

Login problems

I am really new to Unix. I have just bought an old HP 715/100 running HP-UX. When it first arrived to me I did not assign a password to the administrator account. When it comes to the login screen I am not able to log into the graphical interface. I have tried using administrator and also root as I... (0 Replies)
Discussion started by: finnd
0 Replies

Featured Tech Videos