Visit Our UNIX and Linux User Community


vtkpython: command not found... why ? it is there..


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers vtkpython: command not found... why ? it is there..
# 1  
Old 09-01-2009
vtkpython: command not found... why ? it is there..

hi,

I can't run the process vtkpython. I'm inside the bin directory and i can see the command




Code:
omhp-uva-21-43:bin aneuryzma$ ls -l
total 520
-rwxr-xr-x@ 1 aneuryzma  staff    2426 Aug 30  2005 Cone.py
-rwxr-xr-x  1 root       staff   26492 Sep  1 16:39 lproj
-rwxr-xr-x  1 root       staff   22708 Sep  1 16:39 vtkEncodeString
-rwxr-xr-x  1 root       staff  106536 Sep  1 16:37 vtkWrapPython
-rwxr-xr-x  1 root       staff   16868 Sep  1 16:37 vtkWrapPythonInit
-rwxr-xr-x  1 root       staff   73852 Sep  1 17:18 vtkpython


But if I launch it:


Code:
omhp-uva-21-43:bin aneuryzma$ sudo vtkpython Cone.py 
Password:
sudo: vtkpython: command not found


How is possible that is not found if it is there ? I'm in the same directory

thanks
# 2  
Old 09-01-2009
most like your $PATH does not include current directory (.)
try:
Code:
sudo vtkpython ./Cone.py

or specify a full/relative path to a file.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #558
Difficulty: Medium
The term bug was popularized by Grace Hopper in 1947 while working on a Mark II Computer at a US Navy research lab when a moth was stuck in the computer.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Command not found

On my MAC - I get Command not found error for some command like mvn , java_home etc . I CD to the actual directory to take path out of picture and even then i get the command not found error . anyone else have the same problem ? (3 Replies)
Discussion started by: ambm01
3 Replies

2. Solaris

Ar command not found

Hi all, ar command not found on Solaris 10 version. We can execute under ./ar command /usr/ccs/bin directory. However, we want to execute ar command anywhere. We add to /usr/ccs/bin entry under /etc/profile file shown as below. umask 002 trap 2 3 ... (2 Replies)
Discussion started by: ziosnim
2 Replies

3. Shell Programming and Scripting

Want to terminate command execution when string found in the command output

Hi Experts, I am very much new to linux scripting, I am currently working on reducing my manual work and hence writing a script to automate few task. I am running below command to snmpwalk the router.. snmpwalk -v 3 -u WANDL_SU -a MD5 -A vfipmpls -x DES -X VfIpMpLs -l authPriv... (19 Replies)
Discussion started by: Hanumant.madane
19 Replies

4. Shell Programming and Scripting

When i am trying to execute export command within a shell script it is saying command not found.

I am running the export command within a view to use that value inside my build script. But while executing it it is saying "export command not found" My code is as follows: -------------------------- #!/bin/sh user="test" DIR="/bldtmp/"$user VIEW="test.view1" echo "TMPDIR before export... (4 Replies)
Discussion started by: dchoudhury
4 Replies

5. Homework & Coursework Questions

Command not found

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: Trying to run script but everytime I do I get teh following error message line 4: I have attempted... (5 Replies)
Discussion started by: tbear808
5 Replies

6. Shell Programming and Scripting

bash: <command nm> command not found

I created a script that I need to run from time to time, but get this error message. To get it working again I run this command from time to time: export PATH="$PATH:~/scripts" I put all my automated scripts in the /scripts directory and would like to run my scripts from any directory... (5 Replies)
Discussion started by: catalinawinemxr
5 Replies

7. Shell Programming and Scripting

Always getting command not found

I'm using Terminal in MAC OS X, and new to this. I don't know what happened to the path. I always get "command not found". For example, this is some of what I get: -bash: ls: command not found -bash: touch: command not found What should I do to return the terminal to normal? ... (0 Replies)
Discussion started by: Abder-Rahman
0 Replies

8. UNIX for Dummies Questions & Answers

Command not found

Hi guys, I do apologise if this question has been asked before. I am currently running Solaris 10 on a x86 architecture. Now, the problem I am having relates to the issuing of commands, for example if I am trying to find out the ipaddress of the machine I would issue the command 'ipconfig -a |... (2 Replies)
Discussion started by: BigTool4u2
2 Replies

9. UNIX for Dummies Questions & Answers

cc command not found

i installed x windows redhat linux 9.0 in my pc. but the problem is when i run cc command for c programme .....bash:cc: command not found printed ...........i set the path for bash ............with the help of PATH=$PATH....................still it is not working .........please guide me. (4 Replies)
Discussion started by: mishra_sk_in
4 Replies

10. Shell Programming and Scripting

how can i check in csh if command found or not found ?

hello all im trying to use in sun Solaris the information received from the top command now i several machines that dont have install the top program so when im running the script im geting error saying after im running this code : set MemoryInfo = `top | grep Memory` if (... (2 Replies)
Discussion started by: umen
2 Replies

Featured Tech Videos