Visit Our UNIX and Linux User Community


TTY Insane


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers TTY Insane
# 1  
Old 08-30-2009
TTY Insane

Hi All,

Long time reader, first time poster.

I have a tip session to a v480 serial console running Solaris 9.
Look at this mess I'm getting back...

connected root0-**root0-**root0-**li*****************************orclecro***************************tc*************** **************ltfore*****************************roceice*************************cetc* ****************************texort**************************ifl-te-Sire0-ltet**toe****************************ttitllc***********************treoerel***** *********************treoli*****************************rlot+fo**********************r ox****************************olt*****************************xfet**************************** *iirotroot0-**root0-**root0-**exort**Mt00Mt00:*i*ot**ietifierroot0-**root0-**root0-**ro


Can anyone tell me how to make it sane? stty sane made it worse!

I invoked tip using tip -9600 /dev/ttyb, as we always do. It still works fine if we plug it into another box. I have a perfectly legible telnet session to the box so I can make changes, look at stuff etc. My best guess is that there's a line speed issue but I don't know where the settings are.

tia
# 2  
Old 08-30-2009
Maybe enquire on the port settings?

Code:
stty -a </dev/ttyb

# 3  
Old 08-30-2009
Hmm, interesting. Thanks for the idea.

Is it normal to have rows and columns at 0?
Anything else here look wacky?

# stty -a </dev/ttyb
speed 9600 baud;
rows = 0; columns = 0; ypixels = 0; xpixels = 0;
csdata ?
eucw 1:0:0:0, scrw 1:0:0:0
min = 1; time = 0;
intr = ^c; quit = ^\; erase = ^?; kill = ^u;
eof = ^a; eol = <undef>; eol2 = <undef>; swtch = <undef>;
start = ^q; stop = ^s; susp = ^z; dsusp = ^y;
rprnt = ^r; flush = ^o; werase = ^w; lnext = ^v;
-parenb -parodd cs8 -cstopb hupcl cread -clocal -loblk -crtscts -crtsxoff -parext
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -iuclc
ixon -ixany ixoff -imaxbel
-isig -icanon -xcase -echo -echoe -echok -echonl -noflsh
-tostop -echoctl -echoprt -echoke -defecho -flusho -pendin -iexten
-opost -olcuc -onlcr -ocrnl -onocr -onlret -ofill -ofdel
# 4  
Old 08-30-2009
By running:
Code:
$ tip hardwire

you get the correct seeings to tip from one Sun box to another, the settings this uses are in the /etc/remote file with the lable "hardwire" which uses ttyb to connect out of.
# 5  
Old 08-30-2009
Thanks for the reply Tony.
Unfortunately.... same result...

# tip hardwire
connected root0-**root0-**root0-**root0-**ro
.9..5


I think the problem is on the remote machine.
# 6  
Old 08-31-2009
I would suspect the data, stop or start bits are set wrong, apart from the fact that the word "root" turns up okay!?

You could check the ttya-mode setting in the eeprom(1) on the server you are trying to connect to.
# 7  
Old 08-31-2009
eeprom from remote machine shows the following for ttya-mode...

ttya-mode=9600,8,n,1,-

Is the trailing hyphen a problem?

All this worked fine until a few days ago...?
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #502
Difficulty: Medium
If a function uses a particular process or algorithm such as a Fast Fourier Transform to perform an operation, it would not be appropriate to document it in a series of comments in the source code.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Python: Redirecting to tty and reading from tty

In bash, you can do something like this: #!/bin/bash echo -n "What is your name? " > /dev/tty read thename < /dev/tty How can I do the same in python? I have a python script that has the following content: #!/usr/bin/python2.7 import getpass import sys import telnetlib import... (2 Replies)
Discussion started by: SkySmart
2 Replies

2. Solaris

Installing software -going insane

I have Solaris 10 update 11 installed on a virtual machine which I use for my lunix class (I'm studying I.T. but have little unix experience). So I have root access* I'm also do C programming in my course and would love to do it on my Solaris machine. So I looked into installing GCC and... (5 Replies)
Discussion started by: goformickey
5 Replies

3. Shell Programming and Scripting

Insane redirection behavior

Hi guys, I know computers don't misbehave. But I'm puzzled by what's happening right know in a script : I simplified the example to point out what seems weird to me. Don't try to find any sense to this stupid script. There are 10 rows in /tmp/tmp.txt i=0 tmpfile=/tmp/tmp.txt while... (3 Replies)
Discussion started by: chebarbudo
3 Replies

4. UNIX for Advanced & Expert Users

tty changes?

I am not sure if I am using the correct terminology but somehow my tty keeps changing on me. The man pages are confusing to me on what exactly the tty is. This is what I see when I run the tty command. Could anyone explain why my tty keeps changing? ~ $ tty /dev/pts/1 ~ $ tty /dev/pts/0 (6 Replies)
Discussion started by: cokedude
6 Replies

5. Solaris

tty hack

hi all, what i want to do when user open terminal like tty5 and do his work i want to see his terminal how can i do this (1 Reply)
Discussion started by: xxmasrawy
1 Replies

6. UNIX for Dummies Questions & Answers

pts and tty

hi iam very new to linux can anyone tell me about pts and tty acctually today morning i logged into my pc at 9:51 when i have given #who it has given sam tty7 9:51 sam pts/1 10:11 so what does it mean (1 Reply)
Discussion started by: praneel2k
1 Replies

7. AIX

Tty Over Run

dears i have two IBM p630 application servers, they are running hacmp 5.2 as the clustering software. from the output of errpt on one of the nodes i am receiving the following error: 9D30B78E 0530020007 T S tty1 RECEIVER OVER-RUN ON INPUT please are there any ideas about how... (0 Replies)
Discussion started by: TheEngineer
0 Replies

8. AIX

tty

Hi All can anyone tell me what is the meaning of tty,or give me an example of this? (1 Reply)
Discussion started by: magasem
1 Replies

9. UNIX for Dummies Questions & Answers

Insane question : Playing mp3 file from Sun Sparc

hi, i know this is crazy. but i can do this from linux in intel platform. just wonder can my Sun Solaris 8 sparc can do the same thing? (2 Replies)
Discussion started by: champion
2 Replies

Featured Tech Videos