Visit Our UNIX and Linux User Community


home directories not being created by useradd


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers home directories not being created by useradd
# 1  
Old 08-29-2009
home directories not being created by useradd

greetings. I'm using debian lenny, bash shell environment.

It is my understanding that by default, the useradd command should create subdirectories under the /home directory, with the same name as the user being created, but this is not happening.

I checked useradd -D and it showed, among other things

HOME=/home

I even tried to override the default by doing useradd -d /home/bob bob but still no directory was created.

During the debian install, i was prompted to create a user, and a home directory was created, but not now.

I checked the configuration file /etc/default/useradd and all the lines were comments except SHELL = /bin/sh, but I figured that shouldn't be a problem because useradd -D showed the correct defaults.

p.s. I am logged in as root.
# 2  
Old 08-29-2009
Try looking up the "-m" switch in "man useradd".
# 3  
Old 08-29-2009
Well that solves that one. The tutorial I was reading made no mention of -m. I looked at man, but stopped when I "thought" I had the answer.

I guess the moral of the story is, it pays to look over the whole man page, even when you think you have already found what you need to know.

Thanks!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #110
Difficulty: Easy
As of 2014, Apple's macOS was the largest Unix installed base globally.
True or False?

10 More Discussions You Might Find Interesting

1. Emergency UNIX and Linux Support

NIS created users without a home directory

Hi all, So I have created two Centos machines. One is configured as a NIS master and the second is a NIS cleint. The NIS configs are all working perfectly. I created a user nisuser on NIS Master and I can use it on the client. BUT it doesnt show a home directory . Ive been told there is... (9 Replies)
Discussion started by: Junaid Subhani
9 Replies

2. UNIX for Dummies Questions & Answers

User's home directory not being created

I am trying to create Oracle user. I will install oracle after that. But my problem is /home/oracle directory is not being created. bash-3.2# useradd -g oinstall -G dba,oper -d /home/oracle -m oracle cp: /home/oracle: Operation not applicable chown: /home/oracle: No such file or directory ... (3 Replies)
Discussion started by: hubatuwang
3 Replies

3. Solaris

useradd: ERROR: Path must not start with '/home/'.

root@solaris11express:/home# useradd -d /home/oracle oracle UX: useradd: ERROR: Path must not start with '/home/'. and the user oracle is not being created... (2 Replies)
Discussion started by: kompcouk
2 Replies

4. HP-UX

Home directories in packages

Hi, At my new company they use HP-UX on all the servers. They use Serviceguard to provide different packages, which are treated as if they where seperate systems. Therefore people log into packages instead of Host, and even the home directories live in the package. Now there are a different... (4 Replies)
Discussion started by: michas
4 Replies

5. Shell Programming and Scripting

Find directories only and delete them created 3 days before

Hello I have some directories and files created under /export/local/user I would like to delete directories only under /export/local/user, created before 3 days Can someone help me with command to do this task? Thanks (4 Replies)
Discussion started by: needyourhelp10
4 Replies

6. UNIX for Dummies Questions & Answers

UNIX home directories

Hi All, Could someone help, am a complete beginner when it comes to UNIX. However I have been tasked with investigating automatic creation of UK unix home directories. Is someone able to help? Thanks in advance! (7 Replies)
Discussion started by: zainster
7 Replies

7. Programming

opendir() + customly created directories

Gday all In a program I am designing, I am using opendir() to test whether entries under a certain directory are sub-directories or not. This method works fine for the directory itself (.) and the parent directory (..), however it does not work for any sub-directories I manually create. i.e.... (5 Replies)
Discussion started by: JamesGoh
5 Replies

8. Solaris

How to backup /home directories?

I know that how to backup the home directories in sun sparc server. Firstly, umount the filesystem, Secondly, fsck the filesystem, Thirdly, ufsdump the filesystem. Anybody know how to type the full command line backup the /home directory? (1 Reply)
Discussion started by: kingsan
1 Replies

9. UNIX for Dummies Questions & Answers

Files still being created in /var/spool/mmdf/lock/home

Hi all I need help finding a process that is continuing to create files in the above area. There are three sub folder titled addr q.local and msg . I have already found a process called mmdf running and have used the kill command to stop this from running. I have also looked for sendmail or... (12 Replies)
Discussion started by: TeaMaker
12 Replies

10. UNIX for Dummies Questions & Answers

Delete old home directories

I have a script that deletes obselete users from /etc/passwd then moves their home directories to another location. After 30 days, I need to delete the home directories that were moved to the new location. I would appreciate any ideas on how to delete the directories after the 30 days? (2 Replies)
Discussion started by: munch
2 Replies

Featured Tech Videos