Visit Our UNIX and Linux User Community


Printing Problems


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Printing Problems
# 1  
Old 07-06-2001
Printing Problems

I have a problem here. I have a printer that is connected to a silicon graphics O2 machine (a Laser Jet 6MP) which is running under the Laser Jet 6 printer driver. I don't have any problems printing from the UNIX box. However, I do have the printer networked through our local intranet (using LPR command in the windows 2000 interface).

My problem is this. I can print text just fine, however, when I try and print graphics, I get the following error.

"Printer Laserjet could not print file '/usr/spool/lp/request/Laserjet/d0-145'
Fileconvert could not convert this file of type 'BinaryDataFile' to a printable format.

Please help. Is there something that I can do to get graphics to print on the laser printer from my windows machine? Thanks.

-bobmcgee
:: email removed ::

Last edited by oombera; 02-13-2004 at 01:27 PM..
# 2  
Old 07-06-2001
Hi,

Have you considered setting up a samba server printer share on your Unix machine?

With Samba you can store the windows printer drivers on the unix server so when windows users print the printing goes through the windows drivers.

I'm not sure but this may alleviate your problem with printing graphics, other than that you could try the new CUPS printing system.

Andy Hibbins Smilie
# 3  
Old 07-20-2002
this is an answer and question:
A: Theoretically, if it's not necessary to print directly from the unix box, you should be able to shove the binary Windows driver output unaltered from your windows client to the printer on the Unix box using a samba share. Although i've been researching this, I haven't yet been successful due to an access problem.

My Question: My problem is a security issue. I can see my file samba shares fine, but with my printer, I get "Access Denied" on my Win2K client. I tried putting an entry in /etc/printcap (printcap.local), and in the smb.conf file putting "print command = lpr ...", security = user (same as my file shares) and security = share. I also have "public = yes" "browseable = yes" "printable = yes" and "writeable = no".
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #455
Difficulty: Medium
Java was originally developed at Oracle starting in December 1990.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Perl - Problems iwith colors while printing from dynamic array at runtime..

Hi Perl folks, I am having problems printing elements from an array at runtime. I wish to push elements into array at runtime and the print it later. Now I wish to print this matrix using colors. So I do something like this to enter the runtime values in array: ... (1 Reply)
Discussion started by: som.nitk
1 Replies

2. AIX

printing problems...

hello... we have just recently purchased an ibm h80 system to replace our old machine. the new machine is running aix 5.2 and yesterday i had just completed installing all the remote printers that are connected to windows 2k pc's. today i tried to send a print job to one of them and nothing... (1 Reply)
Discussion started by: petrofyed
1 Replies

3. UNIX for Dummies Questions & Answers

Printing problems

Hi, the print spooler from my unix box keeps putting a header before every page, looks as below User: root Host: blemain.blemain.local Class: blemain.blemain.local Job: SPC075 then it forces the rest of the print to spread accross 2 pages (should be single page prints). Any idea... (0 Replies)
Discussion started by: blemainuser
0 Replies

4. Linux

Printing Problems..

Dear All.. When printing(Epson DotMatrix 9pinX136Cols) an graphics(Graphics2D) document through my Java application, the printer simply take a round and drop the paper out. Nothing printed is it my printer driver(currently using omni driver) problem. Any one of you pls suggest me the suitable... (0 Replies)
Discussion started by: arunize
0 Replies

5. UNIX for Dummies Questions & Answers

lpq, lpr and printing problems

good day! i would just like to ask for advice regarding an lp problem i have.. we currently migrated a GIS appl from sol 2.6 to sol 8 but maintained the same version of jetadmin (for the appl plotters and printers). we are able to print files on a printer but not on a plotter. the... (1 Reply)
Discussion started by: maria_iris
1 Replies

6. UNIX for Dummies Questions & Answers

Printing problems

I am not able to print plain text in a correct manner. When I issue the command "lp -ddestination_printer myfile.txt" the printer prints a page with the following contents: Feb 24 11:26 2005 myfile.txt Page 1 ## Configured using SAM by root on Tue The line beginning... (3 Replies)
Discussion started by: ascanestro
3 Replies

7. SCO

Printing Problems with SCO 5.0

I have several printers setup but nothing prints. I get the following error email Subject: Status of lp request aclj3-2297 Your request aclj3-2297 destined for aclj3 encountered an error while printing on printer aclj3. Reason for failure: cat: cannot open 0: No such file or... (1 Reply)
Discussion started by: Jessie Nand
1 Replies

8. Solaris

emulation problems printing from sun solaris

Genicom LG05 printer with LG emulation. Due to problems with printer a replacement printer was installed with LP+ emulation only. Does the queue on UNIX have to be modified or told about the change in emulation for it to print from sun solaris unix. What's the command? (0 Replies)
Discussion started by: ITBT
0 Replies

9. UNIX for Advanced & Expert Users

Printing Problems in unix ... ( Bar-cdoe - Ip Printing)

Hi guys ... i need ur help with some printing problem in unix ... first prob. : i wanna print from my NCR unix to an Win NT , Ip based printing server ( HP JetDirect ) . My issue , is it possible to print directly to an Ip address from unix ? How do i make it work to get any results ?... (3 Replies)
Discussion started by: QuickSilver
3 Replies

10. UNIX for Dummies Questions & Answers

Printing via SCO Unix problems ;-(

I get the following when printing from a SCO Unix application { Who are you ?} The user is printing to a printer on a network print sharing device HP 500x. I think this printer is shared via the Unix machine. How does one set up printer sharing on Unix and access permissions for them? ... (2 Replies)
Discussion started by: JoseHose
2 Replies

Featured Tech Videos