ssh login and auth errors

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers ssh login and auth errors
# 1  
Old 08-14-2009
Question ssh login and auth errors

Hi folks, I'm having some rather odd trouble with ssh. It all started when I tried to create rsa public/private keys to login to a remote ssh account. The account is on a university server and the address redirects to several different machines so (following their wiki instructions...sigh) I executed this on my local (my os is Ubuntu "hardy" btw):
echo "StrictHostKeyChecking=no">>~/.ssh/config

Logged in and everything seemed fine. Logged out and (again following their advice) issued this command to create the rsa key pair:
ssh-keygen -t rsa

The id_rsa and were created and the next step was to send the key to the remote linux account:
scp ~/.ssh/

Something about this command didn't quite look right, however i ran it anyway, trusting their wisdom over mine. The gnome keyring popped up and prompted me for the passphrase to unlock my key. I entered it, then on the terminal I was prompted for my remote account password. Entered it...but, uh-oh, the "password:" prompt reappeared as if my password was wrong?! I know without a shadow of a doubt that I entered all the necessary passwords correctly.
So, now very curious (and confused and frustrated) I force quit the terminal, restarted it and tried to ssh to my remote account again:
The RSA host key for <> has changed,
and the key for the according IP address <>
is unknown. This could either mean that
DNS SPOOFING is happening or the IP address for the host
and its host key have changed at the same time.
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
Please contact your system administrator.
Add correct host key in /home/me/.ssh/known_hosts to get rid of this message.
Offending key in /home/me/.ssh/known_hosts:1
Password authentication is disabled to avoid man-in-the-middle attacks.
Keyboard-interactive authentication is disabled to avoid man-in-the-middle attacks.
Permission denied (publickey,password,hostbased).

My known_hosts file has 2 [1] entries by the way so this error message didn't really help me! I've tried removing both entries individually with no luck. I tried numerous things but to no avail. I found that wiping the contents of /.ssh would (usually) put me back to square one but even then, I can only login once through ssh. The second time I usually get a message similar to the above except with this at the end instead:
Permission denied (publickey,keyboard-interactive,hostbased).

I'm baffled! Is there a problem with my ssh configuation? ssh keys? am i using the wrong commands? Sometimes typing my (correct!) password won't even log me in so I'm thinking there might be a problem with the university's ssh configuration. (It's worth pointing out that I have no problem logging in through ftp) Any ideas?
# 2  
Old 08-14-2009
What does your ssh command look like?
# 3  
Old 08-14-2009
Originally Posted by daytripper
My known_hosts file has 2 [1] entries by the way so this error message didn't really help me!
It has two first lines?
# 4  
Old 08-15-2009
What does your ssh command look like?
The commands i used were the one's listed in my original post if that's what you mean.

It has two first lines?
Well no, but i assumed the 1 that the error was referring to (aka "The offending key") was the entry in my known_hosts that started [1] my case there are two blocks, both starting with [1]. How do I know which one to remove? Or am I completely misinterpreting the way ssh works? Mind you, I don't have much experience with/understanding of ssh. So if anyone has more concise steps to creating an ssh key pair to do password-less login to my remote server, please enlighten me. Taking advice from my university's wiki could be the real problem! Smilie ...but really, they probably just didn't explain it clearly enough.
# 5  
Old 08-15-2009
You can remove both entries in known_hosts. They'll get re-populated when you connect to other servers.

There is an obvious error in the third command you typed. You need to put your pub key inside your home directory's ssh folder, and it needs to be in a specific file. If the school's server is using openSSH, you should add your key to ~/.ssh/authorized_keys . If the school's server is using a commercial ssh, then you may have to convert your pub key to their format.

Anyway, let's start from the top. You said that, if you remove all the contents from your .ssh folder, you can ssh to the schools server. So, go ahead and do that, and try to log in and log out the server a couple times just to make sure your login and password work. If you wiped everything off your .ssh directory, you should get a message asking you if you want to accept the server's public key, which should populate .ssh/known_hosts with one entry. While you are there, check to see if you have a .ssh directory inside your home directory, if you don't create one, give it 400 permissions
$ mkdir .ssh
$ chmod 400 .ssh

After you have established that you can ssh to the server and log in with your username and password, go ahead and create your key. The command below includes the -N flag. If you don't want to supply a passphrase every session, then -N "" will set your passphrase to nothing.
 ssh-keygen -t rsa -N ""

Now, you'll copy your to your home directory in the remote server. Again, assuming the school's server is using openSSH, you'll put your public key in authorized_keys.
scp ./ssh/

Now you should be able to ssh from your computer to the server. If you can't, then we'll need to know the error you received, and take it from there.

About StrictHostKeyChecking=no :
What this does, basically it allows the connection to continue even if you get back the error you posted, that the server pub key and what's in your known_hosts file doesn't match. It is possible that the school server's administrators change the key frequently for whatever reason, and that is why they instruct to add that line to your ssh config. I have that entry in my lab servers, but I don't know that I want to use it in production.
# 6  
Old 08-17-2009
Now I'm not sure what's going on. I just now read your post, System, and tried to login after clearing my known hosts and everything else in /.ssh, and the server won't accept my password. I don't understand this at all, because I can still login through ftp without any problems. But for some reason logging in through ssh doesn't accept my password. Does this mean their server is having a problem?

Also when I ftp'd to my account I tried to mkdir .ssh but it said
550 Make directory operation failed.

Thanks for the help, but I seem to have hit a brick wall.

Last edited by daytripper; 08-17-2009 at 04:03 AM.. Reason: own stupidity...
# 7  
Old 08-17-2009
It sounds like either the disk is out of space or you do not have write access to your own directories for some reason.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Ssh errors

hello all Happy New year I have an issue here whenever I want to ssh into a particular server I get this error message "Disconnected: NO supported authentication methoids available (server sent publickey) I was trying to copy the public key to another server so that I do not need nto... (7 Replies)
Discussion started by: DOkuwa
7 Replies

2. UNIX for Dummies Questions & Answers

SSH SSH encountered 1 errors during the transfer

This issue was resolved due to using the correct user transferring the file over to the desktop. (1 Reply)
Discussion started by: Computergal2104
1 Replies

3. HP-UX

telnet login successful ,but ssh can not login

why I can login by telnet using root account but when i use login by ssh using root account it is not successful ,is it different password i am sure ssh service is started (2 Replies)
Discussion started by: alert0919
2 Replies

4. AIX

ssh public key auth "Remote login for account is not allowed" ?

Hello, Using AIX 6.1 boxes. User user1 connects from box A to box B using ssh. When password authentication is used everything is fine. When I configure user1 to use public key authentication sftp client works fine(no password asked), but ssh client fails. This is sshd log: Accepted publickey... (3 Replies)
Discussion started by: vilius
3 Replies

5. Solaris

SCP & SSH errors

Hi I am trying to scp a file between to servers (both on same subnet and can see each other). However, whenever I try I get the following error: ssh: fatal: relocation error: file /usr/local/bin/ssh: symbol EVP_CIPHER_CTX_key_length: referenced symbol not found lost connection I... (4 Replies)
Discussion started by: skewbie
4 Replies

6. UNIX for Dummies Questions & Answers

ssh pub key auth - can some please guide me idiot proof

hello. can somebody please idiot proff simple guide me how to set up ssh public key authenciation? i am stuck, i tried long and googled a lot but i cant get it. thanks in advance. (4 Replies)
Discussion started by: scarfake
4 Replies

7. AIX

SSH + LDAP Auth Giving Fits

I'm having a bear of a time getting my LDAP connection going, so I hope someone here has some insight. I have AIX 5.3 running on an LPAR. I have ldap-client, ldap-max-crypto-client, gskak, and gskte installed. I'm able to set up the connection via mksecldap, and I can query users just fine... (1 Reply)
Discussion started by: AlexDeGruven
1 Replies

8. UNIX for Advanced & Expert Users

SSH errors

hellow Experts, I want to know that whenever i run ssh command, i get this error > ssh username@x.x.x.x ssh: connect to host x.x.x.x port 22: No route to host or connection refused i want to know the exact reason for these errors .. like because of firewall , no physical conection ,... (3 Replies)
Discussion started by: luckypower
3 Replies

9. HP-UX

X-server errors at login? I want to just get rid of this!

The CDE login manger may repeatedly scroll these error messages on the console: **************************************************************** * The X-server cannot be started on display <hostname>:0... * For details look into the file, Dtlogin.errorLogFile (default: *... (6 Replies)
Discussion started by: emplate
6 Replies

10. UNIX for Advanced & Expert Users

SSH Problem auth problem

Hi, Just recently we seem to be getting the following error message relating to SSH when we run the UNIX script in background mode: warning: You have no controlling tty. Cannot read confirmation.^M warning: Authentication failed.^M Disconnected; key exchange or algorithm negotiation... (1 Reply)
Discussion started by: budrito
1 Replies
Login or Register to Ask a Question