Visit Our UNIX and Linux User Community


Mounting a floppy disk in System V


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Mounting a floppy disk in System V
# 1  
Old 08-11-2009
Question Mounting a floppy disk in System V

Hello all! I just recently inherited a mid-90s gateway full tower system (Original Pentium, SIMM style RAM, etc.). I had always wanted to try an old version of UNIX, and having come across a copy of AT&T System V R4 decided that the time was ripe. There were 30 disks total, and after booting to the first disk and completing the 10 in the base package, it told me I could use pkgadd to install the additional packages, I assume from the other floppy disks.

To my question: how does one go about mounting a floppy disk in System V? I'm kind of a newbie having only used Linux for a couple of months on a newer computer, and I had never used floppy disks with that.

Running "mount /dev/fd0 /mnt" tells me that fd0 is not a device. I did some poking around and found something about floppy disk types on the internet, and looked in /dev/dsk. Running "cat /dev/dsk/f03ht" makes the drive light on the floppy drive light up, and runs coherent text accross the screen (too fast to read) but eventually turns to gibberish and it beeps at me. So the disk drive is recognized at least. But when I try to mount /dev/dsk/f03ht, it tells me that it is not an s5 filesystem. I am puzzled.

I know it would probably be easier to just install one of the newer BSDs etc., but I'm very interested in computing history. Thanks in advance to anyone who can help.
# 2  
Old 08-11-2009
It may be less smart than a more modern OS at autodetecting the correct type of filesystem. You might need to give it the -t option followed by the filesystem type. What SysV uses for floppies though, I have no idea...
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #878
Difficulty: Medium
Memory allocation is less critical in a real-time operating system (RTOS) than in other operating systems.
True or False?

10 More Discussions You Might Find Interesting

1. SCO

Emergency boot floppy - second hard disk not seen

OS = Openserver 5.0.5 Ran 'mkdev fd' and made emergency boot floppy (boot and root). Choose custom kernel, not generic. However kernel on the 1.44 floppy did not see both hard disks, it only saw the first one (SCSI id 0), and not SCSI id 1 (second disk) Q. Is this a limitation of emergency... (5 Replies)
Discussion started by: grips03
5 Replies

2. SCO

Floppy Disk not reading in cygwin

Hi, I have 3 floppy disc (SCO uniix) compressed files in it. I am in windows XP environment, installed cygwin; I tried to read these files and copy out but am not able to mount fd; it show is mount unknown type error; Please advise me how can i resolve.. Regards mfm2066 (1 Reply)
Discussion started by: mfm2006
1 Replies

3. SCO

mounting USB floppy drive /Flash drive in OSR 6.0

Can anybody help me out to mount USB flash /floppy drive in sco openserver 6.0 . (5 Replies)
Discussion started by: sureshdrajan
5 Replies

4. UNIX for Dummies Questions & Answers

configure floppy disk?

what are your next steps when you see: # mount /dev/fd0 /mnt mount: /dev/fd0 : Device not configured - please? yours` sehrguey (2 Replies)
Discussion started by: serguey
2 Replies

5. UNIX for Dummies Questions & Answers

how to copy file in cd or floppy disk

i am novice in unix. in me office my boss hav given me a system with Unix OS. i know about windows and Dos. in dos we access cd or floppy through writing following commands a: or d: copy filename.ext to a: i dont even now how to access CD Rom or floppy drive in unix. please tell... (1 Reply)
Discussion started by: fassi
1 Replies

6. SCO

Read a SCO floppy disk under another OS...

I have formatted a floppy disk under SCO unix. Is there a way I could read this disk under another operating system e.g. Windows or Linux? (1 Reply)
Discussion started by: sgertsos
1 Replies

7. Solaris

mounting floppy on x86 - help

hello from newbie :) i have a question : i've just installed sol-10 on x86 - and i cant access my floppy/cdrom. the device naming totally different from those in bsd or linux - where it was much more difficult to understand :( the mntab/vfstab - i know where it was pointing at - but from... (2 Replies)
Discussion started by: rossonieri#1
2 Replies

8. UNIX for Dummies Questions & Answers

How to duplicate a floppy disk

Hi there, I have a boot disk that I'd like to make a copy of. I can't just copy it through windows because windows obviously doesn't recognise the format. What would I have to do in SCO to just simply make a copy of this disk?? (0 Replies)
Discussion started by: zaphs
0 Replies

9. UNIX for Dummies Questions & Answers

Mounting a Floppy on System V

Hi, i want to mount a floppy disk device on a System V/68 Release R3V6 system because i want to copy some files from this Unix computer to a Win-98 based computer. I have logged in as "root" and used command line: mount /dev/f0ps2 /floppy (the "floppy folder" on the computer i'm working on is... (1 Reply)
Discussion started by: xtremexp
1 Replies

10. UNIX for Advanced & Expert Users

Floppy mounting

How can i mount a floppy drive manually ? ( when i run #volcheck and then run #df -lk , my floppy hasn't been mounted ,however my vold daemon is up ) under /dev there is some links related to my floppy (fd0 ,...)but actually which one of them should be used? Rgrds nikk:confused: (2 Replies)
Discussion started by: nikk
2 Replies

Featured Tech Videos