unable to login HELP!!!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers unable to login HELP!!!
# 1  
unable to login HELP!!!

Hi,
I have installed for the first time sun solaris on my pc and I am trying to learn unix.

I created a new user using the following steps:

-create a new group : groupadd work
-created a new user:
useradd -g work -d /export/home -s /usr/bin/ksh gbruno
(i checked the path of the shell using which ksh= /usr/bin/ksh)
-created a password: passwd gbruno( i have entered the password and than reentered)
-message says password succesfully created for user gbruno
-checked the entry in /etc/passwd and gbruno user is there.
-tried to loggin as gbruno : rlogin -l gbruno giuliano( giuliano is my host name)
-I am prompted to insert the password
-once the password is entered i get a message back saying No shell, connection closed.
-If I go to export/home and do ls -l gbruno it says that the owner is 104 and the group is other ( is this correct?).
I tried as per suggestions from uder user to do :
SHELL=statement and reboot in order to create a new shell authomatically.
I deleted old users who were showing the same error messages and created the above new one, but still the same..
What am i doing wrong?

Thanks for your help, I hope I can help somebody else one day..
Regards
Giuliano
# 2  
Try to use /bin/sh as your shell, this is the Bourne shell, the standard for Solaris. The korn shell is in /bin/ksh, though the standard solaris installation makes /bin a link to /usr/bin. If you omit the -s option the account will have the default Bourne shell.
# 3  
Run the command pwck and see if you get any errors displayed.
# 4  
This suggestion of mine won't solve your login problem but I noticed your useradd command. You should when creating a user set the home directory to /export/home/username - example
useradd -g work -d /export/home/gbruno -s /usr/bin/ksh gbruno

This way gbruno doesn't own /export/home when you create more users under there or that when you create more users, they don't 'steal' /export/home' from gbruno.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #260
Difficulty: Easy
Steve Jobs and Steve Wozniak co-founded Apple in 1976 to sell Wozniak's Apple I personal computer.
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Unable to login with any user

Hi Please I need help on trying to login on a solaris 10, blade server. login as: root Using keyboard-interactive authentication. Password: I even try a normal user, I do not get the prompt. I suspect the reason could be that /varis at 98% because I have configure email alerts to warn me... (9 Replies)
Discussion started by: fretagi
9 Replies

2. How to Post in the The UNIX and Linux Forums

Unable to see my threads when i login

Hello, Is there a way to display all of the posts I have authored? Many thanks in advance. (2 Replies)
Discussion started by: Anamika08
2 Replies

3. Red Hat

Unable to login after patching

Hello, Sorry for posting here..i know there is another section for Urgent...However, i could not locate it... Issue: ) After patching rhel 5.8 with couple of patches. When user is trying to login via putty . They get login promt and when they type their username, screen get freezed kindaa... (3 Replies)
Discussion started by: saurabh84g
3 Replies

4. Forum Support Area for Unregistered Users & Account Problems

Unable to login

Hi, It has been a while since I logged into Unix.com and I have forgotten my userID and password. Please help. Thanks, Ananth. (1 Reply)
Discussion started by: Unregistered
1 Replies

5. Solaris

unable to login Solaris 10

I have inherited a solaris 10 server. I went to log into it the other day over the console connection, and after sucessfully entering the password, I was booted back to the login prompt with no errors visible. If I enter an incorect password, the console displays 'incorrect password' and kicks... (8 Replies)
Discussion started by: Sol-nova
8 Replies

6. Solaris

Unable to login

Hi, I am doing Active Directory(Win 2008) and UNIX(Solaris 10) integration. I was unable to create home directory for the Active Directory users on the first login. So i added other session required pam_mkhomedir.so skel=/etc/skel umask=0022 to pam.conf in /etc/pam.conf. But now I am... (2 Replies)
Discussion started by: sathya47
2 Replies

7. UNIX for Dummies Questions & Answers

AIX Unable to Login

Was OK on AIX5.2. Have installed AIX 5.3 ML02 and now only root can log in. Other users get "You are not allowed to login at this time." Once in as root, it's possible to su or 'su -' to other users. All user parameters are OK. (0 Replies)
Discussion started by: skinthegoat
0 Replies

8. Forum Support Area for Unregistered Users & Account Problems

Unable to login

Hi Admin/Moderator, I am unable to login with my user id "chanakyahere", even it is not accepting my mail id to which i got one reply aso.. it is saying that i suppied "mail id that is not recognised".. please look forward regarding this problem.. i joined on last saturday i.e on... (1 Reply)
Discussion started by: Chanakya
1 Replies

9. UNIX for Dummies Questions & Answers

Unable to get a login shell

I have started using SunOS 5.6 as an administrator. By mistake I changed the default shell entry for root in /etc/passwd file to /bin/ksh. Since there is no such shell available in the bin directory, I am not able to log on to the system.(This happens even in the console) The error is - no... (2 Replies)
Discussion started by: pradeepks
2 Replies

Featured Tech Videos