please help with openbsd 2.9

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers please help with openbsd 2.9
# 1  
Old 06-22-2001
please help with openbsd 2.9

Please help. I have downloaded the openbsd 2.9 snapshot from the following files were downloaded from the snapshot dir. ( the whole dir. was downloaded ) base29,bsd,bsd.rd,cdrom29.fs,cksum,comp29,etc29,all three floppy images,game29,index,install.ata,install.chs install.dbr,install.i386,install.linux,install.mbr install.os,,man29,md5,misc29,xbase29,xfont29,xserv29 and xshare29. I burned them to cdrom. i created my floppy29.fs boot image. The hard disk is clean with no partitions at this point. i was able to boot from the floppy and set the entire machine up perfectly. Everything works even network card and xserver. The problem i am having is being able to execute packages that were added via- pkg add. The packages state in -v mode that all went well and was registered. the added package will show up if i do a pkg info, however i can not get one single package to execute and the same error is given for all packages. Here is the error and xxx is the app.

/usr/libexec/ xxx: No such file or directory.

for example i installed joe the editor.
pkg add -v joe-2.8p1.tgz all was extracted and registered. I am logged in as root when i install the packages and when i try to call them. When i am @ / logged in as root and type joe the above message is displayed. i installed 9menu to and when i call the app 9menu the exact same message is displayed.
/usr/libexec/ 9menu: No such file or directory.

this has been the case with all installed packages. all other commands ( ping, traceroute, halt etc... ) work fine it is just all apps added after the original install. the computer is: compaq professional workstation ap400, 6gig ata/66 hd, 128meg ram, elsa synergy video card, pent!! 450. please explain what i have done wrong and steps to fix it.

thanks for your kindness. Smilie have a great day.

# 2  
Old 06-22-2001
You must check your shared lib directory (directories) for the version of in the directory (and the symbolic link to the current version). Please find the file and the symbolic link and post it so we can see what is going on.
# 3  
Old 06-22-2001
Ok, thanks. would you mind explaining how to do the above. i am new to unix and need details and steps. what is a symbolic link and how do i find and read it.

thanks neo!!!!!
# 4  
Old 06-23-2001
You can try two diff ways

1) ln -s `locate` /usr/lib/

this will locate then create a sym link in /usr/lib.

2) Or add the path where "" resides by editing /etc/rc.conf (shlib_dirs= /path to/new lib )

this will add those path into 'rc.conf' file which specifies additional default directories (beyond the standard set) to be scanned by 'ldconfig' for shared libraries to include in the hints file used by the run-time linker '/usr/libexec/' this is usefull if you have lots of shared libs in that dir.

In linux we do this by editing '/etc/'


# 5  
Old 06-23-2001
# 6  
Old 06-23-2001
-rwxr-xr-x   1 root     root         7736 Mar 21  2000*
lrwxrwxrwx   1 root     root           16 Aug 19  1994 ->*

The example above is from my /lib directory on one of my servers. Notice that the shared library file is, which was the current version when I did my installation. It might be libutil-2.1.5 now (for all I know Smilie ) because shared lib (like all dynamic code) changes frequently to add features and to fix bugs in the code.<P>
However, all code that used the shared library must have a symbol or token to represent the library, this is normally something like Normally will work in code designed for (but not always!). <P>
So, when you install a new library, for example libutil-3.1.1 you must create a symbolic link (as required). In the example above, you might do an:

ln -sf

This might not be enough, because newer code might look for the token !! So, you also must do:

ln -sf

Which creates another symbolic link, as required. <P>
<A HREF=>'what is a symbolic link?' (the question) was discussed here</A>
Fixed typo (thanks MIB!)
# 7  
Old 06-23-2001
You guys are awesome. Thanks for taking time from your schedule to help me, I appreciate it very much. Like I said Unix is new to me. I picked up a copy of slackware 5mo. ago just to see what this UNIX stuff was all about. I dont know why but for some reason The Dark Side just sucked me in. I bought a copy of Unix In A Nutshell 3RD edition but sometimes when you just dont understand what to look for you need to ask somebody for answers. I know some of my questions are stupid and elementary and I ask that you please forgive my ignorance on the subject and have patience as I try to grow.

find / -name -print ---> returns nothing.
ln -s `locate` /usr/lib/ ----> returns nothing

I can find other files just fine so i know the find command is working. The files appears to not be there, but why would a snapshot not contain a critical file needed by the system seeing how a snapshot is just a recompiled version of the general release with errata applied? How to I get this file and apply it or do i have to format and start over with a different build?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. BSD

OpenBSD pf problems

I am having troubles with this pf configuration, it seems when loaded nothing can access my server on the internal interface for the LAN, I cannot see why, and it's pretty much based off the very standard example in the OpenBSD faq. When I unload the configuration, I can access the DNS server on... (0 Replies)
Discussion started by: John Tate
0 Replies

2. BSD


hello , I wondered if anyone could assist me in writing a simple packet filter firewall on my OpenBSD v4.5. All I intend doing is to have two firewalling machine on a separate network : ext_if = xl0 (dhcp) // Internet interface int_if=xl1 // Internatl interface ... (0 Replies)
Discussion started by: mattjam
0 Replies

3. BSD

Trying to get into OpenBSD

I am an eight year Linux user and after getting into an argument with someone about OpenBSD overiding my theory that OS security is 50% OS and 50% admin skill, I decided to try OpenBSD for myself. I've tried BSDs before and haven't been able to get into them for day to dy use, but I am going to... (7 Replies)
Discussion started by: deckard
7 Replies

4. BSD

RAIDing openbsd 4.2

Hello! Can anyone tell me how to make software RAID1 on openbsd 4.2. I try by some manuals but have no results.Maybe is somewhere good manual directly to openbsd 4.2 version? tnx (1 Reply)
Discussion started by: kasparens
1 Replies

5. BSD

OpenBSD and wireless

I've just installed OpenBSD on my laptop (IBM Thinkpad T42) and since this is my first time with wireless networking in OpenBSD I'm a bit lost. What I would like to do is connect to a wireless network using WEP or WPA. Where do I place the key and essid? (3 Replies)
Discussion started by: Timmy66
3 Replies

6. BSD

setting up OpenBSD 4.0

ok these questions may be a little silly but I just started using OpenBSD as I came from Linux... 1. How do I make my desktop in X all snazzy like, I have wallpapers that need to be used. while I admit it will mainly be used for things I wont need a wallpaper for, you just never know :p, im... (4 Replies)
Discussion started by: Siphter
4 Replies

7. BSD

OpenBSD security

OpenBSD is best OS in the world! - I'm talking about security :) After 10 years popularity in OpenBSD, was founded just!!!!!!!!!!!!! just one security hole! You can download OpenBSD from there . However, do you know a better OS? (1 Reply)
Discussion started by: zylwyz
1 Replies

8. BSD

openbsd : cannot login

hi OK. I don't know exactly what I did to system! The system is OpenBSD 3.5. It is 200MMX, 16MB ram 1.2 + 2.4 GB HDD. The system was running well. But a few days ago I try to unpack a big tar.gz file and the system uses most the cpu and ram for this. While the system unpacking the file I try to... (4 Replies)
Discussion started by: fnoyan
4 Replies

9. BSD

Snort on openbsd

Im trying to gather some info to set up snort on openbsd 3.2, has anyone out there managed to get it up and running ? My initial attempts seem to be quite below par (4 Replies)
Discussion started by: malcontent
4 Replies

10. Filesystems, Disks and Memory

Maxtor vs. OpenBSD

Can't setup OpenBSD 3.4 with Maxtor Diamond Plus 9 80Gb ATA/133 HDD... Install process stops at hardware initialize, before installing... :confused: Any Comments... Thanks (2 Replies)
Discussion started by: bsdave
2 Replies
Login or Register to Ask a Question