Visit The New, Modern Unix Linux Community

LENOVO ThinkPad T580 is crashing on Ubuntu 18.04

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers LENOVO ThinkPad T580 is crashing on Ubuntu 18.04
# 1  
LENOVO ThinkPad T580 is crashing on Ubuntu 18.04

My LENOVO ThinkPad T580 is crashing on Ubuntu 18.04. The crashes are seemingly happening at random. I tried running the following command as specified by this SO post:
sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

However, that did not work the system is still crashing. If I were to charictorize the crash I would say everything just stops. The system does not shutdown but everything freezes and I am forced to hard restart the computer by holding down the power button. The laptob was originally simply a windows 10 machine. However, I decided to make it a duel-boot windows/ubuntu machine so that I can take my work home with me. That being said, until I can figure out and eliminate this crashing problem I won't be doing any work on it.

I am not sure if Linux logs crashes like this. If anyone knows how to help or if they need more information please ask/tell me how to get the information you are looking for. Here is some basic system info on the machine:
System:    Host: --- Kernel: 5.0.0-32-generic x86_64 bits: 64 Desktop: Gnome 3.28.4            Distro: Ubuntu 18.04.3 LTS Machine:   Device: laptop System: LENOVO product: 20L9CTO1WW v: ThinkPad T580 serial: N/A            Mobo: LENOVO model: 20L9CTO1WW v: SDK0J40697 WIN serial: N/A            UEFI: LENOVO v: N27ET27W (1.13 ) date: 07/04/2018 Battery    BAT0: charge: 33.3 Wh 100.1% condition: 33.3/32.0 Wh (104%)            BAT1: charge: 20.9 Wh 94.9% condition: 22.0/23.9 Wh (92%) CPU:       Quad core Intel Core i7-8550U (-MT-MCP-) cache: 8192 KB            clock speeds: max: 4000 MHz 1: 2394 MHz 2: 2400 MHz 3: 2400 MHz 4: 2400 MHz 5: 2400 MHz 6: 2400 MHz            7: 2400 MHz 8: 2400 MHz Graphics:  Card: Intel UHD Graphics 620            Display Server: x11 (X.Org 1.20.4 ) driver: i915 Resolution: 1920x1080@59.98hz, 1920x1200@59.95hz            OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) version: 4.5 Mesa 19.0.8 Audio:     Card-1 Intel Sunrise Point-LP HD Audio driver: snd_hda_intel Sound: ALSA v: k5.0.0-32-generic            Card-2 Lenovo driver: USB Audio Drives:    HDD Total Size: 512.1GB (9.5% used)            ID-1: /dev/nvme0n1 model: SAMSUNG_MZVLB512HAJQ size: 512.1GB Partition: ID-1: / size: 229G used: 46G (21%) fs: ext4 dev: /dev/nvme0n1p5 RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present Sensors:   System Temperatures: cpu: 44.0C mobo: N/A            Fan Speeds (in rpm): cpu: 0 Info:      Processes: 319 Uptime: 2 days Memory: 1374.5/7836.2MB Client: Shell (bash) inxi: 2.3.56

# 2  
Did you search your filesystem for core files?
# 3  
Yes, well, Lenovo has had all sorts of issues with Ubuntu concerning their BIOS and graphics chipset. On some Ubuntu distributions, the way the kernel was compiled was known to corrupt the BIOS on Lenovo's. However, I think that was on Ubuntu 17 and has now been fixed, but who knows.

Have you tried running Ubuntu 18.04 live? Does that still hang?

Try Ubuntu 18.04 with an external monitor attached to check whether it's the T580 display that it doesn't like.

The T580 was certified at Ubuntu version 16.04 LTS. You could try installing that just to see what happens and verify your hardware.
Ref: Ubuntu on Lenovo ThinkPad T580 | Ubuntu

Oh, and you could just try changing any graphics adapter settings in the BIOS (e.g. display memory shadowing on/off and the like).

Last edited by hicksd8; 11-12-2019 at 06:40 AM..
This User Gave Thanks to hicksd8 For This Post:
# 4  
Originally Posted by Neo
Did you search your filesystem for core files?

I am not sure what I am looking for. I am in the drivers directory now: @/lib/modules/5.0.0-32-generic/kernel/drivers. Should I be looking for graphics drivers? Perhaps I am misinterpreting your question?

@hicksd8 I am not sure what Ubuntu 18.04 live is. I will run the labtop on an external monitor today and see how that goes. If I were to try changing graphics adapter settings; are there any settings that you would recommend specifically?

Edit: Just a note. I went to: settings->details and clicked "Check for updates" and two system updates were downloaded. I restarted the computer and it went through a hardware update. I am not sure if that has fixed the problem but I will let you guys know if it does. Currently I have another monitor hooked up to the labtop and I am running it in mirror mode.

Last edited by Circuits; 11-12-2019 at 12:26 PM..
# 5  
The hardware updates did not fix the problem, the labtop froze again. I had another monitor setup in mirror mode and the screen simply went black when the labtop froze. I will attempt to setup the monitor s/t it is the only/primary display for the labtop.
# 6  
'live' running is when you boot from CD/DVD and let it run from that media. Sometimes the Linux media for hard disk install and 'live' is the same media; sometimes you have to download a separate ISO for the 'live' CD/DVD. However, when running 'live' you can do most things. It would be interesting to know whether it still hangs under those conditions.

Also, as I said, Lenovo hardware can have problems with Ubuntu kernel's so I would suggest that you try Ubuntu 16.04 LTS and see if it still hangs. If not, then I would suggest that your hardware is not faulty because Ubuntu 16.04 LTS is fully certified on the Lenovo T580.
# 7  
@hicksd8 After checking with my superior running 16.04 with the new build system is not an option. It may be possible but he is concerned that I may introduce dependencies in the code for the 16.04 system that could break the build for people using 18.04. After trying to run the labtop with a different monitor as it's sole display it seems to have crashed again. However, this time the screen did not freeze instead it simply went dark. The computer sounds like it is still running/processing (I can hear it) but I can't see anything. Perhaps I can try messing around with graphics adapter settings.

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #350
Difficulty: Medium
AWK was originally written in 1975 and distributed with Version 6 Unix.
True or False?

9 More Discussions You Might Find Interesting

1. AIX

Lenovo v3700 v2 direct connect to AIX

i have directly connect AIX pwer 7 to lenovo v3700 v2 without San through fiber card. but i cannot see the WWPN to add AIX as host in management console. (10 Replies)
Discussion started by: khalid khanAIB
10 Replies

2. Solaris

Solaris flicker on lenovo laptop x230

hi I installled Solaris 11.3 on my Lenovo X230 with Intel HD Graphics 4000, trouble is the graphic driver doesn't play well with 11.3, on the right of the screen, it blinking/flashing/shifting and no colour (grey; see pic below). I try to reduce resolution to 1024*768, I can't reduce the... (8 Replies)
Discussion started by: van12
8 Replies

3. Red Hat

Need to configure my laptop Thinkpad - T430 as wifi hotspot

Hi All, I have a Thinkpad - T430, which is having the wireless card as "03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205". This one i need to configure as wifi hotspot. which i believe need to configure hostapd.conf, this kind of configuration is new to me anybody done... (1 Reply)
Discussion started by: linux.amrit
1 Replies

4. UNIX for Dummies Questions & Answers

How to type ^ (caret) on Lenovo laptop?

Hi how to type " ^ " symbol in unix .. i am using a lenovo laptop ^ matches start of line (2 Replies)
Discussion started by: manjiri sawant
2 Replies

5. Solaris

Installation of Solaris 10 on Thinkpad

Hi Folks! I use Solaris 10 on my desktop but would like to start using it on my laptop, which is a Thinkpad T400. I am moderately experienced in using Solaris but don't have much experience in installing it on anything other than my desktop. It seems I've managed to get it installed on the... (0 Replies)
Discussion started by: Salinger
0 Replies

6. Ubuntu

Ubuntu Lenovo Thinkpad E520-1143 Laptop

Is it possible to install Ubuntu 11.04 or Ubuntu 11.10 in Lenovo Thinkpad E520-1143 Now it Powerd By windowd Xp Professional is it possible to install Ubuntu in it and supports all drivers for ma laptop such as VGA driver Sound,Wireless,Lan , fingerprint,camera pls reply r is it possible to... (0 Replies)
Discussion started by: babinlonston
0 Replies

7. Ubuntu

Kubuntu on (certain) Lenovo laptops not possible - reasons?

Hi. I've used the Wubi install of Ubuntu and Kubuntu on my Windows XP machine for close to half a year now. My brother has let me know of a program where he works by which they're getting rid of (with support negated) several Lenovo laptops, on which, he also informs me, the K 'flavor' of Ubuntu... (1 Reply)
Discussion started by: SilversleevesX
1 Replies

8. UNIX for Dummies Questions & Answers

Thinkpad 390X Fn

I have in my possession an IBM Thinkpad 390X. I havebeen using word and lately a function delaing with the Fn button have created problems. It acts as if Fn is depressed though it is not. When I depress Fn I can type normally, the keys it affects are J,K,L,:,U,I,O,P,M,<,>,? Does anyone know how to... (0 Replies)
Discussion started by: Word
0 Replies

9. UNIX Desktop Questions & Answers

Help needed to configure GUI with Slackware 7 on an IBM Thinkpad Laptop

I am using Slackware 7 on my IBM Thinkpad. I am unable to configure it to display a graphical environment. Typing startx usually generates a few errors. The system, however, does boot into the shell environment without any issues or problems. I have been able to setup Slackware 7 successfully... (2 Replies)
Discussion started by: adrienb
2 Replies

Featured Tech Videos