No user able to login except root(superuser)

Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users No user able to login except root(superuser)
# 1  
Old 06-24-2002
No user able to login except root(superuser)

Hi All,
Oracle 8.0 database is running on SCO-UNIXWARE 7.0 Operating system. Some how ORACLLE DATABASE has crashed. After rebooting the PC only the SUPER USER could login. No other user is able to login.
we need ORACLE user to start the DATABASE again.
It is asking for the password, after entering the password it asks for the login again..
what could be the reason for other users could not login except root.
it is live database so would be thank full if any one can come and help me the same.
konda reddy
# 2  
Old 06-24-2002
DB tied to a user's login??? Yes/No???


First of all, Let me as a question. Do your users automaticaly establish a connection/thread to the DB when they login? I have seen this type of problem before. This could be the reason that they are getting kicked out. I have definitely seen this!!

I would suggest shutting down the DB, then reboot with the DB down. Then bring the DB back up after the box is fully up and running. Now try a login as a user.

I would also check to see if you login script, /etc/profile, user's profile, and /etc/passwd files are not corrupted. Move in a new copy of your /etc/passwd if the first suggestion doesn't work at the top.

Here are some other suggestions that may be helpful.

This may be the problem.

May not be since they can login but it keeps repeating.

Here is another doc that shows how to lock out users. It may be helpful.
# 3  
Old 06-25-2002
Dear Kelam_Magnus,
Thank you for your information.
The problem has been solved by resetting the permissions on the users login shell files i.e., /usr/bin/ksh, /u95/bin/share/ksh and /var/adm/shserv .
it was a great experince for me. i did the follwoing.
1. after ORACLE DATABASE crash, I logged in as ORACLE user and type the SVRMGRL , connected to the oracel internal and shutdown the database (this is the way we startup and shutdown the database through SVRMGR).
2. Took the backup (cold backup) of existing database files using shell script. In the shell script i have change mode command (chmod) to set some permissions. (This created the problem).
3. I restarted the PC , then i could not login as any except root.
su - login_name also did not work. I checked the home directories, /etc/passwd files, /etc/profiles, users .profiles, users previlages everything seems alright.
4. Today when i try to login from the remote machine it displayed can not exec /var/adm/shserv permission denied.
5. Started giving the permissions and later on it displaed no shell.
6. Reset the permissions for korn shell (ksh) including link files also. Root is working because for roor login shell is /sbin/sh. for this permissions are absolutely fine.
7. Finally i could loging as ORACLE and restored the backup and restarted the DATABASE today i am relax..

thank you for ur info once again..
hope we will meet again if any ...
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Only root could login Redhat and could not su other user

Anyone has met the error following:- 1. Only root could login Redhat 2. Trying su another user by root, the error will be su: warning: cannot change directory to /home/user: permission denied su: /bin/bash: permission denied 3. I have checked the permission of the folder given and even... (2 Replies)
Discussion started by: jc0616
2 Replies

2. Shell Programming and Scripting

How to Login as another user through Shell script from current user[Not Root]

Hi Every body, I would need a shell script program to login as different user and perform some copy commands in the script. example: Supppose ora_toms is the active user ora_toms should be able to run a script where user: ftptomsp pass: XXX should login through and run the commands ... (9 Replies)
Discussion started by: ujjwal27
9 Replies

3. Shell Programming and Scripting

login as root user

hello all, if we haven't set a password to root user, how can we login as root user in konsole by using su? is it necessary to set password for root to login as root user?how can we set password to root user? (6 Replies)
Discussion started by: aarathy
6 Replies

4. Solaris

Solaris superuser login

Hi! Can someone please tell me how to log-in to Solaris as a superuser or as a root? I have tried using "root" as a username, and my superuser password i had set in the terminal for the log-in password but it says "Roles can only be assumed by authorized users". "Permission denied." I'm... (1 Reply)
Discussion started by: CarlosP
1 Replies

5. UNIX for Dummies Questions & Answers

Can not login with root user

Hi folks. our developer had a root user and he changed some settings about root user. We have not known what he changed. There is an oracle user, we can login to oracle, no problem. But when we try to login to root user we are getting this error : $ su root Password: bash:... (9 Replies)
Discussion started by: futi
9 Replies

6. Debian

password less login to root from a user account

hello friends, one user is created named "user1" I login as "user1" . Now when i do "su -" to be root user I have to give password for root . Is there any way through which we can skip giving the password to root. i.e. user1@work:~$ su - Password: xxxxxx work:~$ I don't want that... (1 Reply)
Discussion started by: pradeepreddy
1 Replies

7. Solaris

Unable to login as a User or Root on one client

I am running 5.10 Generic_120011-14 Sunblade 1500 I have one client that was working fine in a training environment. Then this week the user is unable to login as the user that is created by default. The students do not have access to root to change system files or user accounts. This is... (11 Replies)
Discussion started by: deaconf19
11 Replies

8. Solaris

Am not able to login as a root User with telnet

Hi to All, I have configured telnet service in my server but am not able to login with root user in Linux Servers. For that what can i do ? Please help me Thanks in Advance. (1 Reply)
Discussion started by: Sharath Kumar
1 Replies

9. UNIX for Dummies Questions & Answers

How to give an ordinary user the superuser (root) ID which is 0

How to give an ordinary user the superuser (root) ID which is 0 (9 Replies)
Discussion started by: sharaola
9 Replies

10. HP-UX

CDE login Problem for root user only

Hi All, I m facing a problem that, i m not able to login as root user on cde on hp-ux 11.00, i can login as root on commond line as well as telnet. Thanks in Advance for help. Regards, Awadhesh (1 Reply)
Discussion started by: Awadhesh
1 Replies
Login or Register to Ask a Question